Zen Cart Logo
Forums / All Other Contributions/Addons / Site goes down when I try to activate customers testimonials!

Site goes down when I try to activate customers testimonials!

Locked

Views: 1,003

Results 1 to 9 of 9
This thread is locked. New replies are disabled.
19 Apr 2008, 3:02 AM
#1
guzj99 avatar

guzj99

New Zenner

Join Date:
Apr 2006
Posts:
10
Plugin Contributions:
0

Site goes down when I try to activate customers testimonials!

Hi,

I have a strange problem. It has lasted for months.
I am using zen-cart_1.3.8 and testimonial_manager_v1.4.4. And hosted on a VPS hosting account.

I have recieve tons of testimonials through testimonial manager.
I really appreciate the author who wrote this add-on. It really helped me a lot.

But there is one thing always confuses me.

When I started to try to activate a customer's testimonial (set its status on), my site always went down. Like 10 times I did that, my site might go down for 7 times.

And each time the site would return a blank page but it would get back to work in 1-2 minutes itself. And then if I continued to activate more testimonials, it worked well.
I called my hosting company, they said I must inform them when the problem happen again. While the problem is everytime, it only last 1-2 minutes. When it happen again, there is only 1-2 minutes for me to call them and let them to check the status. :(

Also the site might have the same problem in other situation, but testimonial manager thing reproduce the problem most times.

Do you have any clue what the problem is?

19 Apr 2008, 3:14 AM
#2
clydejones avatar

clydejones

Deceased

Join Date:
Nov 2005
Location:
Colorado Springs, CO USA
Posts:
7,017
Plugin Contributions:
12

Re: Site goes down when I try to activate customers testimonials!

guzj99:

Hi,

I have a strange problem. It has lasted for months.
I am using zen-cart_1.3.8 and testimonial_manager_v1.4.4. And hosted on a VPS hosting account.

I have recieve tons of testimonials through testimonial manager.
I really appreciate the author who wrote this add-on. It really helped me a lot.

But there is one thing always confuses me.

When I started to try to activate a customer's testimonial (set its status on), my site always went down. Like 10 times I did that, my site might go down for 7 times.

And each time the site would return a blank page but it would get back to work in 1-2 minutes itself. And then if I continued to activate more testimonials, it worked well.
I called my hosting company, they said I must inform them when the problem happen again. While the problem is everytime, it only last 1-2 minutes. When it happen again, there is only 1-2 minutes for me to call them and let them to check the status. :(

Also the site might have the same problem in other situation, but testimonial manager thing reproduce the problem most times.

Do you have any clue what the problem is?

This is the first I've heard about this type of problem so I really have no idea what the issue might be.

What other situations cause the problem?

do you get any type of error message?

19 Apr 2008, 3:29 AM
#3
guzj99 avatar

guzj99

New Zenner

Join Date:
Apr 2006
Posts:
10
Plugin Contributions:
0

Re: Site goes down when I try to activate customers testimonials!

No error message.
Just I might suddenly recieve blank page.
Then I trid to ping my domain. It responded well.

I can't tell other random situations. It always happened suddenly.

Does it sound like hosting problem?
I have no idea if my customers may encounter similar problem.
I will set up a site uptime monitor.

19 Apr 2008, 4:15 AM
#5
guzj99 avatar

guzj99

New Zenner

Join Date:
Apr 2006
Posts:
10
Plugin Contributions:
0

Re: Site goes down when I try to activate customers testimonials!

I checked 'Error log' in site cpanel.
It's full of 'File does not exist' messages. Can't see previous logs.
That's because 2 image files missed. I uploaded 2 blank image file to avoid this error log.

I will wait to see what error I may get next time.

Thanks for your help, I will keep this updated.

19 Apr 2008, 4:25 AM
#6
guzj99 avatar

guzj99

New Zenner

Join Date:
Apr 2006
Posts:
10
Plugin Contributions:
0

Re: Site goes down when I try to activate customers testimonials!

It happened again just now.
And I found no log in system error log through 'cpanel error log'.

:(

19 Apr 2008, 4:55 AM
#7
guzj99 avatar

guzj99

New Zenner

Join Date:
Apr 2006
Posts:
10
Plugin Contributions:
0

Re: Site goes down when I try to activate customers testimonials!

just updated testimonial manager to the latest version,

problem still exist!

I found I can reproduce the situation like this:

Stay away from my site for half an hour or more, then go to zen-cart admin area, and open 'tools-->testimonial manager '
Then click on any one testimonial list, I then will get a blank page suddenly.
And then wait about 1-2 minutes, I can open the site again, and am able to use the testimonial manager pretty well.

Then if I don't touch my site for another while and do the same thing as I said above, problem will occur again.

:(

19 Apr 2008, 4:58 AM
#8
yellow1912 avatar

yellow1912

Totally Zenned

Join Date:
Oct 2006
Posts:
5,422
Plugin Contributions:
0

Re: Site goes down when I try to activate customers testimonials!

Weird, but one possible problem I can think of: the mod somehow kills off the apache server or mysql server and forces it to restart. But why only on the first use? Pretty weird. One has to look inside this module code to figure out if there is any thing causes this, perhaps the author of this mod can help.

19 Apr 2008, 6:49 AM
#9
clydejones avatar

clydejones

Deceased

Join Date:
Nov 2005
Location:
Colorado Springs, CO USA
Posts:
7,017
Plugin Contributions:
12

Re: Site goes down when I try to activate customers testimonials!

yellow1912:

Weird, but one possible problem I can think of: the mod somehow kills off the apache server or mysql server and forces it to restart. But why only on the first use? Pretty weird. One has to look inside this module code to figure out if there is any thing causes this, perhaps the author of this mod can help.

This is the first instance of this type of problem being reported with the mod.

I have the mod installed on three of my own sites as well as running on my PC through xampp and have not been able to reproduce the described behavior.