Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Cannot install on Linux (premature end of script headers)

Cannot install on Linux (premature end of script headers)

Locked

Views: 1,603

Results 1 to 2 of 2
This thread is locked. New replies are disabled.
21 Apr 2008, 5:44 PM
#1
karma_lab avatar

karma_lab

Zen Follower

Join Date:
Apr 2008
Posts:
135
Plugin Contributions:
0

Cannot install on Linux (premature end of script headers)

Hi, I am having difficulty installing ZenCart 1.3.8a on a new web site host.

Linux, php 4.4.8, apache 1.3.41 (Unix)

I have unzipped the full install "zen-cart-v1.3.8a-full-fileset-12112007" into a directory on my site at public_html/store. As far as I can tell, I have done everything required in the initial steps of the installation instructions, setting permission on the various folders and files as requested.

When I get to the part about installation, and I enter the URL "www.mydomain.com/store/", I get a 500 Internal Server Error, and the Error Log for my site shows the following:

[Mon Apr 21 10:09:03 2008] [error] Premature end of script headers: /home/usr2001/public_html/store/index.php
SoftException in Application.cpp:238: File "/home/usr2001/public_html/store/index.php" is writeable by group

Entering "www.mydomain.com/store/zc_install/" results in the same error, and so does "www.mydomain.com/store/zc_install/index.php".

For what it's worth, my php.ini file is:

register_globals = Off

[Zend]
zend_optimizer.optimization_level=15
zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.2.6
zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.2.6
zend_optimizer.version=3.2.6
zend_extension = /usr/local/ioncube/ioncube_loader_lin_4.4.so

zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so

Any ideas would be appreciated....thanks.

21 Apr 2008, 7:52 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Cannot install on Linux (premature end of script headers)

karma-lab:

SoftException in Application.cpp:238: File "/home/usr2001/public_html/store/index.php" is writeable by group

You need to talk to your hosting company about the correct permissions levels to set on all your files. The error message is saying that the main file (and likely many others) is 'writable by group'. Your host should be able to tell you how to set/reset that appropriately on your server.