Forums / Upgrading from 1.3.x to 1.3.9 / Blank Home Page after Upgrade

Blank Home Page after Upgrade

Locked

Views: 2,398

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
23 Apr 2008, 4:30 PM
#1
ecm avatar

ecm

New Zenner

Join Date:
May 2005
Location:
Leicester, UK
Posts:
86
Plugin Contributions:
0

Blank Home Page after Upgrade

Hi People,
Have upgraded a site from 1.3.7 -> 1.3.8a due to recent problems with Paypal (they had a UK problem with IPN last week & this shop can no longer take credit card payments via PP since their 'fix').

Admin screens are all ok but the catalogue/home page is blank.

I've debugged the page & the debug log shows the following errors:

[23-Apr-2008 17:07:22] PHP Warning: main(includes/languages//index.php) [<a href='function.main'>function.main</a>]: failed to open stream: No such file or directory in /home/r/a/sitename/public_html/shop/index.php on line 42
[23-Apr-2008 17:07:22] PHP Warning: main(includes/languages//index.php) [<a href='function.main'>function.main</a>]: failed to open stream: No such file or directory in /home/r/a/sitename/public_html/shop/index.php on line 42
[23-Apr-2008 17:07:22] PHP Warning: main(includes/languages//index.php) [<a href='function.main'>function.main</a>]: failed to open stream: No such file or directory in /home/r/a/sitename/public_html/shop/index.php on line 42
[23-Apr-2008 17:07:22] PHP Fatal error: main() [<a href='function.require'>function.require</a>]: Failed opening required 'includes/languages//index.php' (include_path='.:/lib/php') in /home/r/a/sitename/public_html/shop/index.php on line 42

The "main(includes/languages//index.php) " points to a path problem, So, I've checked my config file in inludes/ & its like this:

// Define the webserver and path parameters
// HTTP_SERVER is your Main webserver: eg, http://www.yourdomain.com
// HTTPS_SERVER is your Secure webserver: eg, https://www.yourdomain.com
define('HTTP_SERVER', 'http://www.sitename.co.uk');
define('HTTPS_SERVER', 'https://www.sitename.co.uk');

// Use secure webserver for checkout procedure?
define('ENABLE_SSL', 'true');

// NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes!
// * DIR_WS_* = Webserver directories (virtual/URL)
// these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder)
define('DIR_WS_CATALOG', '/shop/');
define('DIR_WS_HTTPS_CATALOG', '/shop/');

define('DIR_WS_IMAGES', 'images/');
define('DIR_WS_INCLUDES', 'includes/');
define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/');
define('DIR_WS_TEMPLATES', DIR_WS_INCLUDES . 'templates/');

define('DIR_WS_PHPBB', '/');

// * DIR_FS_* = Filesystem directories (local/physical)
//the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/
define('DIR_FS_CATALOG', '/domains/r/a/sitename.co.uk/public_html/shop/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');
define('DIR_WS_UPLOADS', DIR_WS_IMAGES . 'uploads/');
define('DIR_FS_UPLOADS', DIR_FS_CATALOG . DIR_WS_UPLOADS);
define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/');

...

define('SQL_CACHE_METHOD', 'file');
define('DIR_FS_SQL_CACHE', '/domains/r/a/sitename.co.uk/public_html/shop/cache');

There doesn't seem any obvious issue with trailing /'s etc?
I've also considered it might be my template so I'm running the classic but without any success.

This is a shop for a children's charity & they are obviously losing money while it's offline, so any help would be much appreciated.

Eddie

23 Apr 2008, 5:31 PM
#2
ecm avatar

ecm

New Zenner

Join Date:
May 2005
Location:
Leicester, UK
Posts:
86
Plugin Contributions:
0

Re: Blank Home Page after Upgrade

UPDATE

Partial success - I reloaded index.php and the other root level files & the catalogue page now displays.

I'm not sure why I decided to reload them or why this would have worked - could it have been a browser cache issue?

The only issue now is that New Products shows 2x product title. I'm off to search the forums for a fix for this one.

Thanks,
Eddie

23 Apr 2008, 5:39 PM
#3
ecm avatar

ecm

New Zenner

Join Date:
May 2005
Location:
Leicester, UK
Posts:
86
Plugin Contributions:
0

Re: Blank Home Page after Upgrade

UPDATE on the update.

The double title display on the new products was actually the img alt tag - the images hadn't been copied over from the old install to the new install!!!!!!!

Sorry!

So it looks like this can be tagged as resolved - have even got a test order thro Paypal using a credit card. Yippeee!

Eddie