Zen Cart Logo
Forums / PayPal Express Checkout support / Having a Failure on both IPN and Paypal express with Zen 138

Having a Failure on both IPN and Paypal express with Zen 138

Locked

Views: 1,966

Results 1 to 4 of 4
This thread is locked. New replies are disabled.
20 May 2008, 7:21 AM
#1
tbokich avatar

tbokich

New Zenner

Join Date:
Aug 2007
Posts:
64
Plugin Contributions:
0

Having a Failure on both IPN and Paypal express with Zen 138

Hi
We brought the update of the Zen 138 online and have a failure of both paypal express check out and IPN. The API credential are set and everything was working fine in the former version of Zen cart. authorized currencies are
Australian Dollar AUD
Canadian Dollar CAD
Euro EUR
GB Pound GBP
US Dollar (default)

When you hit the express check out button you get
Forbidden
You don't have permission to access /new138/ipn_main_handler.php.html on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.41 Server at makupartist.com Port 443

I have zen cart sitting in a folder with a static html page out front on the main for SEO purposes but all the item links go to the pages sitting in the new138 folder

When you go through check out you get two paypal choices that say
Save time. Check out securely.
Pay without sharing your financial information.
And the second one:
Checkout with PayPal. The safer, easier way to pay.

if you confirm the order it does take you to the paypal page but only to your account page with no set up for payment.

I have the logs and mail turned on for debug but it is not sending any logs. I have removed the payment module and reinstalled it but no change. The site is https://www.makupartist.com if you want to play with it. Drop me a note if you have any ideas
Thanks much
Todd

20 May 2008, 5:48 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Having a Failure on both IPN and Paypal express with Zen 138

tbokich:

When you hit the express check out button you get
Forbidden
You don't have permission to access /new138/ipn_main_handler.php.html on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.41 Server at makupartist.com Port 443

I have zen cart sitting in a folder with a static html page out front on the main for SEO purposes but all the item links go to the pages sitting in the new138 folder

Zen Cart doesn't have a "ipn_main_handler.php.html" file.
Your so-called SEO configuration is what's busting things.
The error message about "you don't have permission to access this file" is correct ... although it might be more accurate if it simply said that the file doesn't exist. Again, your SEO setup is what's confusing it.

23 May 2008, 8:58 AM
#3
tbokich avatar

tbokich

New Zenner

Join Date:
Aug 2007
Posts:
64
Plugin Contributions:
0

Re: Having a Failure on both IPN and Paypal express with Zen 138

Hi
Actually not correct you do have a pn_main_handler.php.html sitting in your main zen folder. As it was the problem was you now can not have both empress check out and IPN running for Paypal. This is why my express check out was not working. The second problem was now Paypal requires your PDT certificate to work.

It is also not correct that you can not stick static HTML files out front of your zen cart and even use them to direct to your index.php page to start your zen cart. If these pages are well maintained they can give you an excellent start on even better SEO optimization.

Anyway back up and running hope this will help others
Cheers
Todd

24 May 2008, 9:13 AM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Having a Failure on both IPN and Paypal express with Zen 138

tbokich:

Actually not correct you do have a pn_main_handler.php.html sitting in your main zen folder.

Zen Cart has "ipn_main_handler.php", but does NOT have "ipn_main_handler.php**.html**". That would be your own creation.

tbokich:

As it was the problem was you now can not have both empress check out and IPN running for Paypal. This is why my express check out was not working.

And, yes, you can have both Express and IPN enabled, although it's redundant to do so.
Both modules do use the ipn_main_handler.php file for order status updates though.

tbokich:

The second problem was now Paypal requires your PDT certificate to work.PDT is only needed for Website Payments Standard transactions, and only if you've enabled it in your PayPal account.

tbokich:

It is also not correct that you can not stick static HTML files out front of your zen cart and even use them to direct to your index.php page to start your zen cart.
Not sure where you heard or saw that, as I certainly didn't say it.