Zen Cart Logo
Forums / General Questions / Can't login to admin

Can't login to admin

Locked

Views: 796

Results 1 to 6 of 6
This thread is locked. New replies are disabled.
28 May 2008, 6:51 PM
#1
illphantasm avatar

illphantasm

New Zenner

Join Date:
May 2008
Posts:
5
Plugin Contributions:
0

Can't login to admin

Hey fellas. Noob.

I just installed Zen-cart - and it went well - up unto the point that I wanted to get into the admin.

I got to "(mysite.com)/zencartfolder/admin/index.php" only to get an internal server error that reads:

*Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. *

What'd I possibly do wrong here? This seems like a real supportive community. I'd love the help.

28 May 2008, 7:37 PM
#2
illphantasm avatar

illphantasm

New Zenner

Join Date:
May 2008
Posts:
5
Plugin Contributions:
0

Re: Can't login to admin

I indeed followed all instructions, like handling permissions (777, then back to 444 and whatnot).

But I can also add that my client's server defaults all folders to 755. Is that an issue?

28 May 2008, 7:54 PM
#3
illphantasm avatar

illphantasm

New Zenner

Join Date:
May 2008
Posts:
5
Plugin Contributions:
0

Re: Can't login to admin

as well as I get a problem regarding the certificate if I try to go to the store in https mode. My browser is currently in Portugese (company thing) so I can't even to begin to guess what happened there.

But I did make a key, then made a certificate. Unless there's a sort of wait time for it.

28 May 2008, 9:32 PM
#4
illphantasm avatar

illphantasm

New Zenner

Join Date:
May 2008
Posts:
5
Plugin Contributions:
0

Re: Can't login to admin

update. Went to the server error log (How I wish it wasnt in portugese). Found this.
*
[Wed May 28 18:28:28 2008] [error] [client 72.19.2.154] File does not exist: /home/agp/public_html/500.shtml
[Wed May 28 18:28:28 2008] [error] [client 72.19.2.154] Premature end of script headers: /home/agp/public_html/store/admin/index.php
SoftException in Application.cpp:246: Directory "/home/agp/public_html/store/admin" is writeable by group*

-A little help?

29 May 2008, 1:33 AM
#5
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Can't login to admin

Try reloading your files again for the Admin for:
/admin

and all files and subdirectories ...

29 May 2008, 1:47 AM
#6
illphantasm avatar

illphantasm

New Zenner

Join Date:
May 2008
Posts:
5
Plugin Contributions:
0

Re: Can't login to admin

Ajeh:

Try reloading your files again for the Admin for:
/admin

and all files and subdirectories ...

As in a fresh reinstall? I'll try it. However I won't know what I could have done wrong if it happens again.

I indeed followed all instructions, like handling permissions (777, then back to 444 and whatnot).

But I can also add that my client's server defaults all folders to 755. Is that an issue?
Ignore that, everyone. Found a post that seems to dictate that you only need to 644 (in my unix case, 444) a few specific files.