Zen Cart Logo
Forums / General Questions / Error message from my log files

Error message from my log files

Locked

Views: 1,177

Results 1 to 8 of 8
This thread is locked. New replies are disabled.
29 May 2008, 5:06 PM
#1
canemasters avatar

canemasters

Zen Follower

Join Date:
Mar 2007
Posts:
444
Plugin Contributions:
0

Error message from my log files

I keep getting the following error message constantly when I check my logs in my cpanel:

[Thu May 29 09:57:03 2008] [error] [client 160...99] client denied by server configuration: /home/Removed/public_html/includes/templates/Removed/images/index.php

Is this something I should fix, or just ignore?

29 May 2008, 5:17 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Error message from my log files

That means your .htaccess file or server's mod_security rules blocked something you programmed it to prevent.

"client denied" = the visitor was refused access
"by server configuration" = .htaccess and/or mod_security rules, etc

29 May 2008, 5:29 PM
#3
canemasters avatar

canemasters

Zen Follower

Join Date:
Mar 2007
Posts:
444
Plugin Contributions:
0

Re: Error message from my log files

does the index.php file in the images directory need to be readable?

29 May 2008, 6:20 PM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Error message from my log files

If supplied with Zen Cart, the index.php file in the images directory is intended to be read by visitors only so that they are presented with "something" blank when they attempt to snoop in your images area.

29 May 2008, 6:37 PM
#5
canemasters avatar

canemasters

Zen Follower

Join Date:
Mar 2007
Posts:
444
Plugin Contributions:
0

Re: Error message from my log files

So I can pretty much ignore this error then...

29 May 2008, 6:40 PM
#6
steven300 avatar

steven300

Totally Zenned

Join Date:
Jan 2008
Posts:
1,564
Plugin Contributions:
1

Re: Error message from my log files

I thought there was supposed to be an index.html in the images directory, not index.php?

30 May 2008, 2:49 PM
#7
canemasters avatar

canemasters

Zen Follower

Join Date:
Mar 2007
Posts:
444
Plugin Contributions:
0

Re: Error message from my log files

Steven300:

I thought there was supposed to be an index.html in the images directory, not index.php?

In the ZC setup files, there are no index.php or index.html files.

30 May 2008, 3:15 PM
#8
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Error message from my log files

Zen Cart supplies a /images/index.html file.

If you've created or added an index.php file instead, that's up to your preference.
If you didn't add such a file, you may want to inspect its contents and understand what its purpose is.