Forums / Templates, Stylesheets, Page Layout / Help! Session Errors after modifying "configure.php" files.

Help! Session Errors after modifying "configure.php" files.

Locked

Views: 1,003

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
19 Jun 2008, 7:06 AM
#1
dan0 avatar

dan0

New Zenner

Join Date:
Mar 2008
Posts:
2
Plugin Contributions:
0

Help! Session Errors after modifying "configure.php" files.

Hi,

Tonight, I tried modifying the Enable SSL setting within includes/configure.php and admin/includes/configure.php files

The following tech note on the zen cart support site describes the process: https://www.zen-cart.com/tutorials/index.php?article=14

To make a long story short, I had some permissions problems. After fixing those issues, I'm getting the following errors at the top of all pages and on the admin log-in page:

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /nfs/c01/h02/mnt/35324/domains/shop.lamodarocks.com/html/includes/configure.php:135) in /nfs/c01/h02/mnt/35324/domains/shop.lamodarocks.com/html/includes/functions/sessions.php on line 108

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /nfs/c01/h02/mnt/35324/domains/shop.lamodarocks.com/html/includes/configure.php:135) in /nfs/c01/h02/mnt/35324/domains/shop.lamodarocks.com/html/includes/functions/sessions.php on line 108

Warning: Cannot modify header information - headers already sent by (output started at /nfs/c01/h02/mnt/35324/domains/shop.lamodarocks.com/html/includes/configure.php:135) in /nfs/c01/h02/mnt/35324/domains/shop.lamodarocks.com/html/includes/init_includes/init_templates.php on line 78

Can anyone help with this?? I'm feeling lost and a bit desperate!

Thanks in advance..

Dan

19 Jun 2008, 7:18 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Help! Session Errors after modifying "configure.php" files.

You have left blank lines at the end of your configure.php files after editing.

Related FAQ: https://www.zen-cart.com/tutorials/index.php?article=87

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

19 Jun 2008, 7:36 AM
#3
dan0 avatar

dan0

New Zenner

Join Date:
Mar 2008
Posts:
2
Plugin Contributions:
0

Re: Help! Session Errors after modifying "configure.php" files.

Wow.. that was fast.

All's working now.. I did notice the error was pointing to line 135 in my configure file and that is was an empty line, outside of the PHP code. Ah well, live and learn!

Thanks for all your help in this support forum. I've read a lot of your posts and definitely learned a ton from your wisdom.

Thanks DrByte!

Dan