Zen Cart Logo
Forums / Upgrading from 1.3.x to 1.3.9 / Upgrading from 1.3.7 to 1.3.8 - clicking on 'Upgrade Database' giving error Time Out

Upgrading from 1.3.7 to 1.3.8 - clicking on 'Upgrade Database' giving error Time Out

Locked

Views: 2,077

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
26 Jun 2008, 7:38 PM
#1
audleman avatar

audleman

New Zenner

Join Date:
Jul 2007
Posts:
69
Plugin Contributions:
0

Upgrading from 1.3.7 to 1.3.8 - clicking on 'Upgrade Database' giving error Time Out

I am trying to upgrade from 1.3.7 to 1.3.8. I have chosen to be prudent and make a duplicate of my database first, which has the prefix 'zenupgradetest_zen' opposed to the regular 'zen_'.

I navigate to http://www.yesmagazine.org/store1.3.8/zc_install/index.php to run the update. A couple of issues:

  1. On the first Setup page, it is complaining that it can't find the directory /admin, which is due to me following the recommendation to renaming it. Can I safely ignore this?

  2. When I click 'Database Upgrade' it spins for maybe five seconds then takes me to a page titled: Zen Cart™ Setup - Time Out. It lists a few possible reasons for the error. None of them seem to be true; going back to the previous page shows that session support is on, the /cache directory is writeable, and it seems unlikely that a timeout has occurred in 5 seconds.

Can anybody help me with what to do next?

Kevin

26 Jun 2008, 7:43 PM
#2
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: Upgrading from 1.3.7 to 1.3.8 - clicking on 'Upgrade Database' giving error Time Out

Part of doing this requires that your admin credentials be checked...

To do so it is looking for /admin

You should be doing this to a second install with it's own DB and in that way you can keep the items names as default

Zen-Venom Get Bitten

27 Jun 2008, 4:00 PM
#3
audleman avatar

audleman

New Zenner

Join Date:
Jul 2007
Posts:
69
Plugin Contributions:
0

Re: Upgrading from 1.3.7 to 1.3.8 - clicking on 'Upgrade Database' giving error Time Out

kobra:

Part of doing this requires that your admin credentials be checked...

To do so it is looking for /admin

You should be doing this to a second install with it's own DB and in that way you can keep the items names as default

Yes, I am doing this in a second install. I'm using a folder called /store1.3.8.

I changed the /yesadmin folder back to /admin. Now the only error I'm getting on the first install screen is that the config files are not writeable.

Clicking on Database Upgrade still triggers the same error.

http://www.yesmagazine.org/store1.3.8/zc_install/index.php

Kevin