Zen Cart Logo
Forums / Addon Shipping Modules / UPS XML - problems copying to server

UPS XML - problems copying to server

Locked

Views: 1,719

Results 1 to 4 of 4
This thread is locked. New replies are disabled.
16 Jul 2008, 9:25 PM
#1
dwhitt avatar

dwhitt

New Zenner

Join Date:
Jul 2008
Posts:
2
Plugin Contributions:
0

UPS XML - problems copying to server

Hello,

I'm trying to install UPSXML (from Wiki) to my server under my following directories...

store/admin/includes/classes/xmldocument.php
store/includes/classes/xmldocument.php
store/includes/languages/english/modules/shipping/upsxml.php
store/includes/modules/shipping/upsxml.php

however, after copying files there, I get this error in my Admin panel:

Fatal error: Cannot redeclare exclude_choices() (previously declared in C:\server\xampp\htdocs\store\includes\languages\english\modules\shipping\upsxml.php:880) in C:\server\xampp\htdocs\store\includes\modules\shipping\upsxml.php on line 910

I suppose I could have copied the xmlups.php to the wrong folders? Looks like zen doesn't like part of the php file though.
Using Zen Cart 1.3.7.1 and php 5.05
-Thanks.

17 Jul 2008, 8:21 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: UPS XML - problems copying to server

You'll notice that there are multiple files of the same name in the zip file you downloaded.
Be sure that when you unzip you tell it to extract the folder names too.
Then be sure to upload the right files to the right folders.

You've got the module file in the language folder.

25 Jul 2008, 10:44 PM
#3
dwhitt avatar

dwhitt

New Zenner

Join Date:
Jul 2008
Posts:
2
Plugin Contributions:
0

Re: UPS XML - problems copying to server

hello again,

I'm still not sure where I went wrong. I've looked through my folders and made sure the right files were in the right folders(at least it appears that way).

You said i have the module file in the language folder? Where did I go wrong with what I have here?
store/includes/languages/english/modules/shipping/upsxml.php
Isn't that what the installation instructions state?

Or were you referring to something else?
thanks again.

1 Aug 2008, 5:00 AM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: UPS XML - problems copying to server

When you unzipped, you had files in specific folders, right? They need to be uploaded to the same folder structure as they came in ... don't mix them up just because the filenames are the same. The folder structures are important.

What I meant was the error message is telling you that the content of the file belonging in /includes/modules/shipping/upsxml.php appears to be in the /includes/languages/english/modules/shipping/upsxml.php file.