Zen Cart Logo
Forums / Installing on a Linux/Unix Server / I want my back up restored to another database

I want my back up restored to another database

Locked

Views: 1,183

Results 1 to 2 of 2
This thread is locked. New replies are disabled.
17 Jul 2008, 5:36 AM
#1
judah avatar

judah

New Zenner

Join Date:
Nov 2007
Posts:
68
Plugin Contributions:
0

I want my back up restored to another database

I was waiting for my hosting to complete my transfer, so I got on another domain and set Zencart up. I spent hours getting it the way I wanted it. My correct domain hosted is ready so I exported from my old domain and tried to import to the new and this is the error I got.

#1044 - Access denied for user
Can you not restore a backup to a new database created already?

17 Jul 2008, 7:35 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: I want my back up restored to another database

You may be having a permissions problem if your backup contains instructions to create a database.

If you follow this FAQ for preparing a backup: https://www.zen-cart.com/tutorials/index.php?article=103 ... especially steps 2 & 3 ... then you may have less trouble.
Steps 2 & 3 remind that you should already have the database selected before choosing to do the backup ... that way the database name and any related create/use statements will not be in the backup file. That should make it easier to restore.

Failing that, you may need to ask your hosting company for specific help.