Zen Cart Logo
Forums / All Other Contributions/Addons / Newsletter Subscribe "...6 characters or more" error

Newsletter Subscribe "...6 characters or more" error

Locked

Views: 861

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
23 Jul 2008, 11:08 AM
#1
gregwsmi avatar

gregwsmi

New Zenner

Join Date:
Aug 2005
Posts:
6
Plugin Contributions:
0

Newsletter Subscribe "...6 characters or more" error

Hi,
I've just installed the Newsletter Subscribe 2.1.0 add-on for a ZenCart 1.3.8a site that doesn't sell anything (so no customer sign-ups and no list merging).
The installation appeared to work fine, I have the Subscription Manager in the admin area and I've been able to add a subscriber through it. The sidebox shows up as desired but, when I try to add an address, I'm brought to an error page saying "Is your email address correct? It should contain at least 6 characters. Please try again." I retry on that page using a variety of properly formed email addresses and get the same message over and over. And, not surprisingly, none of these addresses are being added to the subscription DB in the ZCadmin. I've seen this problem posted a few times but, never an answer.

I poured over my installation for a few hours yesterday and everything seems to be named the right thing, given the correct permissions, and in the right place. I would post the site address but, the site is still in double-secret probeta.

Any insight, hints, pointers, advice, suggestions, whatever would be greatly appreciated.

Thanks,
Greg

24 Jul 2008, 12:24 AM
#2
anafor avatar

anafor

New Zenner

Join Date:
Jul 2008
Location:
Ukraine, CK
Posts:
28
Plugin Contributions:
2

Re: Newsletter Subscribe "...6 characters or more" error

Try to roll back your ZenCart and reinstall the Newsletter Subscribe contribution. It shoult help.

24 Jul 2008, 11:48 AM
#3
gregwsmi avatar

gregwsmi

New Zenner

Join Date:
Aug 2005
Posts:
6
Plugin Contributions:
0

Re: Newsletter Subscribe "...6 characters or more" error

anafor,

Thanks for the input. I'm a bit of a novice here (even though this project has been going for months now) so, I'm not 100% on your use of the term "roll back". Are you suggesting that I would go further than re-installing the Newsletter Subscribe contribution?

Also, if I do reinstall Newsletter Subscribe, is it just a process of overwriting the various files with new copies of the contributions originals or do I need to do anything with the sql tables that have been modified or created for this purpose or even reinstall the old, pre-NewsletterSubscribe files?

Thanks again,
Greg