Forums / General Questions / "1030 Got error 28 from storage engine" while updating category/attributes

"1030 Got error 28 from storage engine" while updating category/attributes

Locked

Views: 15,996

Results 1 to 18 of 18
This thread is locked. New replies are disabled.
23 Jul 2008, 7:06 PM
#1
ocsand avatar

ocsand

New Zenner

Join Date:
Dec 2005
Location:
Maryland
Posts:
11
Plugin Contributions:
0

"1030 Got error 28 from storage engine" while updating category/attributes

NOW Products will not display in the cart as items display similar messages
http://www.seasidestampin.com/zencart/index.php?main_page=index&cPath=1
Now what? version 1.3.8
Please help....

1030 Got error 28 from storage engine
in:
[select p.products_image, p.products_model, pd.products_name, p.products_quantity, p.products_id, p.products_type, p.master_categories_id, p.manufacturers_id, p.products_price, p.products_tax_class_id, pd.products_description, IF(s.status = 1, s.specials_new_products_price, NULL) as specials_new_products_price, IF(s.status =1, s.specials_new_products_price, p.products_price) as final_price, p.products_sort_order, p.product_is_call, p.product_is_always_free_shipping, p.products_qty_box_status from zen_products_description pd, zen_products p left join zen_manufacturers m on p.manufacturers_id = m.manufacturers_id, zen_products_to_categories p2c left join zen_specials s on p2c.products_id = s.products_id where p.products_status = 1 and p.products_id = p2c.products_id and pd.products_id = p2c.products_id and pd.language_id = '1' and p2c.categories_id = '1' order by p.products_sort_order, pd.products_name]

23 Jul 2008, 7:10 PM
#2
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: "1030 Got error 28 from storage engine" while updating category/attributes

Never experienced it personally, but I believe that it means your database doesn't have enough space left to complete the query.

Kuroi Web Design and Development | Twitter

(Questions answered in the forum only - so that any forum member can benefit - not by personal message)

23 Jul 2008, 7:10 PM
#3
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: "1030 Got error 28 from storage engine" while updating category/attributes

Error code 28: No space left on device

One or more partitions on your server is out of space or doesn't have enough space to complete this operation. You need to contact your host immediately. You or your host will need to find out which partition is low on disk space and either add more space or free up some.

Or maybe your hosting account has reached the limit of disk space allowed.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

23 Jul 2008, 7:13 PM
#4
agamic avatar

agamic

New Zenner

Join Date:
Apr 2007
Posts:
24
Plugin Contributions:
0

Re: "1030 Got error 28 from storage engine" while updating category/attributes

ocsand:

NOW Products will not display in the cart as items display similar messages
http://www.seasidestampin.com/zencart/index.php?main_page=index&cPath=1
Now what? version 1.3.8
Please help....

1030 Got error 28 from storage engine
in:
[select p.products_image, p.products_model, pd.products_name, p.products_quantity, p.products_id, p.products_type, p.master_categories_id, p.manufacturers_id, p.products_price, p.products_tax_class_id, pd.products_description, IF(s.status = 1, s.specials_new_products_price, NULL) as specials_new_products_price, IF(s.status =1, s.specials_new_products_price, p.products_price) as final_price, p.products_sort_order, p.product_is_call, p.product_is_always_free_shipping, p.products_qty_box_status from zen_products_description pd, zen_products p left join zen_manufacturers m on p.manufacturers_id = m.manufacturers_id, zen_products_to_categories p2c left join zen_specials s on p2c.products_id = s.products_id where p.products_status = 1 and p.products_id = p2c.products_id and pd.products_id = p2c.products_id and pd.language_id = '1' and p2c.categories_id = '1' order by p.products_sort_order, pd.products_name]

Hi
I am getting the same error all of a sudden when going into admin-catalog and also on the site only some categories display the error, other categories display the products just fine?
ZC 1.3.7

23 Jul 2008, 7:15 PM
#5
ocsand avatar

ocsand

New Zenner

Join Date:
Dec 2005
Location:
Maryland
Posts:
11
Plugin Contributions:
0

Re: "1030 Got error 28 from storage engine" while updating category/attributes

will the problem resolve itself when host-99 frees up enough space?

23 Jul 2008, 7:16 PM
#6
ocsand avatar

ocsand

New Zenner

Join Date:
Dec 2005
Location:
Maryland
Posts:
11
Plugin Contributions:
0

Re: "1030 Got error 28 from storage engine" while updating category/attributes

do you usse host-99 as your cart and webhost?

23 Jul 2008, 7:17 PM
#7
agamic avatar

agamic

New Zenner

Join Date:
Apr 2007
Posts:
24
Plugin Contributions:
0

Re: "1030 Got error 28 from storage engine" while updating category/attributes

ocsand:

do you usse host-99 as your cart and webhost?
I use host-99 and it has just started

Thanks Dr Byte for the heads up

23 Jul 2008, 7:25 PM
#8
ocsand avatar

ocsand

New Zenner

Join Date:
Dec 2005
Location:
Maryland
Posts:
11
Plugin Contributions:
0

Re: "1030 Got error 28 from storage engine" while updating category/attributes

agamic:

I use host-99 and it has just started

Thanks Dr Byte for the heads up
i just cut & pasted the replies here and e-mailed them to host-99 support...

23 Jul 2008, 7:35 PM
#9
duffy avatar

duffy

New Zenner

Join Date:
Aug 2005
Location:
Johnstown, PA, USA
Posts:
45
Plugin Contributions:
0

Re: "1030 Got error 28 from storage engine" while updating category/attributes

You can add me to this list also and yes, I too use Host-99. Is there an issue with Host-99?

23 Jul 2008, 8:04 PM
#10
knuckle_101 avatar

knuckle_101

Totally Zenned

Join Date:
Dec 2005
Location:
Cincinnati Ohio
Posts:
1,034
Plugin Contributions:
3

Re: "1030 Got error 28 from storage engine" while updating category/attributes

Hello,

NO there is not an issue with our servers the issue is that you maybe on a plan that is to small for your business and the tmp folder fills a lot quicker on smaller servers.

The bigger your website grows the more resources it requires. There were only a few hard drives effected and apparently your two websites were the hardrives effected.

However we cleaned your database and optimized this for you, we recommend keeping your database optimized and well maintained for future issues.

Or maybe think about upgrading to a plan that can handle your needs. (Means bigger plan = bigger hardrives)

We are keeping an eye on this for a few days and see what happens.

PCI Certified Web Hosting - ControlScan, Security Metrics (Platinum Partner), McAfee, TrustKeeper
Business Class Web Hosting - Linux and cPanel Powered

23 Jul 2008, 8:07 PM
#11
ocsand avatar

ocsand

New Zenner

Join Date:
Dec 2005
Location:
Maryland
Posts:
11
Plugin Contributions:
0

Re: "1030 Got error 28 from storage engine" while updating category/attributes

ocsand:

do you usse host-99 as your cart and webhost?
well now we know!

23 Jul 2008, 8:12 PM
#12
knuckle_101 avatar

knuckle_101

Totally Zenned

Join Date:
Dec 2005
Location:
Cincinnati Ohio
Posts:
1,034
Plugin Contributions:
3

Re: "1030 Got error 28 from storage engine" while updating category/attributes

We will watch the websites and see what happens you can always submit a ticket to our helpdesk, this is your fastest way to get responses from the support team not these forums. Even if they do not answer right away does not mean they are not looking into it. We are known to fix then reply most of the time thats makes good practice.:D

PCI Certified Web Hosting - ControlScan, Security Metrics (Platinum Partner), McAfee, TrustKeeper
Business Class Web Hosting - Linux and cPanel Powered

23 Jul 2008, 8:17 PM
#13
chuck avatar

chuck

Totally Zenned

Join Date:
Jul 2005
Posts:
255
Plugin Contributions:
0

Re: "1030 Got error 28 from storage engine" while updating category/attributes

So, you mean there "is" an issue, but you just won't say so? Instead you're putting the blame on the customers for subscribing to an overloaded server? Gimme a break :shocking:

23 Jul 2008, 8:25 PM
#14
duffy avatar

duffy

New Zenner

Join Date:
Aug 2005
Location:
Johnstown, PA, USA
Posts:
45
Plugin Contributions:
0

Re: "1030 Got error 28 from storage engine" while updating category/attributes

That's generally the way I have found them to be chuck. It gets very frustrating from a customer's point of view.

And knuckle101, I have the "business" plan from Host-99 and use approximately 10% of the resources supposedly available to me. I also regularly clean my database and purge the admin logs regularly, yet somehow this was MY fault???

23 Jul 2008, 8:29 PM
#15
knuckle_101 avatar

knuckle_101

Totally Zenned

Join Date:
Dec 2005
Location:
Cincinnati Ohio
Posts:
1,034
Plugin Contributions:
3

Re: "1030 Got error 28 from storage engine" while updating category/attributes

Two cents does not make the issue any better or worse.

We are simply explaining we partition every website with its own tmp folder and when that tmp folder fills up it means the error you see in this thread appears.

Simple as it gets. Why you ask for so many partitions? That is the most safest way to make sure other customers are not effected.

You cannot run websites that are larger then the smaller plan partitions allow. Heavy trafficed websites, queries and so on must be met in plan size to eb assure that website has the resopurces it needs to run smoothly and flawlessly.

As you see on this forum not one complaint about our hosting or internet wide so lets do not throw fuel into a burned out fire its the safest way don't you think?

Also this thread was for customers who were looking for support, we posted to give just that not to start a fight. If you are not a customer thats fine we want to make sure the ones who are are taken care and assured their websites are in good care.

Thanks.

PCI Certified Web Hosting - ControlScan, Security Metrics (Platinum Partner), McAfee, TrustKeeper
Business Class Web Hosting - Linux and cPanel Powered

23 Jul 2008, 8:30 PM
#16
knuckle_101 avatar

knuckle_101

Totally Zenned

Join Date:
Dec 2005
Location:
Cincinnati Ohio
Posts:
1,034
Plugin Contributions:
3

Re: "1030 Got error 28 from storage engine" while updating category/attributes

Any other business related discussion will be held in private if you like to discuss your website then please email us directly we will not post business issues publicly. To avoid confusion and privacy rights.

PCI Certified Web Hosting - ControlScan, Security Metrics (Platinum Partner), McAfee, TrustKeeper
Business Class Web Hosting - Linux and cPanel Powered

23 Jul 2008, 9:23 PM
#17
duffy avatar

duffy

New Zenner

Join Date:
Aug 2005
Location:
Johnstown, PA, USA
Posts:
45
Plugin Contributions:
0

Re: "1030 Got error 28 from storage engine" while updating category/attributes

You chose this forum, not I. I submitted the trouble ticket through the Host-99 trouble ticket submission system and have still not received a response from it.

I came here in desperation to get answers and hopefully get my site up and running.

Anyway, problem is resolved and that is what is important to me and my bottom line.:clap:

23 Jul 2008, 9:56 PM
#18
knuckle_101 avatar

knuckle_101

Totally Zenned

Join Date:
Dec 2005
Location:
Cincinnati Ohio
Posts:
1,034
Plugin Contributions:
3

Re: "1030 Got error 28 from storage engine" while updating category/attributes

What is your ticket number? We will check on this for you.

Also if you did not receive an email login into our ticket system with your main account information and you can track tickets there.

Do not depend 100% on emails that is why we have a tracking system to store tickets that have been replied to.

For a note your website was up and running way before you posted the second time.

I just happen to be in the forums and saw this post, we never leave anyone stranded we respond to all tickets within a timely manner. Not forums :)

PCI Certified Web Hosting - ControlScan, Security Metrics (Platinum Partner), McAfee, TrustKeeper
Business Class Web Hosting - Linux and cPanel Powered