Zen Cart Logo
Forums / General Questions / Help!1016 Can't open file: 'sessions.MYI' (errno: 144)

Help!1016 Can't open file: 'sessions.MYI' (errno: 144)

Locked

Views: 2,696

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
31 Jul 2008, 10:28 AM
#1
globwu avatar

globwu

New Zenner

Join Date:
Jun 2008
Posts:
1
Plugin Contributions:
0

Help!1016 Can't open file: 'sessions.MYI' (errno: 144)

It shows:

1016 Can't open file: 'sessions.MYI' (errno: 144)
in:
[select value from sessions where sesskey = 'c119d543d40e4cde6cc49af5f0b85dd6' and expiry > '1217498463']

After I did the repair in the PhpMyadmin, it shows below:
Table Op Msg_type Msg_text
zen-cart.products_description repair error 28 when writing to datafile
zen-cart.products_description repair error 28 when writing to datafile
zen-cart.products_description repair status Operation failed
zen-cart.sessions repair info Found block that points outside data file at 7620
zen-cart.sessions repair error 28 when fixing table
zen-cart.sessions repair status Operation failed

I did repire a couple of times, it was still the same.

Please help me to sovle the problem. By the way, I didnot have a back up.
Many thanks

1 Aug 2008, 4:38 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Help!1016 Can't open file: 'sessions.MYI' (errno: 144)

Error 28 suggests that your hosting account has run out of allowed disk space.

You probably need to remove extra files from your account, and talk to your hosting company about the disk space problem.

MySQL error: 144 = Table is crashed and last repair failed
Error code 28: No space left on device

1 Aug 2008, 6:01 PM
#3
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: Help!1016 Can't open file: 'sessions.MYI' (errno: 144)

Also important: if contacting your Host by eMail do not Send from an address connected to your Hosting account.

Once your Hosting account has run out of space you cannot receive new eMail.