Zen Cart Logo
Forums / Managing Customers and Orders / Linkpoint connection error - 58 Unable to load certificate

Linkpoint connection error - 58 Unable to load certificate

Locked

Views: 5,822

Results 1 to 9 of 9
This thread is locked. New replies are disabled.
9 Aug 2008, 10:15 PM
#1
hrm avatar

hrm

New Zenner

Join Date:
Oct 2005
Posts:
95
Plugin Contributions:
0

Linkpoint connection error - 58 Unable to load certificate

We are using Linkpoint API on 1.3.7 and, after migrating to a new server, we are getting the following error:

Communication Result:
Unable to load certificate (path to .pem file)
ErrNo: 58

When I first noticed it, the permissions, I believe, were set to 644 and I changed to 777. I'm not sure if this made any difference. The interesting thing is, some transactions are processing without error. Strangely enough, most times it seems to be happening with the processing of VISA Debit cards - although, I've tested with my own card and received no error.

I have verified with Linkpoint that the .pem file is valid, re-downloaded it, made sure it's accessible.

Here is some additional data from the error log:

Result:
Could Not Connect:
<r_approved>FAILURE</r_approved><r_error>Could not connect.</r_error>

CURL info: Array
(
[url] => https://secure.linkpt.net:1129/LSGSXML
[http_code] => 0
[header_size] => 0
[request_size] => 0
[filetime] => -1
[ssl_verify_result] => 0
[redirect_count] => 0
[total_time] => 0
[namelookup_time] => 0.133664
[connect_time] => 0.1942
[pretransfer_time] => 0
[size_upload] => 0
[size_download] => 0
[speed_download] => 0
[speed_upload] => 0
[download_content_length] => 0
[upload_content_length] => 0
[starttransfer_time] => 0
[redirect_time] => 0
)

I ran the cURL test and it seems to be fine. Port 1129 is open.

Any ideas?

9 Aug 2008, 10:40 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Linkpoint connection error - 58 Unable to load certificate

hrm:

CURL info: Array
(
[url] => https://secure.linkpt.net:1129/LSGSXML
** [http_code] => 0**
[header_size] => 0

...

I ran the cURL test and it seems to be fine. Port 1129 is open.
Getting a "0" back for the http_code suggests that either port 1129 is not open, or your server's CURL configuration is not able to successfully look up the URL for the linkpoint server.

What happens if you run the curltest.php script and add ?linkpoint=1 to the URL?

If you're hosted on GoDaddy, give up now: either pick a different hosting company, or a different payment gateway. GoDaddy doesn't work on port 1129 unless you waste big dollars with them for premium hosting.

9 Aug 2008, 10:43 PM
#3
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Linkpoint connection error - 58 Unable to load certificate

hrm:

Communication Result:
Unable to load certificate (path to .pem file)
ErrNo: 58

When I first noticed it, the permissions, I believe, were set to 644 and I changed to 777. I'm not sure if this made any difference. The file should be fine with 644 permissions. It only needs to be readable.

hrm:

The interesting thing is, some transactions are processing without error. Strangely enough, most times it seems to be happening with the processing of VISA Debit cards - although, I've tested with my own card and received no error.
That is very strange. The "unable to load certificate" issue should result in consistent failures.
Or maybe your new server is wonky and unreliable? Is it changing permissions on the files without your knowledge?

9 Aug 2008, 11:28 PM
#4
hrm avatar

hrm

New Zenner

Join Date:
Oct 2005
Posts:
95
Plugin Contributions:
0

Re: Linkpoint connection error - 58 Unable to load certificate

DrByte:

Getting a "0" back for the http_code suggests that either port 1129 is not open, or your server's CURL configuration is not able to successfully look up the URL for the linkpoint server.

What happens if you run the curltest.php script and add ?linkpoint=1 to the URL?

OK, that's new. Here you go:

Array
(
[url] => "https://secure.linkpt.net:1129/LSGSXML"
[http_code] => 200
[header_size] => 40
[request_size] => 175
[filetime] => -1
[ssl_verify_result] => -8179
[redirect_count] => 0
[total_time] => 0.565284
[namelookup_time] => 0.158606
[connect_time] => 0.217231
[pretransfer_time] => 0.505831
[size_upload] => 37
[size_download] => 280
[speed_download] => 495
[speed_upload] => 65
[download_content_length] => 280
[upload_content_length] => 0
[starttransfer_time] => 0.565238
[redirect_time] => 0
)

Malformed or unrecognized request. EOF

DrByte:

If you're hosted on GoDaddy, give up now:

Nope, we have our own server. So whatever's wrong, it's totally our fault.

Also, we just verified that port 1129 is open.

9 Aug 2008, 11:39 PM
#5
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Linkpoint connection error - 58 Unable to load certificate

hrm:

Array
(
[url] => "https://secure.linkpt.net:1129/LSGSXML"
[http_code] => 200

Malformed or unrecognized request. EOFOkay, that's good. The "200" is what you want, and the "Malformed or unrecognized request. EOF" message comes from the Linkpoint server (just saying that you didn't submit a valid payment request), so that means communication is open.

So the problem is that the PHP script is complaining that it can't open your PEM certificate file. But only sometimes. :blink:

10 Aug 2008, 1:32 AM
#6
hrm avatar

hrm

New Zenner

Join Date:
Oct 2005
Posts:
95
Plugin Contributions:
0

Re: Linkpoint connection error - 58 Unable to load certificate

Ok, I've compared the orders with the error log and here are some of the results:

Customer 1:
received error 16:10
processed successfully 16:12

Customer 2:
received error 16:13
received error 16:14
processed successfully 16:16

Customer 3:
received error 19:07
processed successfully 19:10

Each customer was able to successfully complete their order using the Linkpoint API within 3 minutes of receiving the communication error.

Does that give any clues? I'm baffled!:wacko:

10 Aug 2008, 2:28 AM
#7
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Linkpoint connection error - 58 Unable to load certificate

I'm equally puzzled.

Did they all receive the very same error?

10 Aug 2008, 3:45 AM
#8
hrm avatar

hrm

New Zenner

Join Date:
Oct 2005
Posts:
95
Plugin Contributions:
0

Re: Linkpoint connection error - 58 Unable to load certificate

Thank you so much for your attention.

Yes. All the errors are exactly the same except for the namelookup
and connect times (and the personal info, of course).

Now there's a new error. I just had a customer receive the "SGS-020006: Please contact merchant services" error and then 3 minutes later get declined (which I assume means that Linkpoint was contacted successfully).

Linkpoint's SGS ERRORS page says:

" Verify first that the the correct store number is entered. This error normally occurs when contact information is updated with your merchant bank. For example if the business phone number or address was recently updated. You will need to contact LinkPoint/Yourpay support and they will need to generate a new PEM file for your account. You will then need to download the new file and either upload it to your web site or copy/paste it into your shopping cart. "

Could it be that I need to have Linkpoint actually generate a new pem file rather than just downloading a new copy of the original? Could that fix both errors?

10 Aug 2008, 3:56 AM
#9
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Linkpoint connection error - 58 Unable to load certificate

I suppose there might be something wrong with the file.

However, I don't know whether you had any similar problems on your old server. Or is this a new account and new gateway since the move?