Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Mysql stopping install

Mysql stopping install

Locked

Views: 1,635

Results 1 to 6 of 6
This thread is locked. New replies are disabled.
24 Aug 2008, 3:05 AM
#1
rbarnold avatar

rbarnold

New Zenner

Join Date:
Oct 2007
Posts:
4
Plugin Contributions:
0

Mysql stopping install

I have been tring all night to install Zencart 1.38a but I am still locked up and can't get past the database section, even though I have entered the fields correctly.
I install phpBB3 at the same time but to a different database name and that worked fine.
The problems I am having are to do with the database host, username and/or password.
Following is an example:
database host: = mysql5.s430.sureserver.com
username: = robsuk
password: I have used the correct password
Database name: = robsuk_shop

The error comes back with:
ATTENTION: Problems Found
Connection to Database failed
Access denied for user: '[email protected]' (Using password: YES)

Zencart seems to be ignoring the "mysql5" part of the database host address, or something else.
I have never seen the "@" symbol used in accessing a database before and was under the assumption that it was only used in email addresses, I have no knowledge of php though.
I have spoken to my hosting provider and they have sugested other addresses as follows:
Please try using "localhost:/tmp/mysql5.sock" in order to connect to the database.
You can also try with mysql5.s422.sureserver.com Port: 3307
Neither work.
Mysql is part of the address because my provider has both Mysql4 and Mysql5 available during the phasing out of Mysql4

Any help would be much appreciated
Regards
Roger

24 Aug 2008, 3:17 AM
#2
Kim avatar

Kim

Obaa-san

Join Date:
Jun 2003
Location:
West Coast, North America
Posts:
26,640
Plugin Contributions:
0

Re: Mysql stopping install

Try using just 'localhost'.

24 Aug 2008, 3:22 AM
#3
rbarnold avatar

rbarnold

New Zenner

Join Date:
Oct 2007
Posts:
4
Plugin Contributions:
0

Re: Mysql stopping install

Kim:

Try using just 'localhost'.
I have tried localhost as that is what phpBB3 required however using it in Zencart fails the same as everything else I have tryed.
Thanks for the try though as having been up all night I could have missed that one.

24 Aug 2008, 4:24 AM
#4
rbarnold avatar

rbarnold

New Zenner

Join Date:
Oct 2007
Posts:
4
Plugin Contributions:
0

Re: Mysql stopping install

:clap:Thanks, problem is now sorted, I got a clue from my hosting provider

29 Sep 2008, 7:47 AM
#5
pumpkinacer avatar

pumpkinacer

New Zenner

Join Date:
Sep 2008
Posts:
1
Plugin Contributions:
0

Re: Mysql stopping install

I have the same problem. What was the clue from your hosting provider?

29 Sep 2008, 1:23 PM
#6
vger avatar

vger

Past Contributor

Join Date:
Nov 2004
Location:
Norfolk, United Kingdom
Posts:
3,189
Plugin Contributions:
0

Re: Mysql stopping install

My guess is that they were using the wrong database server address, or else they were using cPanel and had created the database, mysql user and password but had not assigned the mysql user to that db.

Vger