Zen Cart Logo
Forums / Installing on a Linux/Unix Server / after site move getting error: imagepng() gd- ... bmz_image_handler

after site move getting error: imagepng() gd- ... bmz_image_handler

Locked

Views: 1,997

Results 1 to 6 of 6
This thread is locked. New replies are disabled.
30 Aug 2008, 8:34 AM
#1
marksu avatar

marksu

Zen Follower

Join Date:
Nov 2007
Posts:
260
Plugin Contributions:
0

after site move getting error: imagepng() gd- ... bmz_image_handler

I moved my Zen Cart from subfolder to root.
I did edit the 2 config files and edited the cache path

After the move I get following error:

Warning: imagepng() [function.imagepng]: gd-png: fatal libpng error: zlib error in /home/.../includes/classes/bmz_image_handler.class.php on line 646

Any glues what is wrong?

30 Aug 2008, 2:17 PM
#2
vger avatar

vger

Past Contributor

Join Date:
Nov 2004
Location:
Norfolk, United Kingdom
Posts:
3,189
Plugin Contributions:
0

Re: after site move getting error: imagepng() gd- ... bmz_image_handler

Check that the document root is correct in your configure.php files now that you have moved it to the root - as it is probably that setting which is causing the failure.

Vger

30 Aug 2008, 3:04 PM
#3
marksu avatar

marksu

Zen Follower

Join Date:
Nov 2007
Posts:
260
Plugin Contributions:
0

Re: after site move getting error: imagepng() gd- ... bmz_image_handler

**the root config seems ok on bot config files
**
define('HTTP_SERVER', 'http://fotonapakymppi.fi');
define('HTTPS_SERVER', 'https://fotonapakymppi.fi');

define('HTTP_SERVER', 'http://fotonapakymppi.fi');
define('HTTPS_SERVER', 'https://fotonapakymppi.fi');
define('HTTP_CATALOG_SERVER', 'http://fotonapakymppi.fi');
define('HTTPS_CATALOG_SERVER', 'https://fotonapakymppi.fi');

I just figured out that it seems to be Image Handler 2 issue.
Uninstalling it the problem goes away.
I still have to figure the thing our as I need that plugin.

I checked the system info and GD atleas is supported still.
I did the check incase Host provider would have changed it.

30 Aug 2008, 3:53 PM
#4
marksu avatar

marksu

Zen Follower

Join Date:
Nov 2007
Posts:
260
Plugin Contributions:
0

Re: after site move getting error: imagepng() gd- ... bmz_image_handler

As it seem to be Image handler issues maybe I should put my question to its support thread.

Now I come sofar that some of the images are displayed ad on some the error apear.

Maybe some of the images where now uploaded and that is why problems accure?

30 Aug 2008, 4:02 PM
#5
marksu avatar

marksu

Zen Follower

Join Date:
Nov 2007
Posts:
260
Plugin Contributions:
0

Re: after site move getting error: imagepng() gd- ... bmz_image_handler

Yes now I figured out.
The upload of files was not don in FULL.

31 Aug 2008, 6:24 AM
#6
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: after site move getting error: imagepng() gd- ... bmz_image_handler

Thanks for clarifying that the error was a result of not uploading all the files to your new location during the move.