Zen Cart Logo
Forums / General Questions / Sending Newsletter Problem >> 1053 Server shutdown in progress

Sending Newsletter Problem >> 1053 Server shutdown in progress

Locked

Views: 3,026

Results 1 to 6 of 6
This thread is locked. New replies are disabled.
10 Sep 2008, 10:44 PM
#1
geoman avatar

geoman

New Zenner

Join Date:
Nov 2006
Posts:
16
Plugin Contributions:
0

Sending Newsletter Problem >> 1053 Server shutdown in progress

Everything's been working just fine... until today. I can send emails and product notifications but no newsletters.

Any ideas or help would be most appreciated.

Kind regards,

GM


Here's my error when I try to send a newsletter**:


**Newsletter and Product Notifications Manager

1053 Server shutdown in progress
in:
[SELECT DISTINCT c.customers_email_address as customers_email_address, c.customers_lastname as customers_lastname, c.customers_firstname as customers_firstname FROM zen_customers c LEFT JOIN zen_orders o ON c.customers_id=o.customers_id WHERE o.date_purchased IS NULL ]
If you were entering information, press the BACK button in your browser and re-check the information you had entered to be sure you left no blank fields.

2013 Lost connection to MySQL server during query
in:
[select count(*) as total from zen_sessions where sesskey = 'm1c4urn8kdvl7i9hofueq0mir5']
If you were entering information, press the BACK button in your browser and re-check the information you had entered to be sure you left no blank fields.

10 Sep 2008, 11:14 PM
#2
wilt avatar

wilt

Oji-san

Join Date:
Jun 2003
Location:
Newcastle UK
Posts:
1,883
Plugin Contributions:
3

Re: Sending Newsletter Problem >> 1053 Server shutdown in progress

Hi,

have you tried to send since then.

From, your post, it just seems you were incredibly unlucky, in sending your newsletter at exactly the same time as your hosts were doing a reboot

10 Sep 2008, 11:21 PM
#3
geoman avatar

geoman

New Zenner

Join Date:
Nov 2006
Posts:
16
Plugin Contributions:
0

Re: Sending Newsletter Problem >> 1053 Server shutdown in progress

I've tried repeatedly over the span of several hours. Seems to be a problem with Zencart or SQL... Not the server.

wilt:

Hi,

have you tried to send since then.

From, your post, it just seems you were incredibly unlucky, in sending your newsletter at exactly the same time as your hosts were doing a reboot

10 Sep 2008, 11:29 PM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Sending Newsletter Problem >> 1053 Server shutdown in progress

If you are getting repeated error messages from the SQL database, then the problem is SQL ... which ... is part of your server ... which ... is your hosting company's responsibility.
Zen Cart is just passing on the error message it received back while trying to do something that should not normally encounter an error.

10 Sep 2008, 11:55 PM
#5
geoman avatar

geoman

New Zenner

Join Date:
Nov 2006
Posts:
16
Plugin Contributions:
0

Re: Sending Newsletter Problem >> 1053 Server shutdown in progress

I just backed up the database and ran the SQL patch you mentioned in an earlier post.

DELETE FROM query_builder where query_name = 'Customers who have never completed a purchase';

It worked just fine. So, where does the problem lie? Curious!

11 Sep 2008, 12:16 AM
#6
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Sending Newsletter Problem >> 1053 Server shutdown in progress

Well, the record you deleted doesn't do anything to cause your MySQL server to do a shutdown.

Nevertheless, if you think it's solved and you're satisfied that everything else is just fine, I guess that's the end of the matter.
Granted, you won't be able to send a newsletter to the group whose definition you just deleted.