New Zenner
- Join Date:
- Jan 2009
- Posts:
- 13
- Plugin Contributions:
- 0
Cold Steel Template Support Thread
Thanks - that did it! I appreciate the help and quick response! :bigups:
Views: 132,851
New Zenner
Thanks - that did it! I appreciate the help and quick response! :bigups:
Deceased
This is a fix for the Cold Steel Top Navigation Bar
Just unzip the file and upload the includes folder to your server.
[Attachment no longer available]
NOTE: We are sorry that Clyde is no longer with us.
We are grateful for all his contributions to the Zen Cart community.
New Zenner
Hi, just downloaded cold steel, thank you.. I am having install issues, with the 3 folders in the includes folder you provide, do I need to replace existing same named folders with yours you provided. Just putting the whole includes folder into the template folder is not working..
Deceased
wellbourne:
Hi, just downloaded cold steel, thank you.. I am having install issues, with the 3 folders in the includes folder you provide, do I need to replace existing same named folders with yours you provided. Just putting the whole includes folder into the template folder is not working..
The includes folder does not go into the template folder.
Just upload the includes folder to wherever you have your zencart distribution installed.
NOTE: We are sorry that Clyde is no longer with us.
We are grateful for all his contributions to the Zen Cart community.
New Zenner
Hi, that is what I am not sure of, can't seem to find it.. Fantastico through my host provider did the install for me.. c-panel through host gator, both public_html and www files show all the pics, css, php files but they seem tobe named the same as the 3 in the includes file.. Thanks for you support:frusty:
Deceased
wellbourne:
Hi, that is what I am not sure of, can't seem to find it.. Fantastico through my host provider did the install for me.. c-panel through host gator, both public_html and www files show all the pics, css, php files but they seem tobe named the same as the 3 in the includes file.. Thanks for you support:frusty:
The best way to upload files is to use an ftp client
Filezilla is reliable and free.
Trying to use your C-Panel is really time consuming and not all that reliable. Plus you have to upload individual files instead of just draging and dropping to your server.
NOTE: We are sorry that Clyde is no longer with us.
We are grateful for all his contributions to the Zen Cart community.
New Zenner
Ok, it is uploaded and at least now I have the ability to switch over and rest like instructed but now there is a:
Not Found
The requested URL /includes/templates/cold_steel/images/scr_template_cold_steel.jpg was not found on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
that is what i get when I try to preview to actually use the url https://www.familyoutdoorstore.com the only thing I get is a blank white screen with no errors.. Any Ideas?? Thanks
Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8i DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at familyoutdoorstore.com Port 80
Deceased
wellbourne:
Ok, it is uploaded and at least now I have the ability to switch over and rest like instructed but now there is a:
Not Found
The requested URL /includes/templates/cold_steel/images/scr_template_cold_steel.jpg was not found on this server.Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
that is what i get when I try to preview to actually use the url https://www.familyoutdoorstore.com the only thing I get is a blank white screen with no errors.. Any Ideas?? Thanks
Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8i DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at familyoutdoorstore.com Port 80
Please check your PM (personal message)
NOTE: We are sorry that Clyde is no longer with us.
We are grateful for all his contributions to the Zen Cart community.
New Zenner
Good day, Clyde! First, thanks for a great template - the clean look really appeals to me. Sadly, I'm having a bit of a problem with one particular page - on checkout success, the "Thank you, we appreciate...." is duplicated, and while I do want to thank my customers, twice does seem a bit excessive. Could you point me toward the files I should be looking at to solve this? I'm afraid I'm at a bit of a loss.
The install is fresh, and this is the only template on it.... it's at www.a c m e f i b r e s. com
Thanks for your time -
Deceased
pearlie:
Good day, Clyde! First, thanks for a great template - the clean look really appeals to me. Sadly, I'm having a bit of a problem with one particular page - on checkout success, the "Thank you, we appreciate...." is duplicated, and while I do want to thank my customers, twice does seem a bit excessive. Could you point me toward the files I should be looking at to solve this? I'm afraid I'm at a bit of a loss.
The install is fresh, and this is the only template on it.... it's at www.a c m e f i b r e s. com
Thanks for your time -
open includes/templates/cold_steel/templates/tpl_checkout_success_default.php
delete lines 52 and 53
*<h1 id="checkoutSuccessHeading"><?php echo HEADING_TITLE; ?></h1>
NOTE: We are sorry that Clyde is no longer with us.
We are grateful for all his contributions to the Zen Cart community.
New Zenner
I knew it would be something blindingly simple! thanks very much. :D
New Zenner
Hello Clyde
I would appreciate your help with my Cold Steel template installation.
I've downloaded and installed Zen-Cart v1.3.8a on my G4 Mac running OS 10.4.11 and using FF3. Everything seems to be OK so far. Then I've installed Cold Steel to my hard drive...
users/******/sites/ZenCart by opening the includes folder and installing the files in reverse order according to the uninstall instructions. When I attempt to change the template in Admin I get a blank page, and then cannot access any template.
Your debug utility log shows the following...
[11-Feb-2009 00:06:55] PHP Warning: require(/Users//Sites/ZenCart/includes/templates/cold_steel/template_info.php) [<a href='function.require'>function.require</a>]: failed to open stream: Permission denied in /Users//Sites/ZenCart/admin/template_select.php on line 17
[11-Feb-2009 00:06:55] PHP Fatal error: require() [<a href='function.require'>function.require</a>]: Failed opening required '/Users//Sites/ZenCart/includes/templates/cold_steel/template_info.php' (include_path='.:/usr/local/php5/lib/php') in /Users//Sites/ZenCart/admin/template_select.php on line 17
That brings me to the limit of my understanding, and it is not obvious to me which php file is wrong, and how I should change it. Will you please explain the log results and show me where and what I need to change to fix the problem. I'm using TextWrangler as my editor.
Thank you in advance, Bernie
Deceased
colonel_pannik:
Hello Clyde
I would appreciate your help with my Cold Steel template installation.
I've downloaded and installed Zen-Cart v1.3.8a on my G4 Mac running OS 10.4.11 and using FF3. Everything seems to be OK so far. Then I've installed Cold Steel to my hard drive...
users/******/sites/ZenCart by opening the includes folder and installing the files in reverse order according to the uninstall instructions. When I attempt to change the template in Admin I get a blank page, and then cannot access any template.
Your debug utility log shows the following...
[11-Feb-2009 00:06:55] PHP Warning: require(/Users//Sites/ZenCart/includes/templates/cold_steel/template_info.php) [<a href='function.require'>function.require</a>]: failed to open stream: Permission denied in /Users//Sites/ZenCart/admin/template_select.php on line 17
[11-Feb-2009 00:06:55] PHP Fatal error: require() [<a href='function.require'>function.require</a>]: Failed opening required '/Users//Sites/ZenCart/includes/templates/cold_steel/template_info.php' (include_path='.:/usr/local/php5/lib/php') in /Users//Sites/ZenCart/admin/template_select.php on line 17That brings me to the limit of my understanding, and it is not obvious to me which php file is wrong, and how I should change it. Will you please explain the log results and show me where and what I need to change to fix the problem. I'm using TextWrangler as my editor.
Thank you in advance, Bernie
First: uninstall ALL the files for the cold steel template.
Then check admin -> tools -> template selection
NOTE: We are sorry that Clyde is no longer with us.
We are grateful for all his contributions to the Zen Cart community.
New Zenner
Restarted computer this morning and no Apache!!!!! :lookaroun
Phew! Two hours later and up and running again, so uninstalled Cold Steel folders and had the luxury of accessing the Classic template afterwards.
Just in case my earlier fiddling and Apache crash had an influence I reinstalled Cold Steel, but got the same error log message as previously. Uninstalled folders as per your instructions - over to you again Clyde.
Thanks, Bernie
Deceased
colonel_pannik:
Restarted computer this morning and no Apache!!!!! :lookaroun
Phew! Two hours later and up and running again, so uninstalled Cold Steel folders and had the luxury of accessing the Classic template afterwards.
Just in case my earlier fiddling and Apache crash had an influence I reinstalled Cold Steel, but got the same error log message as previously. Uninstalled folders as per your instructions - over to you again Clyde.
Thanks, Bernie
Since the files in the distribution are in the same structure as Zen Cart , Here are the installation instructions I recommend in the readme_cold_steel_template.txt file.
Unzip the Package and upload the entire includes folder to your server.
In your admin panel, go to admin -> tools -> template selection, click the edit button, choose the template from the dropdown menu and click update.
Now go to admin -> tools -> layout boxes controller, Scroll down to the bottom of the screen and click the reset button.
Open your site in your browser and view the new template in action.
I'm guessing from the error message you were/are getting that you failed to to upload includes/templates/cold_steel/template_info.php
NOTE: We are sorry that Clyde is no longer with us.
We are grateful for all his contributions to the Zen Cart community.
New Zenner
I've got it solved Clyde.
The problem turned out to be permissions in the various folders. I've reset them to match those set in the Classic Template and all seems to be in order now.
My limited understanding is that for my inbuilt Mac server the folders/files can be dragged to the appropriate locations in order for them to function correctly. Does this process fail to set the correct permissions I wonder? Seeing as I don't know if FTP can be performed when loading onto my own drive I did it this way, but I should investigate the FTP options for future use!
Thank you for your attention and for this great looking template. I'll do my best not to stuff up from now on!
Bernie
Deceased
colonel_pannik:
I've got it solved Clyde.
The problem turned out to be permissions in the various folders. I've reset them to match those set in the Classic Template and all seems to be in order now.
My limited understanding is that for my inbuilt Mac server the folders/files can be dragged to the appropriate locations in order for them to function correctly. Does this process fail to set the correct permissions I wonder? Seeing as I don't know if FTP can be performed when loading onto my own drive I did it this way, but I should investigate the FTP options for future use!
Thank you for your attention and for this great looking template. I'll do my best not to stuff up from now on!
Bernie
I'm not familiar with Mac, but I'd assume that you could drag and drop the includes folder directly to wherever you have Zen Cart installed on your hard drive.
In any case, glad you got it sorted.
NOTE: We are sorry that Clyde is no longer with us.
We are grateful for all his contributions to the Zen Cart community.
New Zenner
When you drag the includes folder to its new location on your Mac hard drive you are asked if you wish to replace the existing one. I wasn't game to do that as I assumed it would delete what was already there. So I disassembled your includes folder and relocated the various folders to their target locations. That's not difficult, as you provide good uninstall instructions that identify where the various files & folders reside. I knew I had all the bits in the correct places so it had to be something relatively simple, as the Classic template was working as it should. That's when I checked the file permissions and found the problem.
If anyone has a better method I would be pleased to hear about it.
Bernie
Deceased
colonel_pannik:
When you drag the includes folder to its new location on your Mac hard drive you are asked if you wish to replace the existing one. I wasn't game to do that as I assumed it would delete what was already there. So I disassembled your includes folder and relocated the various folders to their target locations. That's not difficult, as you provide good uninstall instructions that identify where the various files & folders reside. I knew I had all the bits in the correct places so it had to be something relatively simple, as the Classic template was working as it should. That's when I checked the file permissions and found the problem.
If anyone has a better method I would be pleased to hear about it.
Bernie
If the Mac works like my PC then dragging and dropping the includes folder will only replace files if they have the same name as files already in that folder other wise it just copies the new files to their proper location.
NOTE: We are sorry that Clyde is no longer with us.
We are grateful for all his contributions to the Zen Cart community.
New Zenner
Hi Clyde,
How do I get the Wide Banners from the admin to show at the bottom of the template?
Thanks,
Keith
Tell staff why this post should be reviewed.