Zen Cart Logo
Forums / General Questions / New Account Creation not working.

New Account Creation not working.

Views: 5,195

Results 1 to 20 of 29
17 Nov 2012, 12:16 PM
#1
kennym avatar

kennym

New Zenner

Join Date:
Mar 2010
Posts:
30
Plugin Contributions:
0

New Account Creation not working.

Hi,

New customers get a server 500 error when trying to create a new account in my store. http://www.railworks.marleyman.co.uk/store/

Zen Cart 1.5.1 - Database Patch Level: 1.5.1 New Install
PHP Version: 5.2.17
Database: MySQL 5.1.56
Server: Microsoft-IIS/7.5
Windows NT WINSRV105 6.1 build 7601
API version 5.0.22

Template API version 5.0.22

Mods
Image Handler 4
backup_zc_v1.1
ckeditor-365-for-zencart
minimum_customer_account_information

Store Status 0

Latest New Account Creation was 15th Nov
No myDebug log files have been generated in my 'logs' folder

Error during account creation reads;


Server error
The website encountered an error while retrieving http://www.railworks.marleyman.co.uk/store/index.php?main_page=create_account. It may be down for maintenance or configured incorrectly.
Here are some suggestions:
Reload this web page later.
HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfil the request.


I have looked at this;

http://www.zen-cart.com/content.php?105
and this;
http://www.zen-cart.com/showthread.php?191342-The-website-encountered-an-error-while-retrieving-index-php-main_page
neither seem to give me the info I need.

I have replaced includes\templates\aberdeen_neutral\templatestpl_modules_create_account.php from a back up dated 08 Nov and still have the same error.

I have opened a ticket with the web host and they suggest the web developer, (me) looks into it. So here I am looking into it, with your help please.

Anyone have any ideas how to resolve the issue please?

17 Nov 2012, 3:43 PM
#2
wmorris avatar

wmorris

Totally Zenned

Join Date:
Aug 2007
Location:
Amarillo, Tx
Posts:
1,683
Plugin Contributions:
0

Re: New Account Creation not working.

I have notice that you are using a Windows server,,,, I advise you to use Linux server it has less problems than Windows servers.

17 Nov 2012, 4:20 PM
#3
kennym avatar

kennym

New Zenner

Join Date:
Mar 2010
Posts:
30
Plugin Contributions:
0

Re: New Account Creation not working.

morrisgiftshop:

I have notice that you are using a Windows server,,,, I advise you to use Linux server it has less problems than Windows servers.

that's not really helpful.

17 Nov 2012, 4:23 PM
#4
bislewl avatar

bislewl

Totally Zenned

Join Date:
Dec 2011
Location:
Wisconsin, USA
Posts:
674
Plugin Contributions:
12

Re: New Account Creation not working.

In you includes/configure.php
what are your settings for ssl, domains, servers, etc?
Sounds to me like there is a wrong setting somewhere.

17 Nov 2012, 4:24 PM
#5
wmorris avatar

wmorris

Totally Zenned

Join Date:
Aug 2007
Location:
Amarillo, Tx
Posts:
1,683
Plugin Contributions:
0

Re: New Account Creation not working.

Can you post your includes/configure.php file all except all your database information?

17 Nov 2012, 5:34 PM
#6
kennym avatar

kennym

New Zenner

Join Date:
Mar 2010
Posts:
30
Plugin Contributions:
0

Re: New Account Creation not working.

<?php /** * @package Configuration Settings circa 1.5.1 * @copyright Copyright 2003-2012 Zen Cart Development Team * @copyright Portions Copyright 2003 osCommerce * @license <http://www.zen-cart.com/license/2_0.txt> GNU Public License V2.0 * File Built by zc_install on 2012-11-07 11:24:12 */ /*************** NOTE: This file is similar, but DIFFERENT from the "admin" version of configure.php. ***********/ /*************** The 2 files should be kept separate and not used to overwrite each other. ***********/ // Define the webserver and path parameters // HTTP_SERVER is your Main webserver: eg-http://www.your_domain.com // HTTPS_SERVER is your Secure webserver: eg-https://www.your_domain.com define('HTTP_SERVER', 'http://www.railworks.marleyman.co.uk'); define('HTTPS_SERVER', 'https:'); // Use secure webserver for checkout procedure? define('ENABLE_SSL', 'false'); // NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes! // * DIR_WS_* = Webserver directories (virtual/URL) // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder) define('DIR_WS_CATALOG', '/store/'); define('DIR_WS_HTTPS_CATALOG', '//www.railworks.marleyman.co.uk/store/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/'); define('DIR_WS_TEMPLATES', DIR_WS_INCLUDES . 'templates/'); define('DIR_WS_PHPBB', '/'); // * DIR_FS_* = Filesystem directories (local/physical) //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/ define('DIR_FS_CATALOG', 'D:/inetpub/vhosts/marleyman.co.uk/subdomains/railworks/httpdocs/store/'); //the following path is a COMPLETE path to the /logs/ folder eg: /var/www/vhost/accountname/public_html/store/logs ... and no trailing slash define('DIR_FS_LOGS', 'D:/inetpub/vhosts/marleyman.co.uk/subdomains/railworks/httpdocs/store/logs'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'edited by poster/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); define('DIR_WS_UPLOADS', DIR_WS_IMAGES . 'uploads/'); define('DIR_FS_UPLOADS', DIR_FS_CATALOG . DIR_WS_UPLOADS); define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/'); // define our database connection define('DB_TYPE', 'mysql'); define('DB_PREFIX', ''); define('DB_CHARSET', 'utf8'); define('DB_SERVER', 'localhost'); define('DB_SERVER_USERNAME', 'edited by poster'); define('DB_SERVER_PASSWORD', 'edited by poster'); define('DB_DATABASE', 'edited by poster'); // The next 2 "defines" are for SQL cache support. // For SQL_CACHE_METHOD, you can select from: none, database, or file // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder // ie: /path/to/your/webspace/public_html/zen/cache -- leave no trailing slash define('SQL_CACHE_METHOD', 'none'); define('DIR_FS_SQL_CACHE', 'D:/inetpub/vhosts/marleyman.co.uk/subdomains/railworks/httpdocs/store/cache'); // EOF
17 Nov 2012, 5:43 PM
#7
wmorris avatar

wmorris

Totally Zenned

Join Date:
Aug 2007
Location:
Amarillo, Tx
Posts:
1,683
Plugin Contributions:
0

Re: New Account Creation not working.

Are you hosting with a company or do your own hosting?

17 Nov 2012, 5:58 PM
#8
kennym avatar

kennym

New Zenner

Join Date:
Mar 2010
Posts:
30
Plugin Contributions:
0

Re: New Account Creation not working.

with a company and they say no errors their end and no *suexec *issues.

All was fine, on the 11 Nov 6 new customers created new accounts. All I have done since then is add one new product listing. Current log ons are not affected and customers can log in and download products.

17 Nov 2012, 6:51 PM
#9
lhungil avatar

lhungil

Totally Zenned

Join Date:
Feb 2012
Location:
mostly harmless
Posts:
1,818
Plugin Contributions:
4

Re: New Account Creation not working.

You may wish to check your settings and / or ask in the support thread for Minimum Customer Account Information plugin as the error you are experiencing appears to be during the create_account script running.

Kennym:

with a company and they say no errors their end and no *suexec *issues.
HTTP Error 500 (Internal Server Error) are displayed for any number of 'internal' problems. Are there any errors in the php log (look in suphp log if running under suphp, look in configured php.ini log settings otherwise)? What is the cause of the 500 error listed as in the IIS Server logs (including error logs)? You may need to ask your provider for these logs (or to enable / look into these logs).

Some extended codes for 500 errors in IIS: http://support.microsoft.com/kb/943891
How to enable / find error logging for the HTTP API: http://support.microsoft.com/kb/820729

Probably not related, but kind of strange the way the 'HTTPS_SERVER' and 'DIR_WS_HTTPS_CATALOG' are split.

The glass is not half full. The glass is not half empty. The glass is simply too big!
Where are the Zen Cart Debug Logs? Where are the HTTP 500 / Server Error Logs?
Zen Cart related projects maintained by lhûngîl : Plugin / Module Tracker

18 Nov 2012, 5:05 AM
#10
bislewl avatar

bislewl

Totally Zenned

Join Date:
Dec 2011
Location:
Wisconsin, USA
Posts:
674
Plugin Contributions:
12

Re: New Account Creation not working.

a couple things to try to change:
define('HTTP_SERVER', 'http://www.railworks.marleyman.co.uk');
define('HTTPS_SERVER', 'https://www.railworks.marleyman.co.uk');
and
define('DIR_WS_CATALOG', '/store/');
define('DIR_WS_HTTPS_CATALOG', '/store/');

plan b
in the admin
configuration->sessions->Add Period... change that setting

either one of theses work?

18 Nov 2012, 10:36 AM
#11
kennym avatar

kennym

New Zenner

Join Date:
Mar 2010
Posts:
30
Plugin Contributions:
0

Re: New Account Creation not working.

@bislewl

No, but thanks.
I don't have any SSl certificates so the HTTPS dirs are empty.

and the second option shows no change.

18 Nov 2012, 1:20 PM
#12
wmorris avatar

wmorris

Totally Zenned

Join Date:
Aug 2007
Location:
Amarillo, Tx
Posts:
1,683
Plugin Contributions:
0

Re: New Account Creation not working.

Are you using an actual server from a hosting company or a local host from your computer?

18 Nov 2012, 2:07 PM
#14
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,104
Plugin Contributions:
56

Re: New Account Creation not working.

bislewl:

a couple things to try to change:
define('HTTP_SERVER', 'http://www.railworks.marleyman.co.uk');
define('HTTPS_SERVER', 'https://www.railworks.marleyman.co.uk');
and
define('DIR_WS_CATALOG', '/store/');
define('DIR_WS_HTTPS_CATALOG', '/store/');

plan b
in the admin
configuration->sessions->Add Period... change that setting

either one of theses work?

Please note that plan A is spot-on. With the original values for the HTTPS_SERVER and DIR_WS_HTTPS_CATALOG, an HTTPS_SERVER value of just "https://" could easily set off a Server 500 error.

Kennym:

@bislewl

No, but thanks.
I don't have any SSl certificates so the HTTPS dirs are empty.

and the second option shows no change.
Did you actually make the change to your /includes/configure.php file (remember to change its read-only status before re-FTPin ... can't tell you how many times I've done that!)? If not, please make the changes suggested by bislewl and retry.

18 Nov 2012, 3:52 PM
#15
kennym avatar

kennym

New Zenner

Join Date:
Mar 2010
Posts:
30
Plugin Contributions:
0

Re: New Account Creation not working.

ok, inclues/configure now reads;

define('HTTP_SERVER', 'http://www.railworks.marleyman.co.uk');
define('HTTPS_SERVER', 'https://www.railworks.marleyman.co.uk');

// Use secure webserver for checkout procedure?
define('ENABLE_SSL', 'false');

// NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes!
// * DIR_WS_* = Webserver directories (virtual/URL)
// these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder)
define('DIR_WS_CATALOG', '/store/');
define('DIR_WS_HTTPS_CATALOG', '/store/');

Still cannot create a new account

18 Nov 2012, 4:13 PM
#16
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,104
Plugin Contributions:
56

Re: New Account Creation not working.

I found an obscure issue (http://www.zen-cart.com/showthread.php?202291-Corrections-for-obscure-quot-syntax-error-unexpected-end-of-file-quot-errors&p=1165106#post1165106) that affects me running on a localhost/windows install. On the off-chance that it's related, I've attached a zip-file of the updated two template files (one of them is the tpl_modules_create_account.php). Just replace the two files in your template override directory and let me know it that helps.

Attachment #11476

18 Nov 2012, 5:47 PM
#17
kennym avatar

kennym

New Zenner

Join Date:
Mar 2010
Posts:
30
Plugin Contributions:
0

Re: New Account Creation not working.

Added files to* includes/templates/aberdeen_neutral/templates* (just checking that is the correct folder. Still no change there.

18 Nov 2012, 6:15 PM
#18
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,104
Plugin Contributions:
56

Re: New Account Creation not working.

You could try installing the Zen Cart Notifier Trace plugin. That plugin "monitors" the notifiers thrown by various Zen Cart modules and will give you/us an idea of how far the page is getting before the server 500 is thrown. If you'd like to go that route, just post the contents of the /cache/notifier_trace.log file after you've tried to create an account.

18 Nov 2012, 6:39 PM
#19
kennym avatar

kennym

New Zenner

Join Date:
Mar 2010
Posts:
30
Plugin Contributions:
0

Re: New Account Creation not working.

I don't understand the instruction (How to use it) and what it actually wants me to do.

18 Nov 2012, 6:51 PM
#20
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,104
Plugin Contributions:
56

Re: New Account Creation not working.

The "How to use it" is primarily for developers who want to use the plugin to help them debug their new code.

For your case, I'm suggesting simply installing the plugin (use the v1.5.1 version of the files). The files simply "drop in" to your store (no overwrites) and then you'll need to run the zen_trace_install.sql file that comes in the zip file. Once you run the SQL file, the trace function is enabled and each access to your store will result in the file /cache/notifier_trace.log file being written. The enable/disable setting is present in your admin's Configuration->Logging tab.