Zen Cart Logo
Forums / All Other Contributions/Addons / WordPress® for Zen Cart® (wp4zen) [Support Thread]

WordPress® for Zen Cart® (wp4zen) [Support Thread]

Views: 43,283

Results 61 to 80 of 110
26 Aug 2015, 7:21 PM
#61
adb34 avatar

adb34

Totally Zenned

Join Date:
Mar 2008
Location:
Brampton, Cumbria, United Kingdom, United Kingdom
Posts:
825
Plugin Contributions:
0

WordPress® for Zen Cart® (wp4zen) [Support Thread]

lat9:

Yes, the plugin works on Zen Cart v1.5.4 and on WordPress versions up to 4.2.4. I'm using the "latest posts" portion on my website.
Thanks for the info

27 Jan 2016, 8:48 AM
#62
heathenmagic avatar

heathenmagic

Totally Zenned

Join Date:
May 2005
Location:
England
Posts:
733
Plugin Contributions:
0

Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

I am just wondering if anyone has had the same problem as me? Google sitemaps and indexing updated how they search a site on the 14th December. Since that time my site has been de-indexing until virtually no pages indexed. Using google fetch it was producing 500 internal server errors. Yet the site is fine and is taking orders. So I checked html_header.php (as I thought it was the best place to start) and took out wp4zen code. The fetch bots (and using web-sniffer) is not picking up the 500 errors now and all is fine. I had no idea that this was going on. Is there a way to use the code without causing this issue? I am thinking premium may be the way to go as it might work differently.

27 Jan 2016, 2:56 PM
#63
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,102
Plugin Contributions:
56

Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

@HeathenMagic, have you checked to see if there are any debug-logs present in your store's /logs folder? Many times that "Server 500" error will be accompanied by a log that indicates (a) what the issue is and (b) where it originated.

You might want to also install the MyDebug Backtrace plugin (https://www.zen-cart.com/downloads.php?do=file&id=1879) to capture the issue's source in more circumstances.

27 Jan 2016, 3:19 PM
#64
heathenmagic avatar

heathenmagic

Totally Zenned

Join Date:
May 2005
Location:
England
Posts:
733
Plugin Contributions:
0

Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

Thanks for reply. For some reason logs aren't showing up at the moment, but I will find out when I can. I have your module installed and will try that instead. Will let you know as soon as I can :-) . Though if others are able to test with web-sniffer or google webmaster tools and don't get a 500 error then it might be site specific to me. I had no idea there was a problem, site works as normal with the code. But it only shows the error when the code is being added to the relevant file and running through either of the tools mentioned.

27 Jan 2016, 3:36 PM
#65
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,102
Plugin Contributions:
56

Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

If by "web-sniffer" you're referring to the Chrome extension named Chrome Sniffer Plus, I've installed that and run it against my site (which uses the wp4zen plugin) without errors.

28 Jan 2016, 12:46 AM
#66
heathenmagic avatar

heathenmagic

Totally Zenned

Join Date:
May 2005
Location:
England
Posts:
733
Plugin Contributions:
0

Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

my apologies. I am on 1.5.4 version, with CSS Loader module added. Perhaps there is some sort of clash I didn't realise existed before, and site specific

28 Jan 2016, 10:29 PM
#67
lhungil avatar

lhungil

Totally Zenned

Join Date:
Feb 2012
Location:
mostly harmless
Posts:
1,818
Plugin Contributions:
4

Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

Can you check if disabling "Prevent Spider Sessions" in Zen Cart makes any change (do not normally recommend changing this).

31 Jan 2016, 4:29 PM
#68
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

HeathenMagic:

I am just wondering if anyone has had the same problem as me? Google sitemaps and indexing updated how they search a site on the 14th December. Since that time my site has been de-indexing until virtually no pages indexed. Using google fetch it was producing 500 internal server errors. Yet the site is fine and is taking orders. So I checked html_header.php (as I thought it was the best place to start) and took out wp4zen code. The fetch bots (and using web-sniffer) is not picking up the 500 errors now and all is fine. I had no idea that this was going on. Is there a way to use the code without causing this issue? I am thinking premium may be the way to go as it might work differently.

Since the change to the html_header.php required for this module only adds a call to the WorPress wp-load.php file in Zen Cart (required so this module can display the WordPress sidebox content inside Zen Cart), I can't help but wonder if the errors you are getting are ACTUALLY coming from your WordPress blog..

3 Feb 2016, 4:02 PM
#69
heathenmagic avatar

heathenmagic

Totally Zenned

Join Date:
May 2005
Location:
England
Posts:
733
Plugin Contributions:
0

Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

lhungil:

Can you check if disabling "Prevent Spider Sessions" in Zen Cart makes any change (do not normally recommend changing this).

Sorry for the delay in replying. I can confirm that disabling this does allow google / websniffer to do its thing. I turned it back on for now just in case and will see what else I can find out

3 Feb 2016, 4:08 PM
#70
heathenmagic avatar

heathenmagic

Totally Zenned

Join Date:
May 2005
Location:
England
Posts:
733
Plugin Contributions:
0

Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

DivaVocals:

Since the change to the html_header.php required for this module only adds a call to the WorPress wp-load.php file in Zen Cart (required so this module can display the WordPress sidebox content inside Zen Cart), I can't help but wonder if the errors you are getting are ACTUALLY coming from your WordPress blog..

Hello there,

sorry for not getting back to you sooner. You could be right. I have been trying to do some log error solving, and it is still the same. The only thing I noticed on wordpress since December is the following when I try to auto update ( never had this problem before, but can always upgrade manually instead I guess:-

Unable to locate WordPress Root directory.

Installation Failed

On the zencart side, the only thing I have noticed since also December (weird) is that error logs are not being created. There is always some minor errors of some kind usually, so I will have to try to figure that one out. If it is indeed related. Though I am getting paypal curl logs and similar still.

3 Feb 2016, 7:42 PM
#71
lhungil avatar

lhungil

Totally Zenned

Join Date:
Feb 2012
Location:
mostly harmless
Posts:
1,818
Plugin Contributions:
4

Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

HeathenMagic:

Sorry for the delay in replying. I can confirm that disabling this does allow google / websniffer to do its thing. I turned it back on for now just in case and will see what else I can find out
My best guess is: One of your WordPress plugins relies upon an active session (and starts one when a session is not present). When you have Zen Cart configured to "Prevent Spider Sessions", no session is started and output may start before WordPress is loaded in "html_header.php". This then causes a PHP error, because the output occurred before the WordPress plugin attempted to start a session.

If the above guess holds true, simplest fix is to allow Zen Cart to start sessions for "Spiders" (these include SE bots/crawlers). Because when a WordPress plugin requires the use of sessions, the gain from preventing spider sessions in Zen Cart will be minimal. A more complex fix is to determine which WordPress plugin is attempting to use sessions, then replace with a different WordPress plugin (which does not require sessions) or modify the WordPress plugin to also detect and prevent spider sessions.

DivaVocals:

Since the change to the html_header.php required for this module only adds a call to the WorPress wp-load.php file in Zen Cart (required so this module can display the WordPress sidebox content inside Zen Cart), I can't help but wonder if the errors you are getting are ACTUALLY coming from your WordPress blog..
Agreed, probably from one of the installed WordPress plugins. I've posted my stab in the dark above!

HeathenMagic:

... I have been trying to do some log error solving, and it is still the same. ... On the zencart side, the only thing I have noticed since also December (weird) is that error logs are not being created. ...
The out-of-box WordPress disables portions of PHP error reporting. This will result in overriding of the Zen Cart PHP error reporting. When trying to track down an issue / error, one can add the following in "wp-config" to have WordPress enable all PHP error reporting and save them to a file (debug.log). Be aware the error log will probably contain a larger number of warnings about the use of deprecated functions/methods (these are not going to be the cause of the HTTP 500).

I would caution against leaving WP_DEBUG enabled on a production server unless one understands the ramifications.

/**
 * For developers: WordPress debugging mode.
 *
 * Change this to true to enable the display of notices during development.
 * It is strongly recommended that plugin and theme developers use WP_DEBUG
 * in their development environments.
 */
define('WP_DEBUG', true);
define('WP_DEBUG_LOG', true);
define('WP_DEBUG_DISPLAY', false);

NOTE: Reference Debugging WordPress for more details regarding the above options.

3 Feb 2016, 8:17 PM
#72
heathenmagic avatar

heathenmagic

Totally Zenned

Join Date:
May 2005
Location:
England
Posts:
733
Plugin Contributions:
0

Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

Thanks ever so much for your insight and help. I think you are spot on, this is the last ever error log received from 14th December:-

[14-Dec-2015 15:25:22 UTC] PHP Warning: session_start(): open(SESSION_WRITE_DIRECTORY/sess_90b148a11e8486d7a845e635fefa1e12, O_RDWR) failed: No such file or directory (2) in //public_html//wp-content/plugins/my-blog-guest/common.php on line 9
[14-Dec-2015 15:25:22 UTC] PHP Fatal error: Call to a member function count_contents() on a non-object in /
/tpl_header.php on line 107
[14-Dec-2015 15:25:22 UTC] PHP Warning: Unknown: open(SESSION_WRITE_DIRECTORY/sess_
*** 2, O_RDWR) failed: No such file or directory (2) in Unknown on line 0
[14-Dec-2015 15:25:22 UTC] PHP Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (SESSION_WRITE_DIRECTORY) in Unknown on line 0

I have turned spider sessions on, and hopefully not too much SEO damage has been done. I have resubmitted the site and sitemaps, and be vigilant on this in the future. I am certain this must be the culprit plugin, so it is best I remove as soon as I can.

11 Feb 2016, 11:03 PM
#73
heathenmagic avatar

heathenmagic

Totally Zenned

Join Date:
May 2005
Location:
England
Posts:
733
Plugin Contributions:
0

Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

Hello again,

Just wondering if the only way to regain zencart error reporting (on zencart specific errors only) is to disable wp4zen and put wordpress back into its own database and folder again? I tried the config as above, and you are right, it is wordpress only errors and lots of them.

Many thanks in advance.

12 Feb 2016, 11:09 AM
#74
heathenmagic avatar

heathenmagic

Totally Zenned

Join Date:
May 2005
Location:
England
Posts:
733
Plugin Contributions:
0

Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

I just figured it out, the wordpress sessions error created a massive amount of debug logs, so hopefully the host can delete most of them and I can start seeing error logs again.

13 Feb 2016, 2:26 PM
#75
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

HeathenMagic:

Hello again,

Just wondering if the only way to regain zencart error reporting (on zencart specific errors only) is to disable wp4zen and put wordpress back into its own database and folder again? I tried the config as above, and you are right, it is wordpress only errors and lots of them.

HeathenMagic:

I just figured it out, the wordpress sessions error created a massive amount of debug logs, so hopefully the host can delete most of them and I can start seeing error logs again.

What will REALLY resolve your issue is to find out which WordPress plugin is the cause of the issues to begin with. WordPress running in it's own database will not solve the REAL issue you have here.. (an errant WordPress plugin). Moving WordPress to a separate folder & DB and disabling this module will only MASK your issue because you will stop seeing the errors that will STILL be generating. To solve your issue once and for all, disable ALL of your WordPress plugins and re-enable them one by one to see which one is the root cause.

1 Mar 2016, 6:41 PM
#76
soxophoneplayer avatar

soxophoneplayer

Totally Zenned

Join Date:
Feb 2008
Posts:
534
Plugin Contributions:
0

Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

I really like the look of this mod. Currently using zc 1.5.4 with Winchester Black responsive and running a blog separately. Planning the update to 1.5.5 when released and do some mod changes at that time. I'd like to dump my cumbersome blogspot blog and put wp in my zc server.

Does/should this mod work (correctly) with responsive templates?

Thanks

2 Mar 2016, 4:28 AM
#77
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

soxophoneplayer:

I really like the look of this mod. Currently using zc 1.5.4 with Winchester Black responsive and running a blog separately. Planning the update to 1.5.5 when released and do some mod changes at that time. I'd like to dump my cumbersome blogspot blog and put wp in my zc server.

Does/should this mod work (correctly) with responsive templates?

Thanks

This is not an "embedding" module -- because IMHO embedding modules are cumbersome and ultimately a disastrous method that is mostly used to avoid doing the work to make ones WordPress blog look like their shop.. This a much simpler module that provides a solution to integrate WordPress & Zen Cart. It adds Zen Cart sideboxes which contain WordPress content. So it works as well with any responsive template as any other Zen Cart sidebox.

2 Mar 2016, 9:03 AM
#78
heathenmagic avatar

heathenmagic

Totally Zenned

Join Date:
May 2005
Location:
England
Posts:
733
Plugin Contributions:
0

Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

Thanks for your help, appreciate you taking the time to reply. I found which wordpress plugin it was, and now removed entirely. They updated the plugin in December, but with a bug I guess.

DivaVocals:

What will REALLY resolve your issue is to find out which WordPress plugin is the cause of the issues to begin with. WordPress running in it's own database will not solve the REAL issue you have here.. (an errant WordPress plugin). Moving WordPress to a separate folder & DB and disabling this module will only MASK your issue because you will stop seeing the errors that will STILL be generating. To solve your issue once and for all, disable ALL of your WordPress plugins and re-enable them one by one to see which one is the root cause.

10 Mar 2016, 3:09 AM
#79
jld avatar

jld

New Zenner

Join Date:
Dec 2007
Posts:
37
Plugin Contributions:
0

Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

Hi
I am having to change from a wordpress blog to a forum as the blog is just not handling the infor in a way I need.
Is there anyway this will work with a wordpress forum?
Please
Johanne

10 Mar 2016, 7:31 PM
#80
amethyst_fairy avatar

amethyst_fairy

Zen Follower

Join Date:
Feb 2016
Location:
Salem, NH
Posts:
103
Plugin Contributions:
0

Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

I installed and it shows up in sideboxes in admin but does not show up on store side boxes at all. I have installed and reinstalled. Should be on R side of site at bottom under onesocial. Any help would be appreciated. Also how do you tell if wordpress is installed on same sql that maybe the issue. https://www.thedragonskeep.net/index.php?main_page=index&cPath=170
Thanks
Sandria