New Zenner
- Join Date:
- Dec 2007
- Posts:
- 37
- Plugin Contributions:
- 0
WordPress® for Zen Cart® (wp4zen) [Support Thread]
Hi I guess the answer to my previous question is no
So
IS there a version of this that will work with v1.3.9
Views: 43,283
New Zenner
Hi I guess the answer to my previous question is no
So
IS there a version of this that will work with v1.3.9
Totally Zenned
Amethyst_fairy:
I installed and it shows up in sideboxes in admin but does not show up on store side boxes at all. I have installed and reinstalled. Should be on R side of site at bottom under onesocial.
Did you make the changes required to our store's includes/templates/YOUR_TEMPLATE/common/html_header.php file??
Do you have the right blog location defined in "Configuration > WordPress for Zen Cart (wp4zen) > WordPress Blog Path"?
Amethyst_fairy:
Also how do you tell if wordpress is installed on same sql that maybe the issue.
You use the same DB settings in both the WP wp-config.php and ZC configure.php files. If you have the blog in a different database, you will need to move the blog tables to the same DB as the store DB.
Totally Zenned
jld:
Hi I guess the answer to my previous question is no
The answer to your previous question is addressed in the module description (which is also on the 1st page of this support thread)
Basic Features (Free)
Could you add additional WordPress sideboxes to display inside a Zen Cart sidebox?? It's very possible dependng on the content, but you may need a developer to create these sideboxes for you.
You could also use the Blank Sidebox contribution, and if your forum plugin supports any shortcodes that can be used inside a WordPress widget, you could use the PHP code for that shortcode inside the Blank Sidebox. For example:
<?php
/**
* blank sidebox - allows a blank sidebox to be added to your site
*
* @package templateSystem
* @copyright 2007 Kuroi Web Design
* @copyright Portions Copyright 2003-2007 Zen Cart Development Team
* @license http://www.zen-cart.com/license/2_0.txt GNU Public License V2.0
* @version $Id: blank_sidebox.php 2007-05-26 kuroi $
*/
$content = '';
$content .= '<div id="' . str_replace('_', '-', $box_id . 'Content') . '" class="sideBoxContent">';
// Replace the text and HTML tags between the apostophes on lines 19 and 20.
// Use as many or as few lines using this model as you need for your custom content.
// If you have a multilingual site define your text in the languages/YOUR_LANGUAGE/extra_definitions/blank_sidebox_defines.php and include it as shown in line 19.
// If your site is monolingual, you can put the text right here as shown on line 20 (and nobody will know!)
//$content .= '<p>' . TEXT_BLANK_SIDEBOX . '</p>';
$content .= do_shortcode('[YOUR-SHORTCODE_HERE]');
$content .= '</div>';
?>
jld:
IS there a version of this that will work with v1.3.9
The version available in the downloads now will work with ZC v1.3.9.
Totally Zenned
zc 1.5.5 test site on WAMP with Responsive Sheffield Blue (testing ok).
Installed latest Wordpress on root, same address, configs etc with wp_ prefix set in zencart db. Tested - Wordpress loads correctly and no issues noted in front end or back end.
Installed WP4zen: store side is fine and opens tests finel. Admin side opens and functions including config WP4zen. But when I go to tools/layout controller to set up the side boxes I get a blank page. It doesn't hang the site - I can backout of the page, but can't access the layout page.
The logs generate no errors on accessing the storefront, a few errors on accessing the admin (which I also get without this mod re WAMP no ssl, version notice), and zillions when I try to open the layout controller. (I thought I saved the error message but turns out I just saved a blank folder. The errors did, however, refer over and over to the layout control, more columns called for than anticipated etc.) I've removed the mod to work on other aspects but can reinstall to replicate the error logs if helpful).
There were some layout controller issues with 1.5.5 and the responsive templates that were resolved. So I'm wondering if there is some similar issue with this mod and zc 1.5.5, or if anything I've described jumps out at anyone as meaning x.
When installing the mod I did change the my_ template and admin folder names, and I did merge the common/html_header file.
Totally Zenned
Re post#84 - I found the error message from the log:
[26-Mar-2016 19:27:26 UTC] Request URI: /xxxxxxxxx/layout_controller.php, IP address: ::1
#1 trigger_error() called at [C:\wamp\www\includes\functions\plugin_support.php:68]
#2 plugin_version_check_for_updates() called at [C:\wamp\www\xxxxxxxx\includes\init_includes\init_responsive_sheffield_blue.php:89]
#3 require(C:\wamp\www\xxxxxxx\includes\init_includes\init_responsive_sheffield_blue.php) called at [C:\wamp\www\includes\autoload_func.php:48]
#4 require(C:\wamp\www\includes\autoload_func.php) called at [C:\wamp\www\xxxxxxxxxx\includes\application_top.php:171]
#5 require(C:\wamp\www\xxxxxxx\includes\application_top.php) called at [C:\wamp\www\xxxxxxx\layout_controller.php:10]
[26-Mar-2016 19:27:26 UTC] PHP Notice: CURL error checking plugin versions: 60:SSL certificate problem: self signed certificate in certificate chain
Trying file_get_contents() instead. in C:\wamp\www\includes\functions\plugin_support.php on line 68[26
-Mar-2016 19:27:26 UTC] PHP Stack trace:
[26-Mar-2016 19:27:26 UTC] PHP 1. {main}() C:\wamp\www\xxxxxxxxx\layout_controller.php:0
[26-Mar-2016 19:27:26 UTC] PHP 2. require() C:\wamp\www\xxxxxxxxx\layout_controller.php:10
[26-Mar-2016 19:27:26 UTC] PHP 3. require() C:\wamp\www\xxxxxxxxx\includes\application_top.php:171
[26-Mar-2016 19:27:26 UTC] PHP 4. require() C:\wamp\www\includes\autoload_func.php:48
[26-Mar-2016 19:27:26 UTC] PHP 5. plugin_version_check_for_updates() C:\wamp\www\xxxxxxxx\includes\init_includes\init_responsive_sheffield_blue.php:89
[26-Mar-2016 19:27:26 UTC] PHP 6. trigger_error() C:\wamp\www\includes\functions\plugin_support.php:68
[26-Mar-2016 19:27:26 UTC] Request URI: /xxxxxxxx/layout_controller.php, IP address: ::1
#1 trigger_error() called at [C:\wamp\www\includes\classes\db\mysql\query_factory.php:167]
#2 queryFactory->show_error() called at [C:\wamp\www\includes\classes\db\mysql\query_factory.php:139]
#3 queryFactory->set_error() called at [C:\wamp\www\includes\classes\db\mysql\query_factory.php:266]
#4 queryFactory->Execute() called at [C:\wamp\www\xxxxxxxx\layout_controller.php:66][26-Mar-2016 19:27:26 UTC] PHP Fatal error: 1136:Column count doesn't match value count at row 1 :: insert into zen_layout_boxes
(layout_template, layout_box_name, layout_box_status, layout_box_location, layout_box_sort_order, layout_box_sort_order_single, layout_box_status_single, show_box_min_width)
values ('responsive_sheffield_blue', 'wp_archives_sidebox.php', 0, 0, 0, 0, 0, 0, 0, 0) ==> (as called by) C:\wamp\www\xxxxxxx\layout_controller.php on line 66 <== in C:\wamp\www\includes\classes\db\mysql\query_factory.php on line 167[26-Mar-2016 19:27:26 UTC] PHP Stack trace:
[26-Mar-2016 19:27:26 UTC] PHP 1. {main}() C:\wamp\www\xxxxxx\layout_controller.php:0
[26-Mar-2016 19:27:26 UTC] PHP 2. queryFactory->Execute() C:\wamp\www\xxxxxx\layout_controller.php:66
[26-Mar-2016 19:27:26 UTC] PHP 3. queryFactory->set_error() C:\wamp\www\includes\classes\db\mysql\query_factory.php:266
[26-Mar-2016 19:27:26 UTC] PHP 4. queryFactory->show_error() C:\wamp\www\includes\classes\db\mysql\query_factory.php:139
[26-Mar-2016 19:27:26 UTC] PHP 5. trigger_error() C:\wamp\www\includes\classes\db\mysql\query_factory.php:167
The top group of statements are what I get routinely from my WAMP test version of live site and as far as I can tell in test mode aren't stopping me from doing anything. The bottlom statements are what come when I hit config/layout controller in the admin panel, resulting in a blank page.
Administrator
Your errors have nothing to do with wp4zen, they have to do with some changes required for existing responsive templates (like Responsive Sheffield Blue) to operate within Zen Cart v1.5.5. There was a posting by @rbarbour within the past couple of days that outlined the changes required.
Totally Zenned
lat9:
Your errors have nothing to do with wp4zen, they have to do with some changes required for existing responsive templates (like Responsive Sheffield Blue) to operate within Zen Cart v1.5.5. There was a posting by @rbarbour within the past couple of days that outlined the changes required.
I had already applied the changes from @rbarbour post and some tips from Dr Byte, but I'll go back over them and see if I missed something or did something wrong.
Totally Zenned
lat9:
Your errors have nothing to do with wp4zen, they have to do with some changes required for existing responsive templates (like Responsive Sheffield Blue) to operate within Zen Cart v1.5.5. There was a posting by @rbarbour within the past couple of days that outlined the changes required.
My set site with no Wordpress or WP4Zen includes the barbour changes. The admin layout controller works properly.
2nd copy of test site with Wordpress added to above, the admin layout controller works properly.(Wordpress functions when called up by localhost/wordpress)
3rd copy of test site - above set that includes Wordpress plus addition of WP4Zen, admin panel loads, but layout controller generates the error.
The only merge between 2nd and 3rd is the single block of code for WP4Zen in common/html_header.
In the Sheffield Responsive common/html_header I merged only the two section of code as in the barbour posting as for test copy 1 and 2. For test copy 3 I added the section of code for WP4Zen.
There were a lot of other differences in the zc 1.5.5 html_header - adding the two sections suggested by Barbour did make the Sheffield template function - but I wonder if some of the other part of the newer code need changing to accommodate WP4Zen. I also tried using the entire zc 1.5.5 default file with only the WP4Zen bit merged in that also didn't work and also didn't work with my test 1 or 2 site.
Should I be asking this in a diff forum?
Totally Zenned
soxophoneplayer:
...admin panel loads, but layout controller generates the error....
Think I have this sorted. I don't know why the zc 1.5.5 layout controller works with Sheffield Blue Responsive template but not WP4Zen. But,
in the 1.5.5 admin/layout controller, line #66, I eliminated two zero's so it now looks like this:
// (BOF - EDIT) ZCA Responsive Components for 1.5.5
$db->Execute("insert into " . TABLE_LAYOUT_BOXES . "
(layout_template, layout_box_name, layout_box_status, layout_box_location, layout_box_sort_order, layout_box_sort_order_single, layout_box_status_single, show_box_min_width)
values ('" . zen_db_input($template_dir) . "', '" . zen_db_input($file) . "', 0, 0, 0, 0, 0, 0)");
// (EOF - EDIT) ZCA Responsive Components for 1.5.5
The layout contoller is now working for me with both the Sheffiled Blue and the WP4Zen installed. If its not already clear I really don't know what I'm doing but this seems to work touch wood.
Totally Zenned
soxophoneplayer:
Think I have this sorted. I don't know why the zc 1.5.5 layout controller works with Sheffield Blue Responsive template but not WP4Zen. But,
in the 1.5.5 admin/layout controller, line #66, I eliminated two zero's so it now looks like this:
// (BOF - EDIT) ZCA Responsive Components for 1.5.5
$db->Execute("insert into " . TABLE_LAYOUT_BOXES . "
(layout_template, layout_box_name, layout_box_status, layout_box_location, layout_box_sort_order, layout_box_sort_order_single, layout_box_status_single, show_box_min_width)
values ('" . zen_db_input($template_dir) . "', '" . zen_db_input($file) . "', 0, 0, 0, 0, 0, 0)");
// (EOF - EDIT) ZCA Responsive Components for 1.5.5
>
> The layout contoller is now working for me with both the Sheffiled Blue and the WP4Zen installed. If its not already clear I really don't know what I'm doing but this seems to work touch wood.
As lat9 pointed out, the issue isn't this module but a problem with your template. The error you were getting and the fix you made confirms this:
[26-Mar-2016 19:27:26 UTC] PHP Fatal error: 1136:Column count doesn't match value count at row 1 :: insert into zen_layout_boxes
(layout_template, layout_box_name, layout_box_status, layout_box_location, layout_box_sort_order, layout_box_sort_order_single, layout_box_status_single, show_box_min_width)
values ('responsive_sheffield_blue', 'wp_archives_sidebox.php', 0, 0, 0, 0, 0, 0[B], 0, 0[/B]) ==> (as called by) C:\wamp\www\xxxxxxx\layout_controller.php on line 66 <== in C:\wamp\www\includes\classes\db\mysql\query_factory.php on line 167
Zen Follower
Hi,
I am on zencart 1.5.5a with sterling grand template pretty new install. Have imported database so zencart and wordpress on same database and they are on the same server. Now don't know if makes a difference but have wordpress on sub domain blog.thedragonskeep.net. I am tying to install on https://www.thedragonskeep.net but every time enable sideboxes the product pages go blank. I have installed and reinstalled.
[05-Oct-2016 13:34:56 America/Denver] PHP Fatal error: Call to undefined function wp_list_pages() in /home1/thedrah1/public_html/includes/templates/stirling_grand/sideboxes/tpl_wp_pages_sidebox.php on line 15
Any help would be extremely grateful.
Thanks
Sandria
Administrator
Sandria, did you make the update to your template's /common/html_header.php, adding the following code fragment just before the <DOCTYPE> specification?
<?php
/**
* WordPress for Zen Cart (wp4zen)
* call for WordPress code
*
*/
define('WP_USE_THEMES', false);
require_once(DIR_FS_WORDPRESS . 'wp-load.php');
?>
Totally Zenned
Amethyst_fairy:
Hi,
I am on zencart 1.5.5a with sterling grand template pretty new install. Have imported database so zencart and wordpress on same database and they are on the same server. Now don't know if makes a difference but have wordpress on sub domain blog.thedragonskeep.net. I am tying to install on https://www.thedragonskeep.net but every time enable sideboxes the product pages go blank. I have installed and reinstalled.[05-Oct-2016 13:34:56 America/Denver] PHP Fatal error: Call to undefined function wp_list_pages() in /home1/thedrah1/public_html/includes/templates/stirling_grand/sideboxes/tpl_wp_pages_sidebox.php on line 15
Any help would be extremely grateful.
Thanks
Sandria
Your Wordpress folder needs to be in same domain, in your root - ie in the same folder where your zen cart admin, includes etc folders reside. So your blog url would then be https://www.thedragonskeep.net/wordpress
You can see my example in my sig file. (Its zc 1.5.5a with Resp Sheffield Blue and WP4Zen).
Zen Follower
Thanks lat9 that worked. Sidebox now working. :-)
Totally Zenned
When I install this module, I get a blank white screen on my website. All the admin bits seem to be working and I can see the sideboxes etc. However, when I apply:
<?php /** * WordPress for Zen Cart (wp4zen) * call for WordPress code * */ define('WP_USE_THEMES', false); require_once(DIR_FS_WORDPRESS . 'wp-load.php'); ?>in my html_header.php file it crashes the site and all I get is a blank page. I am running Zen Cart 1.5.4
Totally Zenned
Fixed it....I didn't have a trailing slash after WordPress Blog Path in the admin
Zen Follower
Can this plugin be used to show the full wp blog and load posts within zencart not just the side boxes so that the WP site does NOT have to be styled to match the store?
Totally Zenned
ShopVille:
Can this plugin be used to show the full wp blog and load posts within zencart not just the side boxes so that the WP site does NOT have to be styled to match the store?
No. I was surprised by this as the mod demo site seemed to show it being done.
I ended up looking for a WP template (Ribsome Pro) that most closely resembled my ZC template (Responsive Sheffield Blue 2.0). I got the pro WP template as the free version limited the styling changes. In the end it only took a few hours of css fiddling to get a pretty good match. I think the pro WP temp was about 35 euros. I also used the pro version of WP4 to get the added features.
(Can't show you as I dropped both when I upgraded to zc 1.5.5f.)
Zen Follower
soxophoneplayer:
No. I was surprised by this as the mod demo site seemed to show it being done.
I ended up looking for a WP template (Ribsome Pro) that most closely resembled my ZC template (Responsive Sheffield Blue 2.0). I got the pro WP template as the free version limited the styling changes. In the end it only took a few hours of css fiddling to get a pretty good match. I think the pro WP temp was about 35 euros. I also used the pro version of WP4 to get the added features.
(Can't show you as I dropped both when I upgraded to zc 1.5.5f.)
Have you tried https://www.zen-cart.com/downloads.php?do=file&id=465 ?
Administrator
ShopVille:
Can this plugin be used to show the full wp blog and load posts within zencart not just the side boxes so that the WP site does NOT have to be styled to match the store?
I'm sure it can; that's a variant of the "Latest Blog Posts" sidebox, which is part of the plugin's premium version (per its readme).
Tell staff why this post should be reviewed.