Zen Cart Logo
Forums / General Questions / PHP Warning: mysqli_connect(): (28000/1045)

PHP Warning: mysqli_connect(): (28000/1045)

Views: 5,307

Results 21 to 30 of 30
17 Sep 2014, 12:41 AM
#21
vanhorn_s avatar

vanhorn_s

Zen Follower

Join Date:
Apr 2010
Posts:
283
Plugin Contributions:
0

PHP Warning: mysqli_connect(): (28000/1045)

It's in the database. Fresh install of 1.5.3 in a subfolder in a new database, and no error. As soon as I import the existing data into the new database, the error comes back.

Any idea on where to look for this? If I decide to wipe the database clean, what should I keep?

17 Sep 2014, 1:04 AM
#22
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: PHP Warning: mysqli_connect(): (28000/1045)

vanhorn_s:

It's in the database. Fresh install of 1.5.3 in a subfolder in a new database, and no error. As soon as I import the existing data into the new database, the error comes back.

Any idea on where to look for this? If I decide to wipe the database clean, what should I keep?

My next guess then would be that it is something in the configurations table thatisnt "set" right. Check out this post, although nearly the entire thread is relatively pertinent. Don't worry that it started with a discussion about a. Different version, it still applies relatively speaking.

http://www.zen-cart.com/showthread.php?213460-Copying-customers-%28only%29-from-1-3-9h-to-1-5-1&p=1248071#post1248071

I would suggest first trying to follow the basic instruction but instead of just the customers data, try everything except the configurations table. If the problem persists, then take a look at the wiki that is referenced in the post, you would want to 1) maintain your adminhistory as necessary for pci compliance (ie transfer over or backup like required every 2 months.) And then at least, products, orders, customer history... Maybe a few others depending on what is installed. And by products forexample, there are several related "sub-tables" (attributes, categories, products to categorries, etc... They are covered for the most part in the wiki.

ZC Installation/Maintenance Support <- Site
Contribution for contributions welcome...

17 Sep 2014, 4:05 PM
#24
vanhorn_s avatar

vanhorn_s

Zen Follower

Join Date:
Apr 2010
Posts:
283
Plugin Contributions:
0

Re: PHP Warning: mysqli_connect(): (28000/1045)

No, I didn't look at that post, because it refers to 1.5.2, and I was working with 1.5.3.

I was able to fix this in my test site, by removing the db, reinstalling it, and reinstalling 1.5.3.
I then imported from the old database:
address_book
admin
admin_activity_log
authorizenet
categories
categories_description
counter
counter_history
coupons
coupons_description
coupons_redeem_track
customers
customers_basket
customers_info
customers_wishlist
featured
group_pricing
manufacturers
manufacturers_info
orders---all tables
paypal---all tables
products---all tables
reviews
reviews_description
salemaker_sales
specials
tax_class
tax_rates

I specifically looked at each table to see which ones I would need to maintain my customers, orders, products, and coupon codes.
Now I just need to experiment with templates before I put my site on that database.

17 Sep 2014, 7:51 PM
#25
dbltoe avatar

dbltoe

Totally Zenned

Join Date:
Jan 2004
Location:
N of San Antonio TX
Posts:
9,843
Plugin Contributions:
17

Re: PHP Warning: mysqli_connect(): (28000/1045)

Actually, it applies to both 1.5.2 and 1.5.3.
Will apply from now on as ZC has migrated to mysqli.
But looks like you got it goin.

Need a hand with Zen Cart? Hire the team at myZenCartZone.com for upgrades, repairs, and custom plugins.
Zen Cart Certified hosting at myZenCartHost.com

17 Sep 2014, 8:15 PM
#26
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: PHP Warning: mysqli_connect(): (28000/1045)

dbltoe:

Have you looked at this post? http://www.zen-cart.com/showthread.php?211145-Pre-release-feedback-for-v1-5-2&p=1228337#post1228337

The errormessages posted by the OP are not like the message(s) reported in the above thread. While agree that mysqli would need to be activated from here on out and good to see reference to that, it doesn't seem to explain the conditions that were reported a couple of times: blank database no problem, restore/upgrade database intermittent/continuous notification.

Btw, if hadn't identified it, plugins that had been installed to this new store may need to be "reinstalled" at least to update the configurations table with the settings applicable.

ZC Installation/Maintenance Support <- Site
Contribution for contributions welcome...

18 Sep 2014, 12:08 AM
#27
vanhorn_s avatar

vanhorn_s

Zen Follower

Join Date:
Apr 2010
Posts:
283
Plugin Contributions:
0

Re: PHP Warning: mysqli_connect(): (28000/1045)

mc12345678:

The errormessages posted by the OP are not like the message(s) reported in the above thread. While agree that mysqli would need to be activated from here on out and good to see reference to that, it doesn't seem to explain the conditions that were reported a couple of times: blank database no problem, restore/upgrade database intermittent/continuous notification.

Btw, if hadn't identified it, plugins that had been installed to this new store may need to be "reinstalled" at least to update the configurations table with the settings applicable.

I got it set up the way I wanted, then switched the live store over to the test database, and the error came back, so now I am installing all of the addons to the test site one at a time, until the error pops up, to see what triggers it. If it never pops up, then I will have to delete everything from the main site, and copy the test site over to see what happens.

16 Feb 2015, 6:43 PM
#28
khe817 avatar

khe817

New Zenner

Join Date:
Sep 2014
Location:
NH, USA
Posts:
1
Plugin Contributions:
0

Re: PHP Warning: mysqli_connect(): (28000/1045)

Hi vanhorn_s, I got the same problem as yours. Did you figure out what was wrong with it yet? If so, please share the wisdom.

Thanks,

17 Feb 2015, 3:24 AM
#29
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: PHP Warning: mysqli_connect(): (28000/1045)

khe817:

Hi vanhorn_s, I got the same problem as yours. Did you figure out what was wrong with it yet? If so, please share the wisdom.

Thanks,
There were several aspects to vanhorn_s's situation. Which specific aspect are you encountering?
Actually, how about supplying the exact error messages you are getting, along with a list of all the plugins you're using, as well as your Zen Cart version and PHP version, and your URL.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

17 Sep 2015, 3:40 PM
#30
vanhorn_s avatar

vanhorn_s

Zen Follower

Join Date:
Apr 2010
Posts:
283
Plugin Contributions:
0

Re: PHP Warning: mysqli_connect(): (28000/1045)

I forgot about this until yesterday, when I did the new security patch, and noticed that I had an old 1.3.8 security patch installed, so I removed that old patch, and emptied out my log folder, which took forever, because this error was setting every time any page was clicked, even by bots. Of course, removing the old patch did nothing, but I googled the error, and found a post on here with the same error, and it recommended installing lat9's MyDebug Backtrace: http://www.zen-cart.com/downloads.php?do=file&id=1879

Lo, and behold, I got the same exact error, and it turns out that phpbb was enabled, but I got rid of it about 3 years ago, because it was more trouble than it was worth. Disabling phpbb in the configuration/my store settings cured this error.

Here is the post that helped me so much: https://www.zen-cart.com/showthread.php?216390-PHP-Warning-mysqli_connect%28%29-%2828000-1045%29