Zen Cart Logo
Forums / General Questions / Double URL's and no formatting.

Double URL's and no formatting.

Views: 2,894

Results 21 to 26 of 26
23 Jun 2015, 1:07 AM
#21
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Double URL's and no formatting.

lot49:

Here's my last Debug log:

[11-Jun-2015 23:47:02 America/Chicago] PHP Parse error: syntax error, unexpected '.', expecting '{' in /home2/studio66/public_html/perspicuus.com/includes/modules/shipping/U.S.php on line 11

  1. Although this error needs to be rectified, I'm not convinced it is the cause of your problem.

  2. "U.S.php" is NOT the name of any of the standard shipping modules that I'm aware of, so where did this come from?

  3. Because you have 'non standard' code here makes me wonder what other non-standard code you have that could be the cause of the problem.

lot49:

I did try disabling the SSL by turning them to false but it made no difference.

Fair enough. I assume you cleared your browser cache after making this change though?

Did you leave the SSL disabled, or have you enabled it again? Why?

Was there a reason why you only gave the last line from the log file. What about the preceding lines, perhaps it is one of those that holds a better clue for us to follow? It's not unusual for errors to 'cascade', meaning that the last error is often a direct result of a preceding error. IOW, the error message supplied is just a symptom of the problem, not necessarily the cause.

More info needed.

Cheers
RodG

NOTE: We are sorry that Rod is no longer with us.
We are grateful for all his contributions to the Zen Cart community.

Ozpost - The Ultimate Shipping module for Australian Merchants. Click these links for its Homepage, or Download from Zen-Cart.com.

23 Jun 2015, 6:11 AM
#22
lot49 avatar

lot49

New Zenner

Join Date:
Oct 2014
Location:
New Westminster, B.C. CANADA
Posts:
34
Plugin Contributions:
0

Re: Double URL's and no formatting.

Hi,

Yes, after I removed the 'true' for the SSL, I cleared the browser cache before I tried - still nothing.

Here's the first debug log:
[11-May-2015 22:59:42] PHP Parse error: syntax error, unexpected T_STATIC in /home2/studio66/public_html/demo/admin/includes/classes/class.admin.zcObserverLogEventListener.php on line 118
This one I believe is regarding the php level of the server. I have confirmed it's 5.4, and this log was also from before I did the re-install.

Second debug log:
[08-Jun-2015 23:30:55 America/Chicago] PHP Fatal error: 1062:Duplicate entry '75f68f57fcf716952a35a827a84b7789' for key 'PRIMARY' :: insert into sessions
values ('75f68f57fcf716952a35a827a84b7789', '1433825155', 'c2VjdXJpdHlUb2tlbnxzOjMyOiI3ZDlhOGJhNDlmZTEwNGIxMDI3OGVlOTYxM2NhNjI1MiI7bGFuZ3VhZ2V8czo3OiJlbmdsaXNoIjtsYW5ndWFnZXNfaWR8czoxOiIxIjtsYW5ndWFnZXNfY29kZXxzOjI6ImVuIjtzZWxlY3RlZF9ib3h8czoxMzoiY29uZmlndXJhdGlvbiI7') ==> (as called by) /home2/studio66/public_html/perspicuus.com/includes/functions/sessions.php on line 77 <== in /home2/studio66/public_html/perspicuus.com/includes/classes/db/mysql/query_factory.php on line 155

Third debug log:
[11-Jun-2015 23:13:48 America/Chicago] PHP Parse error: syntax error, unexpected '-', expecting '{' in /home2/studio66/public_html/perspicuus.com/includes/modules/shipping/Shipping-CANADA.php on line 11]

The rest of the debug logs are:
[11-Jun-2015 23:47:02 America/Chicago] PHP Parse error: syntax error, unexpected '.', expecting '{' in /home2/studio66/public_html/perspicuus1/includes/modules/shipping/U.S.php on line 11

The shipping modules are categoriesitem.php, categoriesitem2.php, and categoriesitem3.php, for zones Canada, U.S. and Int'l. These names are only in the admin (Canada, U.S. Int'l).
Ajeh modified the one file for me and I cloned it to make the other 2 zones. WhenI look at the file with textwrangler I don't see what the problem is on line 11. ? (see picture)

Attachment #15389

23 Jun 2015, 10:54 AM
#23
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Double URL's and no formatting.

The "first" mydebug log confirms that PHP 5.2 is being seen at the website. Can "confirm" by creating a file that displays phpinfo. An example would be:

phpinfo.php:

<?php echo phpinfo(); ?>

For action to resolve the immediate issue (access admin) see: http://www.zen-cart.com/showthread.php?215694-Known-Bugs-%28and-fixes%29-with-v1-5-4

For php resolution, recommend identifying your host so that the proper guidance may be provided to present ZC the PHP version that shows in your cPanel.

ZC Installation/Maintenance Support <- Site
Contribution for contributions welcome...

23 Jun 2015, 10:55 PM
#24
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: Double URL's and no formatting.

lot49:

Yes, after I removed the 'true' for the SSL, I cleared the browser cache before I tried - still nothing.

Trying to get blood out of a stone here.

Did you leave the SSL disabled, or have you enabled it again? Why?

lot49:

Third debug log:
[11-Jun-2015 23:13:48 America/Chicago] PHP Parse error: syntax error, unexpected '-', expecting '{' in /home2/studio66/public_html/perspicuus.com/includes/modules/shipping/Shipping-CANADA.php on line 11]

The rest of the debug logs are:
[11-Jun-2015 23:47:02 America/Chicago] PHP Parse error: syntax error, unexpected '.', expecting '{' in /home2/studio66/public_html/perspicuus1/includes/modules/shipping/U.S.php on line 11

These are the only ones of relevance. Those from before the re-install are worse than useless.

Were there no others?

lot49:

The shipping modules are categoriesitem.php, categoriesitem2.php, and categoriesitem3.php,

So, why is the error log indicating that there is a syntax error in a file called "U.S.php".

I can guarantee that Zen-Cart didn't 'invent' this file or pluck the name out of thin air.

lot49:

for zones Canada, U.S. and Int'l. These names are only in the admin (Canada, U.S. Int'l).

Again, where did the file called "U.S.php" come from. Why does it even exist?

lot49:

Ajeh modified the one file for me and I cloned it to make the other 2 zones. WhenI look at the file with textwrangler I don't see what the problem is on line 11. ? (see picture)

The picture shows the contents of the file "categoriesitem2.php" - Why are you looking at that file, when the error log clearly indicates that the error is in the file /includes/modules/shipping/U.S.php ?

Same deal with the other relevant error message
PHP Parse error: syntax error, unexpected '-', expecting '{' in /home2/studio66/public_html/perspicuus.com/includes/modules/shipping/Shipping-CANADA.php on line 11]

Where does the file "CANADA.php" enter into the picture when your shipping modules are (apparently) called categoriesitem.php, categoriesitem2.php, and categoriesitem3.php?

Exactly what are the names of the files in your /modules/shipping/ folder?

If you have
categoriesitem.php
categoriesitem2.php
categoriesitem3.php
U.S.php
CANADA.php

Then the first thing I'm going to suggest is that you remove the U.S.php and CANADA.php files because clearly they have an error in the code. That is what the error logs are telling you, and your own comments indicate that the correct files (the ones not creating an error message) are the categoriesitem.php, categoriesitem2.php, and categoriesitem3.php files.

Having said that, I'm still not 100% convinced that these errors are going to be the cause of your login issue. However, it is currently the only thing we have to work with, which is why you need to resolve these before looking into any login issues.

Cheers
RodG

NOTE: We are sorry that Rod is no longer with us.
We are grateful for all his contributions to the Zen Cart community.

Ozpost - The Ultimate Shipping module for Australian Merchants. Click these links for its Homepage, or Download from Zen-Cart.com.

24 Jun 2015, 7:48 AM
#25
lot49 avatar

lot49

New Zenner

Join Date:
Oct 2014
Location:
New Westminster, B.C. CANADA
Posts:
34
Plugin Contributions:
0

Re: Double URL's and no formatting.

Hi,

Yes, my SSL is still disabled and my site is still not working.

I apologize for the confusion but was trying to focus on what I thought the problem was - the PHP Parse error/syntax error on line 11 in the shipping modules php file rather than the name of the file. The file was called U.S.php at the time, and I have changed it back to categoriesitem2.php, which is a clone of categoriesitem.php (once called Shipping-CANADA.php). I believe the PHP Parse error: syntax error on line 11 is still there despite the name change.

There are no other debug files.

I think I may just create a brand new fresh install as a test, get it to work, then change things over like an upgrade and see how it goes.

Thanks,

Todd

24 Jun 2015, 9:15 PM
#26
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: Double URL's and no formatting.

lot49:

Yes, my SSL is still disabled and my site is still not working.

That's good/fine. Please keep it this way until all other problems have been solves (it eliminates a lot of possible causes for your problems)

lot49:

I apologize for the confusion

There is nothing 'personal' involved here. No apologies needed.

lot49:

but was trying to focus on what I thought the problem was -

I understand that, but when it comes to what a person thinks, and what computer software states, I tend to trust the computer more than the person. Computers are far more predicable.

lot49:

the PHP Parse error/syntax error on line 11 in the shipping modules php file rather than the name of the file.

The lesson here is that filenames are important. Never overlook this fact.

lot49:

The file was called U.S.php at the time, and I have changed it back to categoriesitem2.php, which is a clone of categoriesitem.php (once called Shipping-CANADA.php). I believe the PHP Parse error: syntax error on line 11 is still there despite the name change.

There are no other debug files.

1). What you 'believe' is unimportant. The computer doesn't care about beliefs. It only 'knows' what it has be programmed to know.
2). If the error IS still there after the name change, then there will be a NEW log entry that reads like:
*
[11-Jun-2015 23:47:02 America/Chicago] PHP Parse error: syntax error, unexpected '.', expecting '{' in /home2/studio66/public_html/perspicuus1/includes/modules/shipping/
categoriesitem.php on line 11*

(or whatever the new name is). Is there such a log entry?

lot49:

I think I may just create a brand new fresh install as a test, get it to work, then change things over like an upgrade and see how it goes.

Seems like a lot of work to solve this particular problem, and there is no assurance that this will resolve the issue anyway.

So, assuming you haven't started this yet, you do realise that all of the shipping modules are optional don't you? So, on that basis, why not delete all of them (make backups first). A file that doesn't exist cannot produce a syntax error. At worse, it will be replaced by a new error saying the file(s) couldn't be found.

Note: This is now the second time I've suggested you do this. What is the point of making suggestions if you are simply going to ignore them and keep trying to re-install time and time again? It's almost as if you don't want us to help you find the cause of the problem(s).

I can appreciate that you may not see the benefit of the suggestions, but I'm making them with a good reason and purpose in mind. The suggestion(s) may not give the instant resolution you seek, but they are designed to move us in a forward direction, yet you seem to want to go backwards all the time.

I'd much rather you follow the instructions than to apologise for not following them.

If you proceed with your current idea of creating afresh you'll simply end up re-installing your modified files and you'll be right back to where you are now.

One other thing that I am finding of 'interest' though is that since you have cloned thecategoriesitem.php (and ignoring the naming confusion), I ask myself (as you should) WHY is the error message for the Shipping-CANADA.php file different than the error reported for the "*U.S.php" file? *

This is telling me that they aren't quite clones, else you'd be getting the same error for each.

SO, after you have deleted the shipping module files and confirm that there are no more error messages of this nature (and I'm certain that this will be the case), your next step would be tackle the admin login problem (if it still exists).

Then after you can log in, you should replace the files you deleted (which may or may not break the admin login again) and re-check the log files, and you'll probably find the syntax errors have returned.

I'll give further instructions and steps to take when you have performed these steps and report back what the error logs are telling us.

Should you decide to re-install yet again I will consider this thread closed because the moment you do this, all previous discussion, suggestions, and error reports become null and void. I would suggest you open a new thread.

Cheers
RodG

NOTE: We are sorry that Rod is no longer with us.
We are grateful for all his contributions to the Zen Cart community.

Ozpost - The Ultimate Shipping module for Australian Merchants. Click these links for its Homepage, or Download from Zen-Cart.com.