lot49:
Yes, my SSL is still disabled and my site is still not working.
That's good/fine. Please keep it this way until all other problems have been solves (it eliminates a lot of possible causes for your problems)
lot49:
I apologize for the confusion
There is nothing 'personal' involved here. No apologies needed.
lot49:
but was trying to focus on what I thought the problem was -
I understand that, but when it comes to what a person thinks, and what computer software states, I tend to trust the computer more than the person. Computers are far more predicable.
lot49:
the PHP Parse error/syntax error on line 11 in the shipping modules php file rather than the name of the file.
The lesson here is that filenames are important. Never overlook this fact.
lot49:
The file was called U.S.php at the time, and I have changed it back to categoriesitem2.php, which is a clone of categoriesitem.php (once called Shipping-CANADA.php). I believe the PHP Parse error: syntax error on line 11 is still there despite the name change.
There are no other debug files.
1). What you 'believe' is unimportant. The computer doesn't care about beliefs. It only 'knows' what it has be programmed to know.
2). If the error IS still there after the name change, then there will be a NEW log entry that reads like:
*
[11-Jun-2015 23:47:02 America/Chicago] PHP Parse error: syntax error, unexpected '.', expecting '{' in /home2/studio66/public_html/perspicuus1/includes/modules/shipping/categoriesitem.php on line 11*
(or whatever the new name is). Is there such a log entry?
lot49:
I think I may just create a brand new fresh install as a test, get it to work, then change things over like an upgrade and see how it goes.
Seems like a lot of work to solve this particular problem, and there is no assurance that this will resolve the issue anyway.
So, assuming you haven't started this yet, you do realise that all of the shipping modules are optional don't you? So, on that basis, why not delete all of them (make backups first). A file that doesn't exist cannot produce a syntax error. At worse, it will be replaced by a new error saying the file(s) couldn't be found.
Note: This is now the second time I've suggested you do this. What is the point of making suggestions if you are simply going to ignore them and keep trying to re-install time and time again? It's almost as if you don't want us to help you find the cause of the problem(s).
I can appreciate that you may not see the benefit of the suggestions, but I'm making them with a good reason and purpose in mind. The suggestion(s) may not give the instant resolution you seek, but they are designed to move us in a forward direction, yet you seem to want to go backwards all the time.
I'd much rather you follow the instructions than to apologise for not following them.
If you proceed with your current idea of creating afresh you'll simply end up re-installing your modified files and you'll be right back to where you are now.
One other thing that I am finding of 'interest' though is that since you have cloned thecategoriesitem.php (and ignoring the naming confusion), I ask myself (as you should) WHY is the error message for the Shipping-CANADA.php file different than the error reported for the "*U.S.php" file? *
This is telling me that they aren't quite clones, else you'd be getting the same error for each.
SO, after you have deleted the shipping module files and confirm that there are no more error messages of this nature (and I'm certain that this will be the case), your next step would be tackle the admin login problem (if it still exists).
Then after you can log in, you should replace the files you deleted (which may or may not break the admin login again) and re-check the log files, and you'll probably find the syntax errors have returned.
I'll give further instructions and steps to take when you have performed these steps and report back what the error logs are telling us.
Should you decide to re-install yet again I will consider this thread closed because the moment you do this, all previous discussion, suggestions, and error reports become null and void. I would suggest you open a new thread.
Cheers
RodG
NOTE: We are sorry that Rod is no longer with us.
We are grateful for all his contributions to the Zen Cart community.
Ozpost - The Ultimate Shipping module for Australian Merchants. Click these links for its Homepage, or Download from Zen-Cart.com.