Zen Cart Logo
Forums / Upgrading to 1.5.x / Site is gone

Site is gone

Views: 3,306

Results 1 to 20 of 26
14 Nov 2015, 9:52 AM
#1
ericawilma_hissink avatar

ericawilma_hissink

New Zenner

Join Date:
Nov 2015
Location:
Netherlands
Posts:
12
Plugin Contributions:
0

Site is gone

Mine host have upgraded there php.. then mine store was gone i had zen 1.5 ...
they sayd to me upgrade

I have done now the upgrade to 1.5.4 but still the store is ofline .. the host have looked into it .. and i got this messages

**Here is the actual error for the 500 error that is showing:

[Fri Nov 13 02:02:23 2015] [error] [client 69.36.160.253] Failed loading /usr/local/Zend/lib/Guard-7.0.0/php-5.6.x/ZendGuardLoader.so: /usr/local/Zend/lib/Guard-7.0.0/php-5.6.x/ZendGuardLoader.so: cannot open shared object file: No such file or directory**

Someone from the Zencart Facebook groups said to me

that would be a problem with your server and php 5.6. Zen cart is not throwing this error

so i told that to the host .. then i got this message ..

Due to the recent upgrades to php on the servers, something may have happened where the ZenCart you were running was no longer compatible with the newer version. With the upgrade to a more current version of php, you would need to make sure that a developer looks at it and gets it running. The php on the server cannot be changed or modified, as it would affect everyone on the server, not just this account. A developer should be able to help you modify your ZenCart installation so that it is compatible with the more current

so you understand i feel left allone by the host ... 3 years no problems and now everything is gone ... :(
what can i do ??
must i go to another host and transfer everything ????

14 Nov 2015, 10:17 AM
#2
frank18 avatar

frank18

Deceased

Join Date:
Nov 2007
Location:
Sunny Coast, Australia
Posts:
3,427
Plugin Contributions:
2

Re: Site is gone

If you are on ZC 1.5.4 then me thinks it may be some setting in your cPanel PHP configuration which causes that error.

Who is your host?

Which PHP version is configured?

14 Nov 2015, 10:28 AM
#3
frank18 avatar

frank18

Deceased

Join Date:
Nov 2007
Location:
Sunny Coast, Australia
Posts:
3,427
Plugin Contributions:
2

Re: Site is gone

In cPanel, under "Select PHP Version", check if zend_guard_loader is enabled or disabled.

14 Nov 2015, 11:02 AM
#4
ericawilma_hissink avatar

ericawilma_hissink

New Zenner

Join Date:
Nov 2015
Location:
Netherlands
Posts:
12
Plugin Contributions:
0

Re: Site is gone

frank18:

If you are on ZC 1.5.4 then me thinks it may be some setting in your cPanel PHP configuration which causes that error.

Who is your host?

Which PHP version is configured?

Mine Host is Midphase
they have php 5.6 since 3 days

14 Nov 2015, 11:05 AM
#5
ericawilma_hissink avatar

ericawilma_hissink

New Zenner

Join Date:
Nov 2015
Location:
Netherlands
Posts:
12
Plugin Contributions:
0

Re: Site is gone

frank18:

In cPanel, under "Select PHP Version", check if zend_guard_loader is enabled or disabled.

i see in cpanel not select php version

the only thing i see with php is phpmyadmin and php configuration

14 Nov 2015, 11:12 AM
#6
frank18 avatar

frank18

Deceased

Join Date:
Nov 2007
Location:
Sunny Coast, Australia
Posts:
3,427
Plugin Contributions:
2

Re: Site is gone

EricaWilma Hissink:

i see in cpanel not select php version

the only thing i see with php is phpmyadmin and php configuration

Try to open "php configuration" and report what you are seeing there.

14 Nov 2015, 11:21 AM
#7
ericawilma_hissink avatar

ericawilma_hissink

New Zenner

Join Date:
Nov 2015
Location:
Netherlands
Posts:
12
Plugin Contributions:
0

Re: Site is gone

Attachment 15793 Here you are

14 Nov 2015, 11:33 AM
#8
frank18 avatar

frank18

Deceased

Join Date:
Nov 2007
Location:
Sunny Coast, Australia
Posts:
3,427
Plugin Contributions:
2

Re: Site is gone

Unfortunately that does not help us much.

Could you ask your host if zend_guard_loader is enabled or disabled. If it is enabled for your site please ask them to disable it, then see if your site loads.

14 Nov 2015, 11:35 AM
#9
ericawilma_hissink avatar

ericawilma_hissink

New Zenner

Join Date:
Nov 2015
Location:
Netherlands
Posts:
12
Plugin Contributions:
0

Re: Site is gone

ok i wil do that

14 Nov 2015, 11:38 AM
#10
frank18 avatar

frank18

Deceased

Join Date:
Nov 2007
Location:
Sunny Coast, Australia
Posts:
3,427
Plugin Contributions:
2

Re: Site is gone

EricaWilma Hissink:

....
so i told that to the host .. then i got this message ..

Due to the recent upgrades to php on the servers, something may have happened where the ZenCart you were running was no longer compatible with the newer version. With the upgrade to a more current version of php, you would need to make sure that a developer looks at it and gets it running. The php on the server cannot be changed or modified, as it would affect everyone on the server, not just this account. A developer should be able to help you modify your ZenCart installation so that it is compatible with the more current

.....

You may also want to point your host to this FAQ: https://www.zen-cart.com/content.php?48-what-are-the-server-requirements-to-run-zen-cart

ZC 1.5.4 works fine on PHP 5.6

14 Nov 2015, 12:05 PM
#11
ericawilma_hissink avatar

ericawilma_hissink

New Zenner

Join Date:
Nov 2015
Location:
Netherlands
Posts:
12
Plugin Contributions:
0

Re: Site is gone

ok i do that

14 Nov 2015, 12:28 PM
#12
ericawilma_hissink avatar

ericawilma_hissink

New Zenner

Join Date:
Nov 2015
Location:
Netherlands
Posts:
12
Plugin Contributions:
0

Re: Site is gone

Thank you for contacting Midphase Technical Support! Yes we do have the PHP module zend_guard_loader enabled on our shared hosting server. We are not able to disable it though because this is a server wide module used by many other clients that you share this server with. If we disable this for you it is disabled for all clients on this server.

14 Nov 2015, 1:33 PM
#13
ericawilma_hissink avatar

ericawilma_hissink

New Zenner

Join Date:
Nov 2015
Location:
Netherlands
Posts:
12
Plugin Contributions:
0

Re: Site is gone

seems that they can't or won't do something

is there something to do in the zencart ?
or better to move to other host?

14 Nov 2015, 2:30 PM
#14
ericawilma_hissink avatar

ericawilma_hissink

New Zenner

Join Date:
Nov 2015
Location:
Netherlands
Posts:
12
Plugin Contributions:
0

Re: Site is gone

They keep by what they say the fault is in the scripting

** I am sorry about the issues you are having but this is not a server issue. We provided you all the information that we could about the problems you are having. There errors I have provided you in my previous response are caused by scripting issues which is not something that our Tech Support team helps correct.

Here are the errors that I have given you before:

[Fri Nov 13 02:02:23 2015] [error] [client 69.36.160.253] Failed loading
/usr/local/Zend/lib/Guard-7.0.0/php-5.6.x/ZendGuardLoader.so:
/usr/local/Zend/lib/Guard-7.0.0/php-5.6.x/ZendGuardLoader.so: cannot open shared object
file: No such file or directory**

Really strange that before they go to the new php there where no problems and now there are

14 Nov 2015, 11:22 PM
#15
frank18 avatar

frank18

Deceased

Join Date:
Nov 2007
Location:
Sunny Coast, Australia
Posts:
3,427
Plugin Contributions:
2

Re: Site is gone

EricaWilma Hissink:

They keep by what they say the fault is in the scripting

** I am sorry about the issues you are having but this is not a server issue. We provided you all the information that we could about the problems you are having. There errors I have provided you in my previous response are caused by scripting issues which is not something that our Tech Support team helps correct.

Here are the errors that I have given you before:

[Fri Nov 13 02:02:23 2015] [error] [client 69.36.160.253] Failed loading
/usr/local/Zend/lib/Guard-7.0.0/php-5.6.x/ZendGuardLoader.so:
/usr/local/Zend/lib/Guard-7.0.0/php-5.6.x/ZendGuardLoader.so: cannot open shared object
file: No such file or directory**

Really strange that before they go to the new php there where no problems and now there are

Thanks for the update. I thought that was the case.... looks like they still have a bit to learn such as providing cPanels which are not skimmed down to the barest.

I would change to a host who understands ZenCart (and other systems for that matter). This link will give you a lead: https://www.zen-cart.com/content.php?3-recommended-services - there is a good host in the UK, can't mention any names here as we are not allowed to advertise. FYG, I am not affiliated with any of those listed.

Please keep us updated.

Cheers / Frank

15 Nov 2015, 12:09 AM
#16
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: Site is gone

EricaWilma Hissink:

Thank you for contacting Midphase Technical Support! Yes we do have the PHP module zend_guard_loader enabled on our shared hosting server. We are not able to disable it though because this is a server wide module used by many other clients that you share this server with. If we disable this for you it is disabled for all clients on this server.

Please inform your host that you don't want them to disable it for you.

What you want them to do is fix their currently broken installation of it.

If they can't fix it THEN they should perhaps consider disabling it.

Here's the deal, to the best of my knowledge, neither ZenCart or any of its publically available modules need or use Zend (some commercial modules do though), so if we assume that you **aren't **using any modules that need Zend, then whether Zend is installed by the host or not is a moot point.

If it is installed and working, it just isn't going to be used by your store, therefore there wouldn't be any problem.

The problem you are having is that even though you are not needing Zend (assumedly), the server is still trying to load the module, and is failing due to
**"/usr/local/Zend/lib/Guard-7.0.0/php-5.6.x/ZendGuardLoader.so: cannot open shared object file: No such file or directory"
**This is a server configuration issue. It has nothing to do with ZenCart whatsoever.

Just in case I've not made it 100% clear - Whether you are using a module that needs Zend or not is a moot point. The error isn't yours to fix. The server itself is busted. The host needs to fix it.

Cheers
RodG

Tip: Send a copy of the bolded error line to your host - with a simple comment 'please fix'. No other explanation will be needed

15 Nov 2015, 12:35 AM
#17
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: Site is gone

EricaWilma Hissink:

They keep by what they say the fault is in the scripting

** I am sorry about the issues you are having but this is not a server issue. We provided you all the information that we could about the problems you are having. There errors I have provided you in my previous response are caused by scripting issues which is not something that our Tech Support team helps correct.

Here are the errors that I have given you before:

[Fri Nov 13 02:02:23 2015] [error] [client 69.36.160.253] Failed loading
/usr/local/Zend/lib/Guard-7.0.0/php-5.6.x/ZendGuardLoader.so:
/usr/local/Zend/lib/Guard-7.0.0/php-5.6.x/ZendGuardLoader.so: cannot open shared object
file: No such file or directory**

Really strange that before they go to the new php there where no problems and now there are

You could try to be a little cheeky, and request that they give you access and permissions to write to their **/usr/local/Zend/ **folder so that you can install the missing ZenGuardLoader.so file to resolve the problem that they imply is your problem and something they can't help with.

As they previously stated though, Zend is a server wide implementation (as is the location of the missing file) I very much doubt that they will call your bluff on this due to the security implications.

Frankly, I'm quite astounded that they've been giving you the responses that they have. Their apparent lack of knowledge goes beyond belief. I can't recall the last time I've seen such an idiotic response from a host (and trust me, I've seen a lot).

OTOH, for $2.36 per month for hosting this is the kind of response to be expected (Not that paying premium prices is any guarantee of anything better)

Cheers
RodG

15 Nov 2015, 12:57 AM
#18
frank18 avatar

frank18

Deceased

Join Date:
Nov 2007
Location:
Sunny Coast, Australia
Posts:
3,427
Plugin Contributions:
2

Re: Site is gone

RodG:

You could try to be a little cheeky, and request that they give you access and permissions to write to their **/usr/local/Zend/ **folder so that you can install the missing ZenGuardLoader.so file to resolve the problem that they imply is your problem and something they can't help with.

As they previously stated though, Zend is a server wide implementation (as is the location of the missing file) I very much doubt that they will call your bluff on this due to the security implications.

Frankly, I'm quite astounded that they've been giving you the responses that they have. Their apparent lack of knowledge goes beyond belief. I can't recall the last time I've seen such an idiotic response from a host (and trust me, I've seen a lot).

OTOH, for $2.36 per month for hosting this is the kind of response to be expected (Not that paying premium prices is any guarantee of anything better)

Cheers
RodG

That's exactly what I thought when I looked at that host's site last night - thanks for confirming this RodG!!

15 Nov 2015, 1:02 AM
#19
frank18 avatar

frank18

Deceased

Join Date:
Nov 2007
Location:
Sunny Coast, Australia
Posts:
3,427
Plugin Contributions:
2

Re: Site is gone

RodG:

Please inform your host that you don't want them to disable it for you.

What you want them to do is fix their currently broken installation of it.

If they can't fix it THEN they should perhaps consider disabling it.

Here's the deal, to the best of my knowledge, neither ZenCart or any of its publically available modules need or use Zend (some commercial modules do though), so if we assume that you **aren't **using any modules that need Zend, then whether Zend is installed by the host or not is a moot point.

If it is installed and working, it just isn't going to be used by your store, therefore there wouldn't be any problem.

The problem you are having is that even though you are not needing Zend (assumedly), the server is still trying to load the module, and is failing due to
**"/usr/local/Zend/lib/Guard-7.0.0/php-5.6.x/ZendGuardLoader.so: cannot open shared object file: No such file or directory"
**This is a server configuration issue. It has nothing to do with ZenCart whatsoever.

Just in case I've not made it 100% clear - Whether you are using a module that needs Zend or not is a moot point. The error isn't yours to fix. The server itself is busted. The host needs to fix it.

Cheers
RodG

Tip: Send a copy of the bolded error line to your host - with a simple comment 'please fix'. No other explanation will be needed

And if they still deny that it is their problem then move to another host. They are obviously not capable or are unwilling to run a fully functional server!

15 Nov 2015, 1:06 AM
#20
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: Site is gone

EricaWilma Hissink:

The php on the server cannot be changed or modified, as it would affect everyone on the server, not just this account.

Sorry about belaboring the point, but this is another example of their cluelessness. Almost every host on the planet supports multiple versions of PHP on the same server these days. Some of them even allow the user to select the version of their choice via their Cpanel, others require the selection to be performed via the php.ini file.

Any host that doesn't allow the user to select PHP version and forces the latest version(s) on all users should be avoided. They need a way to allow their customers time to upgrade whatever software is being used to be compatible with their upgrades rather than installing something that can/will crash the customers sites without warning and without a grace period to rectify the issues.

Run, don't walk to another host. At the moment they haven't given you the option to do anything else.

Please note, that if you move to/from hosts that both use the 'Cpanel' management system (most of them these days), the migration to the new site is going to be far quicker and far easier you could imagine. You will need to do the cPanel backup/export (a couple of keypresses) and the host you migrate too will generally let you upload the backup file (already zipped) to the root folder of the new account, where they will run the scripts needed to extract and restore your entire site (That's WebPages, Databases, Email accounts, email filters and pretty much everything else) on the new site. You will need to do nothing. It's almost like magic (and that is a word I rarely use when it comes to computers).

So far, not one of the hosts I've used (migrated sites too) have ever had a charge for performing this service. I suggest you ask about this before signing up for a new account though, just on the off chance that you select another host without a clue.

Cheers
RodG