Forums / Installing on a Linux/Unix Server / Unable to login to admin area

Unable to login to admin area

Views: 21,520

Results 1 to 20 of 35
26 May 2006, 6:11 PM
#1
earthsfibres avatar

earthsfibres

New Zenner

Join Date:
May 2006
Posts:
4
Plugin Contributions:
0

Unable to login to admin area

Greetings!

I am trying to setup a website for my hemp clothing business and can't manage to log into the admin area.

CATALOG link: https://www.earthsfibres.ca (catalog is in the root)
ADMIN link: https://www.earthsfibres.ca/admin/index.php
TECH SUPPORT link: https://www.earthsfibres.ca/zc_install_complete/techsupp.php

[EDIT: ADMIN INFO DELETED]

  • I have just installed Zen Cart on a Linux server running Apache. https://www.blacksun.ca

  • The store itself loads fine and there are no error messages.

  • When I try and log into ADMIN I put in my user name and password and hit login there is no error message that appears, the admin area does not load, and my user name I just typed in along with the pwd gets erased. Essentially I am left with a fresh login page to the Admin area.

  • resending my admin password does not work either

  • I have also noticed that I am unable to create users on the main site... when I fill out all the info and hit send or ok there is no error or confirmation that is displayed... again I get left with a blank form again... as if I had not entered anything at all.

  • I have also tried renaming the .htaccess in the admin/includes directory but that has not helped

  • I have also tried reinstalling to make sure the password was correct, although it should give an error message if the password was wrong

  • I have also tried turning off the auto update checker in the ski_version_check.ini file....

If I think of or try anything else I will post it.

I have also read the info on this site regarding having no firewalls and making sure that the browsers cash is clean... accepts cookies and that is not the case here.

I also know that the Database was created successfully and that there is a record for my admin account.

Any help would be greatfully accepted.

Cheers.
~ Jano.

26 May 2006, 6:18 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Unable to login to admin area

open your /admin/includes/configure.php file and set the 2 SSL definitions to 'false'
then try again.
Trying to rule out SSL for the time being.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

26 May 2006, 7:52 PM
#3
earthsfibres avatar

earthsfibres

New Zenner

Join Date:
May 2006
Posts:
4
Plugin Contributions:
0

Re: Unable to login to admin area

Sorry about the double post... I'm having internet problems here at work...

I got page can't be displayed and assumed it was not posted

I'll try your suggested course of action and let you know what happens.

Thank you.
~ Jano.

26 May 2006, 8:00 PM
#4
earthsfibres avatar

earthsfibres

New Zenner

Join Date:
May 2006
Posts:
4
Plugin Contributions:
0

Re: Unable to login to admin area

Ok Dr Byte that worked... thank you.

now I have to figure out why SSL is not working.

~Jano.

11 Jul 2007, 6:43 PM
#5
nvmsys avatar

nvmsys

New Zenner

Join Date:
Jul 2007
Posts:
1
Plugin Contributions:
0

Re: Unable to login to admin area

oddly enough, I'm experiencing a similar problem (the site is in dev, so not publicly visible). However, disabling SSL did absolutely nothing. When I try to login, a bad user/pass gives me the appropriate message, but a valid user/pass just returns me to the login screen, with no error on the page, nor any errors (SSL or otherwise) in the web server logs.

18 Jul 2007, 6:54 PM
#6
enewbold avatar

enewbold

New Zenner

Join Date:
Jul 2007
Location:
Columbus, OH
Posts:
11
Plugin Contributions:
0

Re: Unable to login to admin area

nvmsys:

oddly enough, I'm experiencing a similar problem (the site is in dev, so not publicly visible). However, disabling SSL did absolutely nothing. When I try to login, a bad user/pass gives me the appropriate message, but a valid user/pass just returns me to the login screen, with no error on the page, nor any errors (SSL or otherwise) in the web server logs.

Me too. Same darned problem! Don't know where to go from here! (sigh...)

26 Jul 2007, 7:31 PM
#7
ehtraveler avatar

ehtraveler

New Zenner

Join Date:
Feb 2007
Posts:
10
Plugin Contributions:
0

Re: Unable to login to admin area

Hi there,

In the very simpliest of terms, how can I retreive my admin login? It sent me a new password but that's no useful when I forgot my login.

Any assistance will be GREATLY appreciated!

Sincerely;
Laurie

26 Jul 2007, 9:51 PM
#8
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Unable to login to admin area

ehtraveler:

In the very simpliest of terms, how can I retreive my admin login? It sent me a new password but that's no useful when I forgot my login.

From the FAQ section
https://www.zen-cart.com/tutorials/index.php?article=2

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

9 Aug 2007, 3:06 AM
#9
kardashi avatar

kardashi

New Zenner

Join Date:
Aug 2007
Posts:
2
Plugin Contributions:
0

Re: Unable to login to admin area

earthsfibres:

Greetings!

I am trying to setup a website for my hemp clothing business and can't manage to log into the admin area.

CATALOG link: https://www.earthsfibres.ca (catalog is in the root)
ADMIN link: https://www.earthsfibres.ca/admin/index.php
TECH SUPPORT link: https://www.earthsfibres.ca/zc_install_complete/techsupp.php

[EDIT: ADMIN INFO DELETED]

  • I have just installed Zen Cart on a Linux server running Apache. https://www.blacksun.ca

  • The store itself loads fine and there are no error messages.

  • When I try and log into ADMIN I put in my user name and password and hit login there is no error message that appears, the admin area does not load, and my user name I just typed in along with the pwd gets erased. Essentially I am left with a fresh login page to the Admin area.

  • resending my admin password does not work either

  • I have also noticed that I am unable to create users on the main site... when I fill out all the info and hit send or ok there is no error or confirmation that is displayed... again I get left with a blank form again... as if I had not entered anything at all.

  • I have also tried renaming the .htaccess in the admin/includes directory but that has not helped

  • I have also tried reinstalling to make sure the password was correct, although it should give an error message if the password was wrong

  • I have also tried turning off the auto update checker in the ski_version_check.ini file....

If I think of or try anything else I will post it.

I have also read the info on this site regarding having no firewalls and making sure that the browsers cash is clean... accepts cookies and that is not the case here.

I also know that the Database was created successfully and that there is a record for my admin account.

Any help would be greatfully accepted.

Cheers.
~ Jano.

I have the exact same problem!! i checked both are false... on top of that i tried the same install on 2 different hosts and and it works on one and not the other... and the one it doesnt work on has a newer mysql and phpadmin... also i have the latest and greatest of zencart... its driving me crazy!! :shocking: please help...

9 Aug 2007, 3:31 AM
#10
kardashi avatar

kardashi

New Zenner

Join Date:
Aug 2007
Posts:
2
Plugin Contributions:
0

Re: Unable to login to admin area

also here are the install specs:

*  Webserver = Apache
* HTTP Host = store.nightvisionmall.com
* Path_Translated = /home/httpd/vhosts/store.nightvisionmall.com/httpdocs/opticshq/zc_install/index.php
* Server Free Disk Space = 54.06 GB
* PHP O/S = Linux
* PHP API Mode = apache2filter
* PHP Max Execution Time per page = 30
* Register Globals = OFF
* MySQL Support = ON
* PHP Version = 4.3.2
* PHP Safe Mode = OFF
* PHP Sessions Support = ON
* PHP Session.AutoStart = OFF
* PHP session.use_trans_sid = OFF
* Current SQL Cache Folder = /home/httpd/vhosts/store.nightvisionmall.com/httpdocs/opticshq/cache  -->Writeable
* Suggested SQL Cache Folder = /home/httpd/vhosts/store.nightvisionmall.com/httpdocs/opticshq/cache
* PHP magic_quotes_runtime setting = OFF
* PHP GD Support = ON
* GD Version = GD bundled (2.0.12 compatible)
* PHP ZLIB Compression Support = ON
* PHP OpenSSL Support = ON
* PHP cURL Support = ON
* PHP Upload Support = ON  upload_max_filesize=2M;  post_max_size=8M
* PHP Upload TMP dir =

View PHPINFO for your server
Other System Information (For Reference Only)
The following info does not necessarily indicate any problem or configuration issue. It is simply for the sake of displaying it in an easy-to-find location.

* PHP include_path = .:
* PHP SMTP destination = localhost
* PHP sendmail path = /usr/sbin/sendmail -t -i
* PHP sendmail 'from' = [email protected]
* PHP open_basedir restrictions =
* PHP Output Buffering (gzip) = OFF
* PHP FTP Support = ON
* PHP XML Support = ON
* PHP Session.Save_Path = /tmp  -->Writeable

File and Folder Permissions
In order for many Zen Cart™ administrative and day-to-day functions to work properly, You need to mark several files/folders "Writeable". The following is a list of folders which need to be "read-write", along with recommended CHMOD settings. Please correct these settings before continuing installation. Refresh this page in your browser to re-check settings.

Some hosts may not allow you to set CHMOD 777, but only 666. Start with the higher setting first, and switch to lower values if required.

* includes/configure.php = Writeable
* admin/includes/configure.php = Writeable
*  
* cache = OK
* images = OK
* includes/languages/english/html_includes = OK
* media = OK
* pub = OK
* admin/backups = OK
* admin/images/graphs = OK

PHP Output Buffering (gzip) = OFF
is the only thing that is yellow but its the same on the other host and the other host has even more yellows...

9 Aug 2007, 6:26 AM
#11
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Unable to login to admin area

If you remove it from a subdomain, does it behave any differently?

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

16 Sep 2008, 6:42 PM
#12
batterygenie avatar

batterygenie

New Zenner

Join Date:
May 2008
Location:
Thousand Oaks, CA
Posts:
30
Plugin Contributions:
0

Re: Unable to login to admin area

I also got an error like this once...turns out I had adjusted the php.ini file to -1 in an effort to load a large database when transferring my site to a new hosting provider. Changing the settings back to a number setting like 10M fixed the problem and I was able to login properly again. I'd forgotten about it over the weekend and I spent a day trying to troubleshoot it. Maybe it will help someone to learn from my dumb mistake.

19 Sep 2008, 7:17 PM
#13
daljo628 avatar

daljo628

New Zenner

Join Date:
Sep 2008
Posts:
2
Plugin Contributions:
0

Re: Unable to login to admin area

Arright, I'm having the same problem! It's not on any subdomain, mine is hosted on inflationomics.com/shop -- but whenever I try to login, just like they said, it clears both the username&password and returns to the login page.

My hosting is from apollohosting.com -- any ideas? I can be contacted at [email protected], I'd really appreciate any help you can offer.

19 Sep 2008, 9:15 PM
#14
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Unable to login to admin area

What happens if you set the enable in the:
/admin/includes/configure.php

to false vs true?

Linda McGrath
If you have to think ... you haven't been zenned ...

**Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!**

Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today!]
Officially PayPal-Certified! Just click here

Try our Zen Cart Recommended Services - Hosting, Payment and more ...
Signup for our Announcements Forums to stay up to date on important changes and updates!

22 Sep 2008, 3:42 PM
#15
daljo628 avatar

daljo628

New Zenner

Join Date:
Sep 2008
Posts:
2
Plugin Contributions:
0

Re: Unable to login to admin area

You mean for the SSL? I don't have it on this server, so they're both set to false.

28 Sep 2008, 3:14 AM
#16
snowkrash avatar

snowkrash

New Zenner

Join Date:
Aug 2007
Posts:
65
Plugin Contributions:
0

Re: Unable to login to admin area

I'm having the same problem:

I moved the database, updated the database with the zc_install, everything was working fine. I logged into the admin area with the old admin login the old database and changed it to the new one I wanted. I was able to log in several times and I woke up today, and suddenly, when I try to login, it just returns me to the default login page. If I enter the wrong login info, I get a message that says it's the wrong login info, but when I use the right info, it seems like it simply reloads the page, and I can't access the admin.

I'm going nuts. :frusty:

BTW, I'm not using the SSL yet, so it's all on false. The catalog area is working fine. I have even re-uploaded all my admin directory. I have double-checked the DB username/password/server all matches up from the config files to the only database I have in my hosting account. I am on GoDaddy. I am using cURL. The only thing I did between the last time I logged in successfully and the time I could not was to add images to the images directory, and add styles to the stylesheet.

28 Sep 2008, 4:13 AM
#17
snowkrash avatar

snowkrash

New Zenner

Join Date:
Aug 2007
Posts:
65
Plugin Contributions:
0

Re: Unable to login to admin area

Guess what!

I NEVER thought it would be because my Firefox updated when I restarted Firefox to get a fresh start this morning. I did as many suggested, cleared my cache, deleted my cookies, restarted, and voila! I get right into the admin area!

Grrrr. Can't believe I couldn't login because of a browser update! :yuck:

Thanks

28 Sep 2008, 4:12 PM
#18
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Unable to login to admin area

Thanks for letting us know that this was a browser issue ... :smile:

Linda McGrath
If you have to think ... you haven't been zenned ...

**Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!**

Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today!]
Officially PayPal-Certified! Just click here

Try our Zen Cart Recommended Services - Hosting, Payment and more ...
Signup for our Announcements Forums to stay up to date on important changes and updates!

3 Nov 2009, 3:42 PM
#19
beep avatar

beep

New Zenner

Join Date:
Nov 2008
Location:
London
Posts:
94
Plugin Contributions:
0

Re: Unable to login to admin area

I appear to be having this login problem also;

the site has been up and running for over six months and everything was fine last week. When I tried to login this week I encountered an admin login page which seemed to be redirecting to itself without error.
The SSL are both set to false
I have cleared the browser cache
I have tried login in 3 different browsers
I am unable to contact my web hosts; they appear to be on holiday or something.
:shocking:

Any ideas what the problem might be of what i could do about it?
https://www.queenib.com

3 Nov 2009, 5:55 PM
#20
ik35 avatar

ik35

New Zenner

Join Date:
Nov 2009
Posts:
2
Plugin Contributions:
0

Re: Unable to login to admin area

Im having a problem loggin in...when I go to email password this is the message I get

Warning: sprintf() [function.sprintf]: Too few arguments in /home/autot10/public_html/admin/password_forgotten.php on line 65

Warning: sprintf() [function.sprintf]: Too few arguments in /home/autot10/public_html/admin/password_forgotten.php on line 66

Please help.....Thanks