Forums / Installing on a Linux/Unix Server / Unable to login to admin area

Unable to login to admin area

Views: 21,520

Results 21 to 35 of 35
13 Nov 2009, 2:29 AM
#21
esugrue avatar

esugrue

Zen Follower

Join Date:
Jun 2004
Posts:
182
Plugin Contributions:
0

Unable to login to admin area

Hi!

I was having the same problem (Admin login refreshes) and my FF updated to 3.6 Beta 2 last night.

I tried with Chrome and it logged in OK. Weird.

15 Nov 2009, 4:09 PM
#22
customk1 avatar

customk1

Zen Follower

Join Date:
Mar 2009
Location:
Cornelius, NC
Posts:
334
Plugin Contributions:
0

Re: Unable to login to admin area

same solution here, dumped cache etc from firefox... solved issue.

sounds like a few other people are having additional issues, but it solved my issue anyways.

"Be the Change you wish to see in the World..." -Gandhi

30 Nov 2009, 4:32 PM
#23
fran2me avatar

fran2me

New Zenner

Join Date:
Nov 2009
Posts:
1
Plugin Contributions:
0

Re: Unable to login to admin area

I appear to be having this login problem also;

the site has been up and running for over six months and everything was fine last week. When I tried to login this week I encountered an admin login page which seemed to be redirecting to itself without error.
The SSL are both set to false
I have cleared the browser cache
I have tried login in 3 different browsers
I am unable to contact my web hosting hosts; they appear to be on holiday or something.

12 Dec 2009, 12:55 AM
#24
spiko avatar

spiko

New Zenner

Join Date:
Dec 2009
Posts:
1
Plugin Contributions:
0

Re: Unable to login to admin area

I'm having the exact same problem with the latest Zen Cart version installed on localhost (Ubuntu Karmic). I have tried everything suggested in the FAQ area and the forum yet nothing works. There are no error messages in apache's error log either.

12 Dec 2009, 3:39 PM
#25
elepepe avatar

elepepe

New Zenner

Join Date:
Dec 2009
Posts:
5
Plugin Contributions:
0

Re: Unable to login to admin area

I just upload the last Zen Cart on my new hosting by Fantastico.
I'm able to see the site, but when I try to enter the admin area, after I enter name and password the page is blank.
Please advise
Emanuele

19 Dec 2009, 2:39 AM
#26
bmccune avatar

bmccune

New Zenner

Join Date:
Dec 2009
Location:
Central Midwest
Posts:
16
Plugin Contributions:
0

Re: Unable to login to admin area

Well let me join the ranks here.... Been working on the cart 1.3.8a now for about 3 weeks on localserver, uploaded it to live server http://www.thequestshop.com/store/ edited all and worked just great for a week. Worked on it last night (no edits to ANY file) went had dinner and came back up, could not log into Admin, nor can I login as a user. Resend password just loops, admin login loops. User login states "There was a security error when trying to login." No warnings on Admin login.

Looked at the local verses Online in phpadmin in EVERY area (same names on both, same database etc) all Indentical. Did a back up night before last of the database, flushed all and re loaded, same thing.

Used Compare on files in local verses online dir other than local host verses online all same as ner as can tell.

Did Reg fix, Spy ware fix. Broswer clean on both IE and Firefox, Samething.

Tried 3 other PCs Same thing.

Now lost on what to do next.

Went into IE and Firefox and manualy deleted ALL Cookies/info that pretained to thequestshop of ALL types, files and txt still nothing. Booted, nothing. Looked at recent updates a Vista update was done 2 days ago.

Need some advise, need it as soon as possible, understand fully this is a freeware program but if I cannot get it to work I must move on paid or free does not matter, losing time, money and patients. Love the program do not get me wrong best open source one I had found and I think I installed 8 of them prior to this one, hated all. So PLEASE help as it appears there is more than I having cvoncerns here....:(

Loving Life and Living it to the maximum I can everyday, every minute God gives me...

19 Dec 2009, 2:35 PM
#27
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Unable to login to admin area

I created an account and can login/out with FireFox 3.5 and IE 6.x on your site and am unable to reproduce a problem ... were you able to fix this? :smile:

Linda McGrath
If you have to think ... you haven't been zenned ...

**Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!**

Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today!]
Officially PayPal-Certified! Just click here

Try our Zen Cart Recommended Services - Hosting, Payment and more ...
Signup for our Announcements Forums to stay up to date on important changes and updates!

19 Dec 2009, 2:38 PM
#28
vger avatar

vger

Past Contributor

Join Date:
Nov 2004
Location:
Norfolk, United Kingdom
Posts:
3,189
Plugin Contributions:
0

Re: Unable to login to admin area

Try resetting your Zen Cart admin login as outlined here:
https://www.zen-cart.com/tutorials/index.php?article=2

Once you have done that and logged in successfully then you can change it back to what you want.

If that doesn't work then check to make sure that the server firewall is not blocking your ip address.

Vger

31 Dec 2009, 1:21 AM
#29
bmccune avatar

bmccune

New Zenner

Join Date:
Dec 2009
Location:
Central Midwest
Posts:
16
Plugin Contributions:
0

Re: Unable to login to admin area

Ajeh:

I created an account and can login/out with FireFox 3.5 and IE 6.x on your site and am unable to reproduce a problem ... were you able to fix this? :smile:

Sorry yes I fixed it.

I posted a little deal about it, the ROOT htaccess file, not for the store but for the site which as I remember correctly rules all dirs under it unless you change the htaccess in the dir of question to ignore the root one.

Well my Root htaccess was causing a loop in login as I think others may have as they say the same thing so I posted a little about htaccess so others may check theirs.. Something on the rewrite rule, do not have old one anymore, edited it, cleared cache for the 50th or so time and all worked....:clap:

Say your login.... thanks for checking....

Loving Life and Living it to the maximum I can everyday, every minute God gives me...

6 Jan 2010, 9:06 PM
#30
banpei avatar

banpei

New Zenner

Join Date:
Aug 2006
Posts:
5
Plugin Contributions:
0

Re: Unable to login to admin area

Same problem here... I didn't touch the admin for a few days, tried to log in today and no success so far... :(
I cleared all cookies, cache and browser history, tried it in 3 different browsers and 2 different computers... No success so far... :no:

What I did find with capturing the HTTP headers was that after the login I get redirected to the index of the admin ( /admin/index.php ) with a 302 and it sets a cookie ( zenAdminID=<hash>; path=/; domain=<full-domain>, ) at the same time.

On retrieving the index page the zenAdminID cookie is offered in the call. At the index I get redirected to the login page ( /admin/login.php ) with a 302.

7 Jan 2010, 1:42 PM
#31
banpei avatar

banpei

New Zenner

Join Date:
Aug 2006
Posts:
5
Plugin Contributions:
0

Re: Unable to login to admin area

Got a bit further with investigating this problem.

1: I found out the session handler for the admin section is defined through the includes/functions/sessions.php and NOT through the expected admin/includes/functions/sessions.php. Dunno if this makes any difference to the working of the admin section. :dontgetit

2: I can log in if I change the admin from DB-based sessions to file-based sessions. So it certainly has something to do with the session handler. However the shop itself works fine with the DB-based sessions. :dontgetit

For anybody needing a quick workaround: try changing the sessions to file based sessions! :bigups:

11 Nov 2010, 3:05 PM
#32
vadimzven avatar

vadimzven

New Zenner

Join Date:
Aug 2009
Posts:
26
Plugin Contributions:
0

Re: Unable to login to admin area

I got the same situation, when I transfer my website to another hosting. I wasn't able to login in admin area and I didn't receive any messages except wrong user name or password. I spent a lot of time to changing user name/password and finally I decided to install zen cart to the different directory, but using the same admin name and pwd. The name of DB I'm also created also the same, just added number after name. After that I changed configure.php in a admin/include . Next step - open phpMyAdmin (new DB) and copy from zen_admin table encrypted admin password to the old DB.
And finally I just remove new installation, new DB and change pwd from Admin Store config.

14 Dec 2010, 10:59 PM
#33
jackie_taferner avatar

jackie_taferner

Totally Zenned

Join Date:
Jun 2009
Location:
Orange County, California
Posts:
547
Plugin Contributions:
3

Re: Unable to login to admin area

To confirm whether you have session problems, try creating a sessions.php file with the following code:

<?php
session_start();
if(isset($_SESSION['views']))
    $_SESSION['views'] = $_SESSION['views']+ 1;
else {

    $_SESSION['views'] = 1;
}

if( $_SESSION['views'] > 1)
  echo "Sessions are enabled";
else
  echo "Sessions are disabled"
?>

Upload the file to your site and navigate to it in your browser and see what the file says. If it gives a number, and that number goes up every time you refresh the page, caching is fine. If it says "Sessions are disabled" then you need to contact your webhost.

Jackie Taferner - JT Website Design
Custom Website Design and Ecommerce
Support the community. Don't Private Message, post your questions in the forum.

3 Feb 2011, 8:18 AM
#35
orca avatar

orca

New Zenner

Join Date:
May 2005
Posts:
11
Plugin Contributions:
0

Re: Unable to login to admin area

jackie.taferner:

To confirm whether you have session problems, try creating a sessions.php file with the following code:

<?php session_start(); if(isset($_SESSION['views'])) $_SESSION['views'] = $_SESSION['views']+ 1; else { $_SESSION['views'] = 1; } if( $_SESSION['views'] > 1) echo "Sessions are enabled"; else echo "Sessions are disabled" ?>
> 
> Upload the file to your site and navigate to it in your browser and see what the file says. If it gives a number, and that number goes up every time you refresh the page, caching is fine. If it says "Sessions are disabled" then you need to contact your webhost.

Just wanted to thank you directly for this tip.  With this, I was able to point out to the Hosting Provider that Sessions were not enabled on our server after a PHP upgrade.  The Hosting Provider then wrote a .htaccess file to enable sessions and this solved both a Admin and User login loop issue when SSL was active.