Zen Cart Logo
Forums / All Other Contributions/Addons / OLD Super Orders 2.0 (See v3.0 thread instead)

OLD Super Orders 2.0 (See v3.0 thread instead)

Locked

Views: 456,062

Results 381 to 400 of 2,020
This thread is locked. New replies are disabled.
19 Dec 2006, 2:49 PM
#381
blindside avatar

blindside

Totally Zenned

Join Date:
Sep 2004
Posts:
1,237
Plugin Contributions:
1

OLD Super Orders 2.0 (See v3.0 thread instead)

No problem, glad you got it all straight. Enjoy! :smile:

19 Dec 2006, 4:06 PM
#382
mtgdoofy avatar

mtgdoofy

New Zenner

Join Date:
Dec 2006
Posts:
1
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

I would like to be able to send an email similar to the new order email after I edit the order. I don't see a way to do this in Super Orders. I don't mind doing coding myself, but I was wondering if someone (who has had more experience with this code) had any advice on where I should be looking. I started last night and found myself copying over a bunch of stuff from the catalog (including the order class as well as several others that it needs) in order to resend the email (although parts of it still aren't working such as the totals and customer info. Any advice would be greatly appreciated.

19 Dec 2006, 10:29 PM
#383
snowblind avatar

snowblind

New Zenner

Join Date:
Nov 2006
Location:
Dallas, Texas
Posts:
11
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

Hi All and thanks for an excellent cart.
I'll buy ya all a cup of coffe as soon as I get rich off this thing.:wink2: I have a question about installing the superorders mod, AND,... I'm a total newbie to php, mysql, phpadmin, apache, etc,... In short not a total dummass, but lacking in experience and knowledge. I do have a fair IQ though and have figured out apache, ssl, php, mysql, all the needed supporting modules and so forth required for a fully functioning website with cart, some basics of the entire process required and do have a cart working now with full functions and some basic customizations (V1.3.6). Pardon my ignorance though if I get something wrong here, education is the only cure to ignorance so I'm asking for some please.

Basically, I have the database working and backed it up, followed the install process (super_orders_2.0rev45) and got an error "1064...line 1,..." at the start of the import process using the sql patch in the admin. I followed a lot of threads here and got that phpmyadmin would get over this, but it didn't. I took a look at the raw data of the files and the tables and so forth and believe the problem is the table names. All the tables in my database start with zencart_whatever_table, the tables created by the script do not and I think this is the reason. Also one table, "catalog.orders" does not exsist at all even with the zencart_ prefix. Am I right in assuming that editing the .sql script to write the tables as zencart_this_or_that will solve the error ? Or is this an even deeper issue ? I'm using the latest phpmyadmin 2.9.1.1, Apache 2.2.3, mod_ssl 2.2.3, openssl 0.9.8d, php 5.1.6 and MySQL 5.0.20 I have not found any issues with these versions except the strict mode with mysql which I disabled. I'm hoping this isn't too complicated an issue, any input would be greatly appreciated.

Thanks,
Snowblind

20 Dec 2006, 4:52 AM
#384
snowblind avatar

snowblind

New Zenner

Join Date:
Nov 2006
Location:
Dallas, Texas
Posts:
11
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

Apologies to everyone, I'm having some weird errors trying to get this going.
Is there any reason to think that my versions of the programs installed on my system act differently than what appears to be the expected behavior of the install instructions for super orders? Several tries later and still some odd things.
Parts of SO work, and some don't. Errors when trying out the mod are from columns don't exist to tables don't exist or even double entries. I'm starting to think my cart is not right in some way. I rechecked the install steps and edits several times and have had partial success, partial failures, but not completely one or the other. Is there something about ZC 1.3.6 that requires altering the install process for SO that I've missed ? Maybe it's mySQL version ?

20 Dec 2006, 5:42 AM
#385
snowblind avatar

snowblind

New Zenner

Join Date:
Nov 2006
Location:
Dallas, Texas
Posts:
11
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

Um,... I can't seem to edit my posts.
I got this error after completely restoring everything, database and (catalog folder);
1064 You have an error in your SQL syntax;
check the manual that corresponds to your MySQL server version
for the right syntax to use near 'True', 'False'), ')' at line 1
in:
[INSERT INTO zencat_configuration VALUES (NULL, 'Enable Purchase Order Module', 'MODULE_PAYMENT_PURCHASE_ORDER_STATUS', 'True', 'Do you want to accept Purchase Order payments?', 6, 1, now(), now(), NULL, 'zen_cfg_select_option(array('True', 'False'), ');]
If you were entering information, press the BACK button in your browser and
re-check the information you had entered to be sure you left no blank fields.

When I got this last time I edited the sql file and it did other errors, so I think it's something about the po module gone wrong. I copied the commands from below the po module ones to a new file "inserts.sql"and ran it through the sql patch tool and didn't get any errors, the database took the edits without error as I can see. Please stop me if i'm gone insane or will this run the SO properly ? I installed the po module from the admin>modules>payment and it seems all is well. should I jump now or hold on to the ledge a while longer?
:blink:
If I made a booboo somewhere I can't see it, but thanks to Blindside for a very cool mod.

20 Dec 2006, 8:05 PM
#386
snowblind avatar

snowblind

New Zenner

Join Date:
Nov 2006
Location:
Dallas, Texas
Posts:
11
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

Just an update on my issues if anyone is interested.

I ran the install per instructions (SO Rev45) and had a failure when the sql script got to the purchase orders part. I snipped the script below that part and ran it without errors. So maybe it's a unique or blind dummy thing I did that caused the failure. But with so many posts about the 1064 error and so many different reasons I thought I'd toss in my resolution. As I can see it if you have ZC 1.3.6 and MySQL 5.0.20 and PhP 5.1.6 :) then run the SO*.sql script through the sql patch tool and be sure to comment out the part about the purchase order inserts that look like this before running it:

-- Purchase Order payment module configs
INSERT INTO configuration VALUES (NULL, 'Enable Purchase Order ...
INSERT INTO configuration VALUES (NULL, 'Make payable to:', ...
INSERT INTO configuration VALUES (NULL, 'Sort order of display.', ...
INSERT INTO configuration VALUES (NULL, 'Payment Zone', ...
INSERT INTO configuration VALUES (NULL, 'Set Order Status', ...

AFTER doing the file edits (which BTW, most of those values were already in my *php files) then install the P.O. module from admin >modules >payment. This seems to have resolved all the little issues I was having with getting it to work and it now runs very well, Thank you BlindSide, Thank you ZC Team.

(Your Coffee is coming I promise :happy:)

20 Dec 2006, 9:10 PM
#387
blindside avatar

blindside

Totally Zenned

Join Date:
Sep 2004
Posts:
1,237
Plugin Contributions:
1

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

mtgDoofy:

I would like to be able to send an email similar to the new order email after I edit the order. I don't see a way to do this in Super Orders. I don't mind doing coding myself, but I was wondering if someone (who has had more experience with this code) had any advice on where I should be looking. I started last night and found myself copying over a bunch of stuff from the catalog (including the order class as well as several others that it needs) in order to resend the email (although parts of it still aren't working such as the totals and customer info. Any advice would be greatly appreciated.
So you want to resend message previously sent out through your store? I recommend you check out another of my modules: E-mail Archive Search. You need to turn on e-mail archiving for it to work, but then you can use it to resend messages previously sent at the click of a button.

20 Dec 2006, 9:32 PM
#388
blindside avatar

blindside

Totally Zenned

Join Date:
Sep 2004
Posts:
1,237
Plugin Contributions:
1

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

@SnowBlind: I appreciate your letting us know what the problem was. I'll see about removing those SQL statements for the next release.

21 Dec 2006, 10:51 PM
#389
chrome_orange avatar

chrome_orange

Totally Zenned

Join Date:
Jun 2004
Posts:
457
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

Blindside

this is some lovely code, real nice to edit/add to!

Thanks for the contribution.

Andy

22 Dec 2006, 9:30 PM
#390
blindside avatar

blindside

Totally Zenned

Join Date:
Sep 2004
Posts:
1,237
Plugin Contributions:
1

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

Glad you like it, Chrome! Wait till you see the code for returns/exchanges. :blink:

22 Dec 2006, 10:24 PM
#391
chrome_orange avatar

chrome_orange

Totally Zenned

Join Date:
Jun 2004
Posts:
457
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

BlindSide:

Glad you like it, Chrome! Wait till you see the code for returns/exchanges. :blink:

:)

did you get my email regarding split the order with a quantity and increasing/decreasing price and order quantity?

28 Dec 2006, 7:47 PM
#392
rcrosier avatar

rcrosier

Zen Follower

Join Date:
Dec 2006
Location:
Vermont
Posts:
128
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

I'm looking at the SQL file for the Super Orders 2.0, and I notice that all the files are the "base" filenames, whereas my Zen Cart installation uses a PREFIX for my store name, ie; instead of "configuration", I have "storename_configuration", etc.

Will I need to modify this to use it?

Or... should I simply move ALL my data back to the base files instead, and if so, is there an easy way to do this?

Thanks.

29 Dec 2006, 4:42 PM
#393
wickedklown avatar

wickedklown

Zen Follower

Join Date:
Aug 2005
Posts:
370
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

Blindside,
Im finaly going to have our site reconfiged by a pro to remove all these damned problems that plauged us this year. Get SO running smooth again and all that good stuff..

But i have a small question that we cant seem to come up with an answer..

Why is it that when an order is split, the shipping is duplicated to the next order? This seems to just make things that much harder to track, becuase you have to go back to the orig order, and pull the shipping bill to figgure out what shipping balance is actualy left on the split order.
any info on this matter is much appriciated.
Thanks
Wicked

29 Dec 2006, 4:55 PM
#394
jacerider avatar

jacerider

New Zenner

Join Date:
Oct 2004
Posts:
29
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

I have a quick question. I allow customers to pay using two methods on my site. Credit Card using Skipjack and PayPal.

When I get a new order using either of the methods this is what my order looks like:

Sub-Total: $11.00
USPS Media Mail: $3.57
Tax charged when shipped to Minnesota: $0.72
Total: $15.29
Amount Applied: $0.00
Balance Due: $15.29

Why is the amount applied not automatically filled out when using either of these methods when the payment has already been approved and received?

On the old Super Orders if someone payed with a CC the balance do was automatically set to 0. Am I missing something here?

29 Dec 2006, 10:33 PM
#395
blindside avatar

blindside

Totally Zenned

Join Date:
Sep 2004
Posts:
1,237
Plugin Contributions:
1

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

Hey guys, I'm currently on vacation visiting family, and wanted to drop a quick note regarding 1.3.7. Being part of the support team, I am well aware of the new changes and the fact that they directly affect SO. Just a FYI to head off all the Will this work with 1.3.7? posts and PM's. :wink2:

Since I've been away, I haven't had time to test yet, but from what I understand you should be ok using SO, it simply won't have the new bells and whistles attached to it. Next release will of course rectify this. I will confirm the compatibility once I get home and test things out.

1 Jan 2007, 4:25 PM
#396
rcrosier avatar

rcrosier

Zen Follower

Join Date:
Dec 2006
Location:
Vermont
Posts:
128
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

I installed this mod, but when I click on the "Print" button, at the top of the invoice/order that's printed, and in the new window, I get this error:

PHP Fatal error: Call to undefined method super_order::get_admin_notes() in C:\Inetpub\VTStuffTest2\admin\super_data_sheet.php on line 262

I can see both the "super_orders_functions.php", and in it, the "get_admin_notes()" function...

It seems that the program is looking for it in the wrong place. I have the "super_orders_functions.php" in "C:\Inetpub...\admin\includes\functions\extra_functions", but maybe it should be elsewhere?

I don't seem to get errors anyplace else.

Ideas? Thanks!

3 Jan 2007, 10:24 PM
#397
dogtags avatar

dogtags

Totally Zenned

Join Date:
Nov 2003
Posts:
876
Plugin Contributions:
1

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

Hi All

Happy New Year! :-)

Is SO 2.0 (rev 45) the latest version ? (in the downloads section)

I've been hunting around in this thread for anything later, but so far no go.

Many thanks :-)

3 Jan 2007, 11:43 PM
#398
samad64 avatar

samad64

Totally Zenned

Join Date:
May 2006
Location:
Texas
Posts:
554
Plugin Contributions:
2

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

DogTags:

Hi All

Happy New Year! :-)

Is SO 2.0 (rev 45) the latest version ? (in the downloads section)

I've been hunting around in this thread for anything later, but so far no go.

Many thanks :-)

95% sure its the latest version.. BlindSide has been talking about a newer version in which you can edit orders, do returns, etc.. but haven't seen any new news about it yet or releases :P

5 Jan 2007, 4:17 AM
#399
blindside avatar

blindside

Totally Zenned

Join Date:
Sep 2004
Posts:
1,237
Plugin Contributions:
1

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

What's listed in the download section is the latest public version. All those new bells and whistles are currently in development.

I installed this mod, but when I click on the "Print" button, at the top of the invoice/order that's printed, and in the new window, I get this error:

PHP Fatal error: Call to undefined method super_order::get_admin_notes() in C:\Inetpub\VTStuffTest2\admin\super_data_sheet.php on line 262

I can see both the "super_orders_functions.php", and in it, the "get_admin_notes()" function...

It seems that the program is looking for it in the wrong place. I have the "super_orders_functions.php" in "C:\Inetpub...\admin\includes\functions\extra_fun ctions", but maybe it should be elsewhere?

I don't seem to get errors anyplace else.
That section should be commented out, but looking at the file I see that the opening php tag is shorthand ("<?" instead of "<?php") on line 261. Add the "php" to the tag and the problem should go away.
wickedclown:

But i have a small question that we cant seem to come up with an answer..

Why is it that when an order is split, the shipping is duplicated to the next order? This seems to just make things that much harder to track, becuase you have to go back to the orig order, and pull the shipping bill to figgure out what shipping balance is actualy left on the split order.
any info on this matter is much appriciated.
Well the original idea was that, since you're splitting an order, the shipping would be adjusted to reflect two separate orders. So, I put the total on both orders so there's a starting point, then adjust accordingly. It's worked out in my office well, but I can see how that might cause some accounting havoc. I'll take that out, leaving the shipping and all other sub-total figures on the original order.
rcrosier:

I'm looking at the SQL file for the Super Orders 2.0, and I notice that all the files are the "base" filenames, whereas my Zen Cart installation uses a PREFIX for my store name, ie; instead of "configuration", I have "storename_configuration", etc.

Will I need to modify this to use it?
Yes, and if you read the readme you'd know that, along with where to edit the file. :lamo:
Or... should I simply move ALL my data back to the base files instead, and if so, is there an easy way to do this?
If the DB is not sharing space with tables from another system, I think you ought to drop the prefix. The Zen Cart installer allows you to do this, although I'd wait until your next upgrade to do so.

5 Jan 2007, 10:08 PM
#400
barco57 avatar

barco57

Totally Zenned

Join Date:
Apr 2006
Location:
West Salem, IL
Posts:
2,845
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

How do I turn off product images on the packing slip? Do I have to edit some file somewhere or is there a switch....maybe in the database....