Zen Cart Logo
Forums / Built-in Shipping and Payment Modules / Shipping Estimator Error 404 when cliet is not logged in

Shipping Estimator Error 404 when cliet is not logged in

Locked

Views: 3,790

Results 1 to 20 of 30
This thread is locked. New replies are disabled.
6 May 2007, 5:57 AM
#1
mikebr avatar

mikebr

Zen Follower

Join Date:
May 2007
Posts:
124
Plugin Contributions:
0

Shipping Estimator Error 404 when cliet is not logged in

When end user is not logged in and updates the shipping estimator in the shopping cart after entering there country and state and zip code new window with error 404 is displayed.
If person loggs in no problem all rates are displayed.
Is this a problem with the shipping_estimator.php
file?
Any help would be appreciated

Site

http://www.ojemporium.com/

6 May 2007, 6:00 AM
#2
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Shipping Estimator Error 404 when cliet is not logged in

I cannot reproduce this error ...

Are you missing files perhaps? Or have files out of date?

What shipping modules are you using?

Does your checkout_shipping page load and display properly?

6 May 2007, 6:09 AM
#3
mikebr avatar

mikebr

Zen Follower

Join Date:
May 2007
Posts:
124
Plugin Contributions:
0

Re: Shipping Estimator Error 404 when cliet is not logged in

The shipping rates display fine in the cart for a logged in user.
Also the rates are displayed fine when proceding to checkout
Using USPS and UPS
version 1.3.7 zen

6 May 2007, 6:13 AM
#4
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Shipping Estimator Error 404 when cliet is not logged in

Sounds like you have some bad, missing or corrupt files ...

First, switch to Classic Template ...

Does it work?

If so, then there are template issues ...

6 May 2007, 6:25 AM
#5
mikebr avatar

mikebr

Zen Follower

Join Date:
May 2007
Posts:
124
Plugin Contributions:
0

Re: Shipping Estimator Error 404 when cliet is not logged in

Classic template not working at all.
Why is the estimator working when a user is logged in?

6 May 2007, 2:28 PM
#6
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Shipping Estimator Error 404 when cliet is not logged in

It sounds like you have out of date, bad files, missing files, etc.

Classic should work unless you have touched the files in Classic vs working in your own template and overrides directories ...

You might get something like Beyond Compare from scootersoftware.com which allows you to compare files from a clean Zen Cart to your custom Zen Cart and see if you have missing, out of date or damaged files ...

Without literally doing the work for you and verifying all the files on your server, again with something like Beyond Compare, I cannot see what it is that you might have done to cause this issue ...

6 May 2007, 4:19 PM
#7
mikebr avatar

mikebr

Zen Follower

Join Date:
May 2007
Posts:
124
Plugin Contributions:
0

Re: Shipping Estimator Error 404 when cliet is not logged in

I was able to get Classic to work and the Shipping Estmator does work for persons not logged in
When Switching back to my custom template and selecting the shopping cart the shipping estimator displays the rates based on the zip code info that was entered in the Classic template, however when entering a new zipcode the error 404 page appears.
What files does the classic template use after entering the zip code info and then selecting the update button.
Thank you for any insight into this problem

6 May 2007, 4:23 PM
#8
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Shipping Estimator Error 404 when cliet is not logged in

Classic is using the defaults ...

Sounds like something is missing or corrupt in your template and override files ...

6 May 2007, 5:12 PM
#9
mikebr avatar

mikebr

Zen Follower

Join Date:
May 2007
Posts:
124
Plugin Contributions:
0

Re: Shipping Estimator Error 404 when cliet is not logged in

Ok the estimator is finally working
I switched over to the default Shipping estmator.php file for my custom template
One problem remains
when the pop-up estmator window appears there is an extra blank field with no label just under the State drop down field.
How would I get rid of this field?

http://www.ojemporium.com/

Thanks fo0r your help

6 May 2007, 5:24 PM
#10
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Shipping Estimator Error 404 when cliet is not logged in

You are missing a couple classes in your stylesheet ...

.hiddenField {
display: none;
}
.visibleField {
display: inline;
}

6 May 2007, 6:16 PM
#11
mikebr avatar

mikebr

Zen Follower

Join Date:
May 2007
Posts:
124
Plugin Contributions:
0

Re: Shipping Estimator Error 404 when cliet is not logged in

Added statements to stylesheet
Everything working great now
Thanks so much

7 May 2007, 2:12 AM
#12
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Shipping Estimator Error 404 when cliet is not logged in

You are most welcome ... thanks for the update! :smile:

3 Jun 2007, 6:05 PM
#13
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,567
Plugin Contributions:
58

Re: Shipping Estimator Error 404 when cliet is not logged in

I get the 404 on your site. The link for the update button is: "www.ojemporium.com/_"

I have the same error in my cart as well...

3 Jun 2007, 6:17 PM
#14
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,567
Plugin Contributions:
58

Re: Shipping Estimator Error 404 when cliet is not logged in

Update:

I'm getting a 404 error on three zen cart websites for the shipping estimator when not logged in. The link for the update button is always domain.com/_ or domain.com/store/_ and it always leads to a 404 error. However, if I then browse back to the shipping page, the estimates now display...

3 Jun 2007, 6:35 PM
#15
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,567
Plugin Contributions:
58

Re: Shipping Estimator Error 404 when cliet is not logged in

Update 2:

I don't receive the error with FireFox. Only IE7 which is installed on a Vista machine. Anyone else having problems or is this an error with my IE7 only...?

3 Jun 2007, 6:35 PM
#16
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Shipping Estimator Error 404 when cliet is not logged in

It's impossible to help without more information, such as:

  • URLs to sites where this can be seen in action
  • list of shipping modules installed/active on these sites
  • list of all customizations made to the sites
  • version of Zen Cart installed on the sites
3 Jun 2007, 8:55 PM
#17
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,567
Plugin Contributions:
58

Re: Shipping Estimator Error 404 when cliet is not logged in

Sure,

I've now tested it on two different machines using IE7.

I don't know what scripts the other sites have installed, but they are:

infaithwear.com and the thread starters website as well as my own, numinix.com

3 Jun 2007, 9:29 PM
#18
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Shipping Estimator Error 404 when cliet is not logged in

In IE6, I cannot reproduce the problem of 404-errors on shipping-estimator pages ... for any of the sites.

I do note that on the numinix site, you appear to have the zen-id-remover mod installed, causing pages to do an extra refresh, which can be a bit annoying. Although, I doubt it's directly related to the shipping-estimator problems you are encountering.

3 Jun 2007, 11:35 PM
#19
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,567
Plugin Contributions:
58

Re: Shipping Estimator Error 404 when cliet is not logged in

DrByte, is there a way to remove the zenID and not have the refresh? I installed this mod because of the issue of copying and pasting zenID's to other users.

The error seems to be IE7 only. It seems to be unable to handle the "_" in the link. Any ideas?

4 Jun 2007, 1:29 AM
#20
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Shipping Estimator Error 404 when cliet is not logged in

numinix:

The link for the update button is always domain.com/_ or domain.com/store/_ and it always leads to a 404 error.

Since the _ is a valid character in a URL, when you click on a link with just _ as the path, it's going to try to go to a file or folder of that name.
Since it doesn't exist, naturally, you'll get a 404 error.

Why IE7 is doing that is puzzling.