Zen Cart Logo
Forums / General Questions / How to launch??? Need to move to main folder

How to launch??? Need to move to main folder

Locked

Views: 7,180

Results 41 to 59 of 59
This thread is locked. New replies are disabled.
13 May 2008, 2:04 AM
#41
indicana avatar

indicana

New Zenner

Join Date:
Apr 2008
Posts:
55
Plugin Contributions:
0

How to launch??? Need to move to main folder

DrByte:

"Affected rows:1" is the expected result ... and thus your new user/pwd is Admin/admin
I have requested my host provider to upload the backup files from the server. I am just wondering if I upload the original index.php files from the zen cart zip folder on my PC, would I not have to work on the design template ie the home page of my website again?

My host provider restored both the index.php files, but when I checked their code it is exactly the same. So I have requested them to restore the right index.php files in the exact location. If I upload the original version of the index.php file from the zen cart admin folder and put it in the /admin/ folder, will there be any problem?

Secondly "regarding the 5th step in the tutorial, I downloaded the Fix Cache Key file from the troubleshooting section. But the instructions are a bit confusing. Where do Iupload the file - in the root folder indicana.com or in the admin folder ie /admin ? And how do I run the file? "

Thirdly regarding the bug, I detected 2 files which are 0 bytes - service.lck & frontpg.lck and another - services.cnf which is 2 bytes - all in the admin folder.

I downloaded the debug error logging Utility and uploaded the enable_error _logging.php file in the /admin/includes/extra_configures folder. The permissions for all the files in the extra_configures folder are set to 755. Now after this I don't understand ie from step 3 onwards:
3. Make sure your /cache/ folder permissions are set to writable.
4. Test the page on your site that is having problems -- ie: trigger whatever symptom is ailing you. - how?
5. Open the latest /cache/myDEBUG-xxxxxxx.log file (Where?)to see the list of any PHP errors that occurred while the page/test was running.
6. Be sure to delete the enable_error_logging.php file from the /includes/extra_configures folder when done (or rename it to .php1 instead of .php )

I have spent more than 3 days working on this problem and with your help I have come close to solving it but still not been succesful. I will breathe a sigh of relief once this issue is resolved once for all. I appreciate your help very much.

thanks

Indicana

13 May 2008, 2:14 AM
#42
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: How to launch??? Need to move to main folder

indicana:

I have requested my host provider to upload the backup files from the server. I am just wondering if I upload the original index.php files from the zen cart zip folder on my PC, would I not have to work on the design template ie the home page of my website again?/index.php goes to /index.php
/admin/index.php goes to /admin/index.php
The files are different. Very different.

indicana:

Secondly "regarding the 5th step in the tutorial, I downloaded the Fix Cache Key file from the troubleshooting section. But the instructions are a bit confusing. Where do Iupload the file - in the root folder indicana.com or in the admin folder ie /admin ? And how do I run the file? "
Upload it to your main webfolder ... I guess in your case that's /indicana.com (for most people it's called public_html, but you have a less common hosting setup apparently)

Then to "run" it, type in www.your_site_name.com/fix_cache_key.php ... or whatever you named it.

Before you ask about the error messages it says, note that you can ignore any "headers already sent" messages it displays -- they're expected in this case.

indicana:

Thirdly regarding the bug, I detected 2 files which are 0 bytes - service.lck & frontpg.lck and another - services.cnf which is 2 bytes - all in the admin folder.
Please tell me you're not using MS Frontpage to manage your site?
Delete those two *.lck files.
Granted, they should not be causing any "blank page" problems.
Nor should services.cnf.

indicana:

I downloaded the debug error logging Utility and uploaded the enable_error _logging.php file in the /admin/includes/extra_configures folder. The permissions for all the files in the extra_configures folder are set to 755. Now after this I don't understand ie from step 3 onwards:
3. Make sure your /cache/ folder permissions are set to writable.
4. Test the page on your site that is having problems -- ie: trigger whatever symptom is ailing you. - how?
5. Open the latest /cache/myDEBUG-xxxxxxx.log file (Where?)to see the list of any PHP errors that occurred while the page/test was running.
6. Be sure to delete the enable_error_logging.php file from the /includes/extra_configures folder when done (or rename it to .php1 instead of .php )4. If the problem you're having is accessing the admin area, then ... try accessing the admin area.
Basically, it means do whatever you were trying to do that wasn't working.
That way the system can create logs of the problems for you to review.

  1. You have a /cache/ folder on your server, right? That's where the files wil be, as long as you made the folder writable as per step 3 earlier.

indicana:

I have spent more than 3 days working on this problem and with your help I have come close to solving it but still not been succesful. I will breathe a sigh of relief once this issue is resolved once for all. I appreciate your help very much.It likely would have been faster to wipe it all and restore from your backup and start your relocation over again.

Nevertheless, you're getting a crash course in how some things work.

13 May 2008, 2:27 AM
#43
indicana avatar

indicana

New Zenner

Join Date:
Apr 2008
Posts:
55
Plugin Contributions:
0

Re: How to launch??? Need to move to main folder

Quote:
Originally Posted by indicana
I have requested my host provider to upload the backup files from the server. I am just wondering if I upload the original index.php files from the zen cart zip folder on my PC, would I not have to work on the design template ie the home page of my website again?

/index.php goes to /index.php
/admin/index.php goes to /admin/index.php
The files are different. Very different.

Yes, I understand, but what I mean is, if I upload the /admin/index.php file from the zencart zip folder on my PC and upload it to the /admin folder on my server will it cause any problem? Would I have to do the home page, customise the design again?

13 May 2008, 2:50 AM
#44
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: How to launch??? Need to move to main folder

The index.php file does not have anything to do with your template. So, no, it won't make you have to redo your design again.
Even if it did, you do have backups, right? You could go back to your saved copy of the work you had done using the backup.

13 May 2008, 3:21 AM
#45
indicana avatar

indicana

New Zenner

Join Date:
Apr 2008
Posts:
55
Plugin Contributions:
0

Re: How to launch??? Need to move to main folder

Hello Dr. Byte,

I first ran the Cache_Fix_Key.php file by uploading it in the root folder, then ran it and the problem was fixed.

I uploaded the admin/index.php file from the zencart on my PC and Lo! I got access to the admin page without even loggin in. But I got this warning.
"Warning: Your Admin login is not secure ... either you still have default login settings for: Admin admin or have not removed or changed: demo demoonly
The login(s) should be changed as soon as possible for the Security of your Shop
Go to Tools->Admin Settings to change login IDs and passwords.
For additional Security for the Admin please see the /docs"

Therefore I succesfully changed my ID & password in the admin settings. I wanted to check if it is working so I logged off and then now when I am trying to login again using the new id and password it says wrong ID and pswd. I am back to square one again.

13 May 2008, 3:24 AM
#46
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: How to launch??? Need to move to main folder

indicana:

I first ran the Cache_Fix_Key.php file by uploading it in the root folder, then ran it and the problem was fixed.:clap:

indicana:

I uploaded the admin/index.php file from the zencart on my PC and Lo! I got access to the admin page without even loggin in. But I got this warning.
"Warning: Your Admin login is not secure ... either you still have default login settings for: Admin admin or have not removed or changed: demo demoonly
The login(s) should be changed as soon as possible for the Security of your Shop
Go to Tools->Admin Settings to change login IDs and passwords.
For additional Security for the Admin please see the /docs" That is to be expected.
indicana:

Therefore I succesfully changed my ID & password in the admin settings. I wanted to check if it is working so I logged off and then now when I am trying to login again using the new id and password it says wrong ID and pswd. I am back to square one again.

You'll probably need to reset it again: https://www.zen-cart.com/tutorials/index.php?article=2
And then when you go to set the password to something else, be sure you make note of exactly what you enter. The usernames and passwords are case-sensitive.

13 May 2008, 3:37 AM
#47
indicana avatar

indicana

New Zenner

Join Date:
Apr 2008
Posts:
55
Plugin Contributions:
0

Re: How to launch??? Need to move to main folder

I uploaded the enable_error _logging.php file in the /admin/includes/extra_configures folder. The cache folder in the root folder contains the myDEBUG-1210646554.log file which cannot be opened, 18 zcinstallation details files and 5 sess_33cf3a8a35f2f59 files - all of them cannot be opened. What do I do now? I feel like I have lost everything all over again.

Indicana

13 May 2008, 3:41 AM
#48
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: How to launch??? Need to move to main folder

The zcInstallxxxx.log files can be safely deleted. They are for troubleshooting installer problems.

The sess_xxxxx files are tracking customer shopping sessions.

The myDEBUGxxx.log files are what would contain error messages.

What do you mean by "cannot be opened"? Notepad should be able to open the file fine.

13 May 2008, 4:01 AM
#49
indicana avatar

indicana

New Zenner

Join Date:
Apr 2008
Posts:
55
Plugin Contributions:
0

Re: How to launch??? Need to move to main folder

Thanks a lot, Dr. Byte, now I am on the right track. It was such a great relief to see my admin panel back again........ like finding a lost kid. You have been so patient and supportive.

Well, now I opened the debug..log file and here's the result:

[13-May-2008 03:42:34] PHP Warning: main(DIR_WS_TEMPLATEStemplate_default/common/html_header.php) [<a href='function.main'>function.main</a>]: failed to open stream: No such file or directory in /home/www/indicana.com/admin/index.php on line 43
[13-May-2008 03:42:34] PHP Warning: main(DIR_WS_TEMPLATEStemplate_default/common/html_header.php) [<a href='function.main'>function.main</a>]: failed to open stream: No such file or directory in /home/www/indicana.com/admin/index.php on line 43
[13-May-2008 03:42:34] PHP Warning: main(DIR_WS_TEMPLATEStemplate_default/common/html_header.php) [<a href='function.main'>function.main</a>]: failed to open stream: No such file or directory in /home/www/indicana.com/admin/index.php on line 43
[13-May-2008 03:42:34] PHP Fatal error: main() [<a href='function.require'>function.require</a>]: Failed opening required 'DIR_WS_TEMPLATEStemplate_default/common/html_header.php' (include_path='.:/usr/local/php4/lib/php') in /home/www/indicana.com/admin/index.php on line 43

Could you please tell me what this means? By the way there are these zcinstalexceptiondetails files too in the cache folder. Can I delete them too safely?

thank you once again for all your help

Indicana

13 May 2008, 6:45 AM
#50
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: How to launch??? Need to move to main folder

indicana:

Well, now I opened the debug..log file and here's the result:

[13-May-2008 03:42:34] PHP Warning: main(DIR_WS_TEMPLATEStemplate_default/common/html_header.php) [<a href='function.main'>function.main</a>]: failed to open stream: No such file or directory in /home/www/indicana.com/admin/index.php on line 43
[13-May-2008 03:42:34] PHP Warning: main(DIR_WS_TEMPLATEStemplate_default/common/html_header.php) [<a href='function.main'>function.main</a>]: failed to open stream: No such file or directory in /home/www/indicana.com/admin/index.php on line 43
[13-May-2008 03:42:34] PHP Warning: main(DIR_WS_TEMPLATEStemplate_default/common/html_header.php) [<a href='function.main'>function.main</a>]: failed to open stream: No such file or directory in /home/www/indicana.com/admin/index.php on line 43
[13-May-2008 03:42:34] PHP Fatal error: main() [<a href='function.require'>function.require</a>]: Failed opening required 'DIR_WS_TEMPLATEStemplate_default/common/html_header.php' (include_path='.:/usr/local/php4/lib/php') in /home/www/indicana.com/admin/index.php on line 43Those are almost certainly a result of trying to use the storefront index.php inside the admin folder. You should delete those logfiles, since they are no longer relevant since you've fixed your admin access.
indicana:

By the way there are these zcinstalexceptiondetails files too in the cache folder. Can I delete them too safely?Yes.

13 May 2008, 3:33 PM
#51
indicana avatar

indicana

New Zenner

Join Date:
Apr 2008
Posts:
55
Plugin Contributions:
0

Re: How to launch??? Need to move to main folder

DrByte:

Those are almost certainly a result of trying to use the storefront index.php inside the admin folder. You should delete those logfiles, since they are no longer relevant since you've fixed your admin access.
Yes.
Thank you Dr. Byte for your prompt responses. I am facing another admin problem now. I still cannot access the admin/configuration panel in my admin settings. it takes me to a page not found or error 404 page. How do I fix this? I thought I have access to all the admin settings. I am also not receiving any emails when I log in as a customer. Seems like the email account is not working.

Indicana

13 May 2008, 3:37 PM
#52
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: How to launch??? Need to move to main folder

Do you have an /admin/configuration.php file?
If not, restore it from backup.
(NOTE: this is different from the "configure.php" file ... note the spellings)

13 May 2008, 3:38 PM
#53
indicana avatar

indicana

New Zenner

Join Date:
Apr 2008
Posts:
55
Plugin Contributions:
0

Re: How to launch??? Need to move to main folder

indicana:

Thank you Dr. Byte for your prompt responses. I am facing another admin problem now. I still cannot access the admin/configuration panel in my admin settings. it takes me to a page not found or error 404 page. How do I fix this? I thought I have access to all the admin settings. I am also not receiving any emails when I log in as a customer. Seems like the email account is not working.

Indicana
I also feel like my website has slowed down. It takes forever to go to the check out page and for the products to display. It was not so before. And the newsletter subscriptions/ Email notifications is not working ie when I click on the newletter subscription button, nothing happens, seems like it has frozen.

I would appreciate your help

Indicana

13 May 2008, 3:49 PM
#54
indicana avatar

indicana

New Zenner

Join Date:
Apr 2008
Posts:
55
Plugin Contributions:
0

Re: How to launch??? Need to move to main folder

indicana:

I also feel like my website has slowed down. It takes forever to go to the check out page and for the products to display. It was not so before. And the newsletter subscriptions/ Email notifications is not working ie when I click on the newletter subscription button, nothing happens, seems like it has frozen.

I would appreciate your help

Indicana
Hello Dr.Byte,

My configuration.php file was in the /includes folder, so I put it in the /admin folder now but it shows a server error as follows:
Server error!
The server encountered an internal error and was unable to complete your request.

Error message:
Premature end of script headers: configuration.php

If you think this is a server error, please contact the webmaster.

Error 500
https://www.indicana.com
Tue May 13 16:44:07 2008
Apache/2.0.54 (Debian GNU/Linux) mod_auth_pgsql/2.0.1 mod_ssl/2.0.54 OpenSSL/0.9.7e mod_perl/1.999.21 Perl/v5.8.4

I checked my /admin folder and found that the .htaccess file is missing from there.

thanks

Indicana

13 May 2008, 10:32 PM
#55
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: How to launch??? Need to move to main folder

Do you have a backup on your PC?

I think you need to do a compare of all the files on your server vs all the file that are supposed to be on the server.

If you don't have your own backup, make sure you start making regular backups.

If you don't have a backup, then you'll have to do a compare using the original Zen Cart fileset: https://www.zen-cart.com/tutorials/index.php?article=95

Then do a comparison of your server's files (download all your files using FTP) using a method similar to what I've described in the following article. This is the approach I use when troubleshooting something that's gone wrong: http://www.zen-cart.com/wiki/index.php/Troubleshoot_-_Diagnosing_Obscure_Issues

14 May 2008, 4:34 AM
#56
indicana avatar

indicana

New Zenner

Join Date:
Apr 2008
Posts:
55
Plugin Contributions:
0

Re: How to launch??? Need to move to main folder

DrByte:

Do you have a backup on your PC?

I think you need to do a compare of all the files on your server vs all the file that are supposed to be on the server.

If you don't have your own backup, make sure you start making regular backups.

If you don't have a backup, then you'll have to do a compare using the original Zen Cart fileset: https://www.zen-cart.com/tutorials/index.php?article=95

Then do a comparison of your server's files (download all your files using FTP) using a method similar to what I've described in the following article. This is the approach I use when troubleshooting something that's gone wrong: http://www.zen-cart.com/wiki/index.php/Troubleshoot_-_Diagnosing_Obscure_Issues
Hello Dr. Byte,

Thank you for your response. Unfortunately I do not have a back up of all my files on my PC. I did a backup of my database but it is unintelligible as it is all in one folder and difficult to decipher. I am just wondering how I should do a backup manually. How could I download all the files manually from the server to the PC? Could you pls give me a clue?

Fortunately I was able to fix the problem of the configuration settings in the admin panel after reading the forums. The configure.php file in the /admin folder was set to 777 and once I changed it to 444, I got access to the configuration settings of the admin Panel.

Even though the problem has been fixed I do not want to take any more chances because I cannot depend on my host provider to furnish me with backups all the time. You are right, I should have my own back up. I had to waste so much time waiting for my host to restore a file.

Thanks

Indicana

14 May 2008, 4:48 AM
#57
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: How to launch??? Need to move to main folder

Another FAQ:
Doing Database Backups: https://www.zen-cart.com/tutorials/index.php?article=103

To backup your files, use your FTP program and download everything in your web folder (in your case that's likely your indicana folder). That means all the folders and files in them.

14 May 2008, 4:05 PM
#58
indicana avatar

indicana

New Zenner

Join Date:
Apr 2008
Posts:
55
Plugin Contributions:
0

Re: How to launch??? Need to move to main folder

Thanks for your help. I have a doubt about enabling SSL on the admin/includes/configure.php:

// Use secure webserver for catalog module and/or admin areas?
define('ENABLE_SSL_CATALOG', 'false');
define('ENABLE_SSL_ADMIN', 'false');
Do I need to change this to "true" instead of "false" for both or just leave as it is?

indicana

14 May 2008, 4:09 PM
#59
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: How to launch??? Need to move to main folder

If you want to have your admin login use SSL, then you would set those to 'true'.