Inactive
- Join Date:
- Jun 2005
- Location:
- Cheney WA
- Posts:
- 1,123
- Plugin Contributions:
- 0
Install says Curl not installed, but it is.
My hosting company added zend.com to the firewall settings and walla, Curl is working on all subdirectories.
Views: 24,070
Inactive
My hosting company added zend.com to the firewall settings and walla, Curl is working on all subdirectories.
Sensei
birdoasis:
I'm on surfspeedy now.
birdoasis:
My hosting company added zend.com to the firewall settings and walla, Curl is working on all subdirectories.
Glad they found a "speedy" solution to their configuration problem.
Seems very odd that "zend.com" would have anything to do with CURL operating, whether navigating to zen-cart.com or to any other destination.
Totally Zenned
Hi,
I asked my hosting service to allow firewall connections to zend.com and they have replied:
"an outward connection from the server to a port 80 (via curl or wget) is always closed for security reasons on servers of shared hosting. Any serious ISP has this basic and necessary security measure in place."
Any comments on this from the wise?
If I close the firewall on my local machine when installing1.38/1.38a, the installer brings up the same error about the problems with the curl installation as php.exe tries to (unsuccessfully) make the outward connection to https://www.zen-cart.com
I notice that sometime it connects to https://www.zen-cart.com on port 80 and other times on 443.
Is there a way to get it to not use port 80? Or am I barking up the wrong tree?
regards
Steve
Sensei
torvista:
Hi,
I asked my hosting service to allow firewall connections to zend.com and they have replied:
"an outward connection from the server to a port 80 (via curl or wget) is always closed for security reasons on servers of shared hosting. Any serious ISP has this basic and necessary security measure in place."Any comments on this from the wise?
Just one comment: Any serious ISP offering eCommerce hosting to their customers has this port open and knows how to protect their server without having to block all ports as a catch-all security measure.
If they won't open it, find a host who will. Otherwise you'll not be able to process shipping quotes and payments using 3rd-party services such as UPS, USPS, PayPal, Authorize.net, and more.
Oh, and for the record, Zen Cart has nothing to do with "zend.com"
Totally Zenned
Hi,
my hosting people tell me it is common practice to block 80 and 433 outgoing on shared hosting.
They can open a specific port above 10,000. Can I instruct php to use that and complete the installation or must it use those two ports?
Thanks again
Steve
Inactive
Tiffany-wholesaler, your first post and you choose to Spam the Forum? :yuck:
torvista, as mentioned by DrByte, your Hoster does not seem to do things in the normal fashion. Yes, they are somewhat correct in what they said but nobody installs a Front Door to their house then leaves it open all the time.
Server security can be a tricky thing but your Hoster seems to be taking the approach of "let's block everything we can and provide minimal service".
Inactive
By the way,
I still can't login to admin.
Zen Follower
I'm having the same problem on Lunarpages hosting. I'm working on updating my testing sandbox from version 1.3.7 to 1.3.8a.
Error message I see during upgrade installation:
Message I see running /extras/curltest.php:
You submitted the following fields and data:
Array
(
[field1] => This is a test
[statuskey] => ready
)
Data validation
Good Other Info
Your server IP address is: 74.50.11.50.
user-agent: unknown.
Array
(
[url] => "http://www.zen-cart.com/testcurl.php"
[content_type] => text/html
[http_code] => 200
[header_size] => 139
[request_size] => 192
[filetime] => -1
[ssl_verify_result] => 0
[redirect_count] => 0
[total_time] => 1.240831
[namelookup_time] => 1.143627
[connect_time] => 1.189642
[pretransfer_time] => 1.189964
[size_upload] => 0
[size_download] => 2139
[speed_download] => 1723
[speed_upload] => 0
[download_content_length] => 0
[upload_content_length] => 0
[starttransfer_time] => 1.240306
[redirect_time] => 0
)
PHP info from my old (real) 1.3.7 store:
curl
CURL support enabled
CURL Information libcurl/7.12.0 OpenSSL/0.9.7a zlib/1.1.4
We do use authorize.net AIM, so I may be affected by this problem.
I'm going to see if I can continue the installation/upgrade on that store and see what happens.
The sandbox store is at http://coreknowledge.org/register
---Diana
(subscribing to this thread!)
New Zenner
I am getting the same error:
"CURL requires SSL Support. Please notify webmaster..." (Connect Timed out).
Received Error code from proxy - 403...
CURL is activated on the godaddy server...
AND- I have tested with the curl test, and it Works fine.
http://www.vinylsheetprotectors.com/extras/curltest.php
I'll send an email to godaddy as well, but if anyone knows what the issue is, please let me know. (I read the entire thread and can't see any solutions).
Thanks!
Sensei
If you're stuck with no options other than GoDaddy, you can ignore that CURL warning, but BE SURE to go and turn on the CURL Proxy settings, as described here:
http://www.zen-cart.com/forum/showthread.php?t=61528
New Zenner
Thank you, I'll try it out.
So far I like Godaddy. I hear alot of people bashing it, but so far as I can tell it's pretty easy to use.
I also got an email from Godaddy saying that I have to use a proxy server and gave me the server name, etc.
Thanks again
Chris.
Inactive
The way I got rid of this error is to put a ticket into my host. They set the firewall to accept curl at the url I was attempting to install on.
However, I tried installing in another folder to play on and got the error message again.
Of course most people don't have two, much less three installations on one hosting account. Duh, me know what I doing. I sure of it.
New Zenner
I keep getting this error when I go to checkout:
"DECLINE - Your credit card could not be authorized for this reason. Please correct the information and try again or contact us for further assistance."
There is no indication as to what it is having problems with.
After reading many threads regarding GoDaddy (which is where the site is hosted) and CURL, I am inclined to think that this is the problem.
I looked at the CURL info from GoDaddy: http://help.godaddy.com/article.php?article_id=289&topic_id=
Not sure what I should do with this or where it should go.
Shouldn't this be covered by the CURL Proxy info in the MyStore settings?
The code seems quite a bit different!?!
That is why I wanted to run the testcurl.php... which I don't have?
Is it available for download?
or am I barking up the wrong tree?
Thanks
-B
Zen Follower
curltest.php is in the extras folder :smile:
New Zenner
I don't seem to have it in mine.
I have:
htasccess_for_page_not_found_redirects.htsaccess
index.html
ipn_test.php
ipn_test_return.php
on Zen Cart 1.3.7 btw.
Zen Follower
why are you installing the previous version of Zen Cart, and not the current version, 1.3.8a? (this is a new installation thread, I thought.)
---Diana
New Zenner
This is what GoDaddy installed for us.
New Zenner
My client is about to go thru the roof... I can't get the credit cards to approve... It is sending into to PayTrace, but I keep getting errors when I try and "confirm order"
Any help would be greatly appreciated!
-B
Zen Follower
If you've never gotten your payment module to work, why would it have to be a CURL issue? Did you check your payment module settings and support FAQs for your payment gateway?
Since this issue is in the wrong thread, as you haven't run curltest.php, I'd post it in the Payment modules section of the website, and regard it as a payment module configuration issue.
There's nothing preventing you from downloading 1.3.8a and running the curl test.
You might want to contact GoDaddy for support with this issue, if it turns out to be unique to your server configuration.
New Zenner
Well.. I don't, and I guess I was wrong. I put up the curltest.php as you suggested. Looks like it passed:
Data validation
Good
Other Info
Your server IP address is: 64.202.161.130.
user-agent: unknown.
Array
(
[url] => "http://www.zen-cart.com/testcurl.php"
[content_type] => text/html
[http_code] => 200
[header_size] => 168
[request_size] => 245
[filetime] => -1
[ssl_verify_result] => 0
[redirect_count] => 0
[total_time] => 0.169
[namelookup_time] => 0.004
[connect_time] => 0.006
[pretransfer_time] => 0.006
[size_upload] => 0
[size_download] => 2142
[speed_download] => 12674.556213
[speed_upload] => 0
[download_content_length] => 0
[upload_content_length] => 0
[starttransfer_time] => 0.169
[redirect_time] => 0
)
I am just trying to figure out whats wrong and why... The paymentgateway and processing company suggested I try Authorize.net instead of PayTrace, but we got the same error.
Guess its back to the PayTrace configuration.... Sorry about being in the wrong forum.
-B
Tell staff why this post should be reviewed.