Zen Cart Logo
Forums / Installing on a Linux/Unix Server / 500 Internal Error

500 Internal Error

Locked

Views: 14,464

Results 1 to 20 of 31
This thread is locked. New replies are disabled.
4 Jan 2008, 6:35 PM
#1
dacordave avatar

dacordave

New Zenner

Join Date:
Jan 2008
Posts:
21
Plugin Contributions:
0

500 Internal Error

I know...I know... not again!
But, as a real newbie, I am stuck with this error.
"The server encountered an unexpected condition which prevented it from fulfilling the request.
The script had an error or it did not produce any output. If there was an error, you should be able to see it in the error log. "
I followed instructions to a T... still error.
Followed all the advice in threads... still error.
Have dowloaded/uploaded/ stood on my head, drank a bottle of port... still error!
I cant even find the error log it talks about.
I've put a support request in with hosting server (Startlogic)...waiting...waiting.
So, has any one got any step-by-step instructions that a newbie can follow (make that a babie can follow)... before I start on the brandy!

my url is https://www.aussiemarketplace.com (Yeah!.. I know... I'm an Ozzie) and its 5:00am Saturday... I've been at this since 7:00pm yesterday.
HELP!!
:frusty:
:oops:

4 Jan 2008, 9:31 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: 500 Internal Error

DacorDave:

I am stuck with this error.
"The server encountered an unexpected condition which prevented it from fulfilling the request.
The script had an error or it did not produce any output. If there was an error, you should be able to see it in the error log. "

"Where" or "When" are you getting this error?

5 Jan 2008, 1:14 AM
#3
dacordave avatar

dacordave

New Zenner

Join Date:
Jan 2008
Posts:
21
Plugin Contributions:
0

Re: 500 Internal Error

Morning DrByte
(Its now 11:45am Saturday... and I'm still no further....:frusty:

The "500 Internal Server Error" comes when I try to run the dc_install.php Installer. I have not been able to get any further, regardless of any combination of addresses of the catalog subdirectory... so I'm totally lost...

Oh! the bottle of brandy is almost empty!

Dave
:no:

:bangin:

5 Jan 2008, 1:18 AM
#4
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: 500 Internal Error

sounds like they have php running as cgi

create an upload a phpinfo file,

<?php
phpinfo();
?>

put this in a blank file name it info.php and upload it to your hosting account root,
then point your browser at it,

lets see if phpo is running as cgi,
if so then you will have to do a few permissions changes
( Wishes the devs would add modified directions for hosts running php as cgi )

5 Jan 2008, 1:28 AM
#5
dacordave avatar

dacordave

New Zenner

Join Date:
Jan 2008
Posts:
21
Plugin Contributions:
0

Re: 500 Internal Error

Thanks Merlinpa

I hope I've done it right...

This is what I get when I point my browser at info.php

"Page not found
The page you are looking for might have been removed,
had its name changed, or is temporarily unavailable.


Please try the following:
If you typed the page address in the Address bar, make sure that it is spelled correctly.

  • Click the Back button in your browser to try another link.
  • Use a search engine like Google to look for information on the Internet.

HTTP 404 - File not found

So, something's not right!!!!

5 Jan 2008, 1:52 AM
#6
dacordave avatar

dacordave

New Zenner

Join Date:
Jan 2008
Posts:
21
Plugin Contributions:
0

Re: 500 Internal Error

One thing I should add... checking through the list of files/folders where I have installed Zen Cart to, I notice there id no such file as zc_install.... only a folder (directory).... so how can I run the installer, if its not there to run??

Its a thought! or maybe its the bottle thinking!!

5 Jan 2008, 2:19 AM
#7
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: 500 Internal Error

the files to run are inside the folder

did you name your file info.php
did you upload it to the same place that your default index.html file would go

in c-panel this would be just inside the public_html folder

5 Jan 2008, 2:44 AM
#8
dacordave avatar

dacordave

New Zenner

Join Date:
Jan 2008
Posts:
21
Plugin Contributions:
0

Re: 500 Internal Error

Well, I double checked.

The info.php file is in the same directory as the index.html file and this is the result:
"500 Internal Server Error
The server encountered an unexpected condition which prevented it from fulfilling the request.
The script had an error or it did not produce any output. If there was an error, you should be able to see it in the error log. "

Its the same error as when I try to run the dc_install installer file

5 Jan 2008, 2:49 AM
#9
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: 500 Internal Error

Do you have access to your server's error logs? Perhaps via your hosting control panel?

5 Jan 2008, 2:55 AM
#10
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: 500 Internal Error

what are the folder permissions on the Root folder
in c-panel this would be public_html

5 Jan 2008, 3:14 AM
#11
dacordave avatar

dacordave

New Zenner

Join Date:
Jan 2008
Posts:
21
Plugin Contributions:
0

Re: 500 Internal Error

I'm pretty sure Ive got access to the server's error logs through a control panel (vDeck).
I also have a FileManager to view stats directory and access the raw log files.

The folder permissions of the public_html are full (777)

5 Jan 2008, 3:33 AM
#12
dacordave avatar

dacordave

New Zenner

Join Date:
Jan 2008
Posts:
21
Plugin Contributions:
0

Re: 500 Internal Error

Hi guys... what a frustrating day it has been....
I have just found out that allow_url_fopen Has Been Disabled on my host's servers. > "For security reasons, we've globally disabled allow_url_fopen in the default php.ini files. This will not affect most sites, but for some, it will cause some PHP pages to stop working as expected. There is no way to override this change. Pages and functionality relying on allow_url_fopen will need to be adjusted to use another means of remote file access.

There are other, safer means of accessing remote data. One such method is using cURL. cURL is built into php and is much safer (and generally better performing!) than fopen. A general overview of how to use cURL with php can be found here:
http://www.codeandcoffee.com/2006/07/17/how-to-use-curl-with-php/ "

hmmmmm!! (I dont know what that means, but it sounds like a big part of the present problem). So what does that mean? No to Zen... and find another cart?? gollllly goshhhh!

5 Jan 2008, 4:50 AM
#13
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: 500 Internal Error

Zen Cart uses CURL for most advanced communications.
It only relies on allow_url_fopen for a few things (and this will change in the next release):

  • USPS quotes
  • UPS-US quotes
  • PayPal IPN confirmations
  • Currency updates in the admin (but do a fallback to CURL anyway)
  • Admin new-version alerter (which can be disabled)

Other addons may require it.

The Zen Cart installer does not use any fopen resources, so the allow_url_fopen issue you mention has no bearing on installer problems. The installer does attempt to test CURL though, but not until the System Inspection page.

You have a few options:
a) continue if you can live with the above limitations
b) use a (different) host which has been proven to work with Zen Cart because they value ecommerce customers
c) or, as you said, find something else

5 Jan 2008, 4:55 AM
#14
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: 500 Internal Error

try changing public_html to 750

17 Jan 2008, 7:52 PM
#15
qhome avatar

qhome

Totally Zenned

Join Date:
Feb 2004
Posts:
1,702
Plugin Contributions:
5

Re: 500 Internal Error

just got around to installing a fresh copy of 1.3.8a and i too am getting this error. Usually i just delete the .htaccess and set the folder permissions, but this time there is no htaccess on my server and All the folders/file appear to be set up correctly.

here is a link to my phpinfo file:
http://www.unbannable.com/phpinfo.php

I also run zc136 and zc137 on this server with no problems. Not sure whats different about zc138a.

17 Jan 2008, 8:04 PM
#16
qhome avatar

qhome

Totally Zenned

Join Date:
Feb 2004
Posts:
1,702
Plugin Contributions:
5

Re: 500 Internal Error

Resolved.

Seems my ftp program is hiding the .htaccess file that was inside the zc_install folder. I looked through cpanel and deleted it and it no longer gives me the error. Installing now :)

I've hosted with many diff companies and none of them seem to like the zen-cart htaccess files nor most other programs (CMS, blogs, etc). Perhaps there needs to be an initiative for htaccess similarly like the GoPHP5 initiative.

18 Jan 2008, 4:25 AM
#17
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: 500 Internal Error

Zen Cart v1.3.8 is much less prone to mod_security blocks during install-time than prior versions were.
The /zc_install/.htaccess file may be no longer needed, and might be removed in v1.4 to help avoid this issue.

18 Jan 2008, 4:37 PM
#18
keef6666 avatar

keef6666

New Zenner

Join Date:
Jan 2008
Posts:
9
Plugin Contributions:
0

Re: 500 Internal Error

Hi, I have just installed zen cart for the first time on a linux server, the Hello. Thank you for loading Zen Cart™ page loads but when I click install I receive Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

The log file says directory index forbidden by rule
as well as premature end of script headers htdocs/cgi-bin/jmail.asp

any help please.
Keith

18 Jan 2008, 5:52 PM
#19
qhome avatar

qhome

Totally Zenned

Join Date:
Feb 2004
Posts:
1,702
Plugin Contributions:
5

Re: 500 Internal Error

keef6666:

Hi, I have just installed zen cart for the first time on a linux server, the Hello. Thank you for loading Zen Cart™ page loads but when I click install I receive Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

The log file says directory index forbidden by rule
as well as premature end of script headers htdocs/cgi-bin/jmail.asp

any help please.
Keith

Read my resolution 2 posts up

18 Jan 2008, 6:49 PM
#20
keef6666 avatar

keef6666

New Zenner

Join Date:
Jan 2008
Posts:
9
Plugin Contributions:
0

Re: 500 Internal Error

:clap: Thanx it works !!!!:yes: