Zen Cart Logo
Forums / Upgrading from 1.3.x to 1.3.9 / blank page during install

blank page during install

Locked

Views: 14,621

Results 21 to 40 of 43
This thread is locked. New replies are disabled.
31 Mar 2009, 7:10 PM
#21
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

blank page during install

Your post doesn't indicate whether you've actually followed any of the suggestions discussed earlier in this thread ... such as:> DrByte:

maybe you don't have the /zc_install/includes/modules/pages/config_checkup/header_php.php file on your server?

1 Apr 2009, 12:14 AM
#22
georgezheng avatar

georgezheng

New Zenner

Join Date:
Mar 2009
Posts:
13
Plugin Contributions:
0

Re: blank page during install

thanks for DrByte's speedly reply!
i read all the post in this thread,and try what i can do to fix that.but it is impossible for me to upgrade my mysql.so i still got the blank page when installer do the system inspect in the third step?any idea to handle it.

important:why i don't want to upgrade because just two weeks ago i install zen cart well in the same server,though at first it has the same prob,but i don't know why it goes well later.

thanks!!!!!!!!!!!!!!!

1 Apr 2009, 12:26 AM
#23
georgezheng avatar

georgezheng

New Zenner

Join Date:
Mar 2009
Posts:
13
Plugin Contributions:
0

Re: blank page during install

i have read and tried those thread:
http://www.zen-cart.com/forum/showthread.php?t=54802&highlight=blank+page+system+inspect
http://www.zen-cart.com/forum/showthread.php?t=110920&highlight=blank+inspect

http://www.zen-cart.com/forum/showthread.php?t=85522&highlight=blank+inspect

http://www.zen-cart.com/forum/showthread.php?t=80078&highlight=blank+inspect

but seems nobody who have same blank page in the system inspect page got to solve the problem.

zen cart is no aware of this?it's not so good 。。。。thought i hope anyone who have experience on fixing this can help me out!!!:smile:

1 Apr 2009, 12:27 AM
#24
georgezheng avatar

georgezheng

New Zenner

Join Date:
Mar 2009
Posts:
13
Plugin Contributions:
0

Re: blank page during install

there is no install log under cache
no log in php log
no log in apache log,just one 302 code respone

any idea ?

1 Apr 2009, 4:48 AM
#25
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: blank page during install

Normally Zen Cart suppresses the display of all PHP errors, for security and aesthetic reasons.

If you want to have PHP show the ugly errors on the screen while the installer is running,
edit the /zc_install/includes/installer_params.php file, and change this line:define('STRICT_ERROR_REPORTING', [B]false[/B]);to say TRUE:```
define('STRICT_ERROR_REPORTING', [B]TRUE[/B]);


Your server is likely imposing restrictions on the inspection operations, causing fatal PHP errors.
Or, maybe you're missing some of the required files and thus triggering PHP errors.
1 Apr 2009, 9:06 AM
#26
georgezheng avatar

georgezheng

New Zenner

Join Date:
Mar 2009
Posts:
13
Plugin Contributions:
0

Re: blank page during install

thanks for DrByte reply!!!

however,i tried add that code but with no output.

but it seems your reply make some sense to me,but i don't know how can i lower the restrict on the system inspect or where to change it.because i don't know what configuration directive that can be used to let the zct installer do system inspect?:frusty:

1 Apr 2009, 9:25 AM
#27
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: blank page during install

I think your FTP upload failed.
Re-upload all your files to the server again.

1 Apr 2009, 2:02 PM
#28
georgezheng avatar

georgezheng

New Zenner

Join Date:
Mar 2009
Posts:
13
Plugin Contributions:
0

Re: blank page during install

hi DrByte,

i have tried reupload all the need file and check them be uploaded successfully many times.also i have try to download zen cart directly on server and extract it on the server.so it may not caused by trancated file.

so still no idea to solve this prob?!!:frusty::frusty:

below is phpinfo page:

System  Linux localhost.localdomain 2.6.18-92.el5 #1 SMP Tue Jun 10 18:49:47 EDT 2008 i686  
Build Date  Jan 1 2009 18:08:52  
Configure Command  './configure' '--prefix=/usr/local/php' '--with-apxs2=/usr/local/apache2/bin/apxs' '--with-mysql=/usr/local/mysql/' '--with-curl=/usr/local/curl' '--enable-ftp' '--enable-sockets' '--with-libxml-dir=/usr/local/libxml2' '--with-expat-dir=/usr/lib' '--enable-soap' '--with-xsl=/usr/local/libxslt' '--enable-xslt' '--with-gd=/usr/local/gd2/' '--with-jpeg-dir=/usr/local/jpeg6/' '--with-zlib-dir=/usr/local/lib/' '--with-png=/usr/local/lib/' '--with-freetype-dir=/usr/local/freetype/' '--enable-bcmath' '--enable-pdo' '--with-pdo-sqlite=shared' '--with-sqlite=shared' '--with-pdo-mysql=/usr/local/mysql/bin/mysql_config' '--with-mcrypt=/usr/local' '--with-mhash'  
Server API  Apache 2.0 Handler  
Virtual Directory Support  disabled  
Configuration File (php.ini) Path  /usr/local/php/lib  
Loaded Configuration File  /usr/local/Zend/etc/php.ini  
PHP API  20041225  
PHP Extension  20060613  
Zend Extension  220060519  
Debug Build  no  
Thread Safety  disabled  
Zend Memory Manager  enabled  
IPv6 Support  enabled  
Registered PHP Streams  php, file, data, http, ftp, compress.zlib  
Registered Stream Socket Transports  tcp, udp, unix, udg  
Registered Stream Filters  string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, convert.iconv.*, zlib.*  

 This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    with Zend Extension Manager v1.2.2, Copyright (c) 2003-2007, by Zend Technologies
    with Zend Optimizer v3.3.3, Copyright (c) 1998-2007, by Zend Technologies
 


--------------------------------------------------------------------------------

PHP Credits

--------------------------------------------------------------------------------

Configuration
PHP Core
Directive Local Value Master Value 
allow_call_time_pass_reference On On 
allow_url_fopen On On 
allow_url_include Off Off 
always_populate_raw_post_data Off Off 
arg_separator.input & & 
arg_separator.output & & 
asp_tags Off Off 
auto_append_file no value no value 
auto_globals_jit On On 
auto_prepend_file no value no value 
browscap no value no value 
default_charset no value no value 
default_mimetype text/html text/html 
define_syslog_variables Off Off 
disable_classes no value no value 
disable_functions no value no value 
display_errors On On 
display_startup_errors Off Off 
doc_root no value no value 
docref_ext no value no value 
docref_root no value no value 
enable_dl On On 
error_append_string no value no value 
error_log no value no value 
error_prepend_string no value no value 
error_reporting 6135 6135 
expose_php On On 
extension_dir ./ ./ 
file_uploads On On 
highlight.bg #FFFFFF #FFFFFF 
highlight.comment #FF8000 #FF8000 
highlight.default #0000BB #0000BB 
highlight.html #000000 #000000 
highlight.keyword #007700 #007700 
highlight.string #DD0000 #DD0000 
html_errors On On 
ignore_repeated_errors Off Off 
ignore_repeated_source Off Off 
ignore_user_abort Off Off 
implicit_flush Off Off 
include_path .:/usr/local/php/lib/php .:/usr/local/php/lib/php 
log_errors Off Off 
log_errors_max_len 1024 1024 
magic_quotes_gpc On On 
magic_quotes_runtime Off Off 
magic_quotes_sybase Off Off 
mail.force_extra_parameters no value no value 
max_execution_time 30 30 
max_input_nesting_level 64 64 
max_input_time 60 60 
memory_limit 128M 128M 
open_basedir no value no value 
output_buffering no value no value 
output_handler no value no value 
post_max_size 8M 8M 
precision 12 12 
realpath_cache_size 16K 16K 
realpath_cache_ttl 120 120 
register_argc_argv On On 
register_globals Off Off 
register_long_arrays On On 
report_memleaks On On 
report_zend_debug On On 
safe_mode Off Off 
safe_mode_exec_dir no value no value 
safe_mode_gid Off Off 
safe_mode_include_dir no value no value 
sendmail_from no value no value 
sendmail_path /usr/sbin/sendmail -t -i  /usr/sbin/sendmail -t -i  
serialize_precision 100 100 
short_open_tag On On 
SMTP localhost localhost 
smtp_port 25 25 
sql.safe_mode Off Off 
track_errors Off Off 
unserialize_callback_func no value no value 
upload_max_filesize 2M 2M 
upload_tmp_dir no value no value 
user_dir no value no value 
variables_order EGPCS EGPCS 
xmlrpc_error_number 0 0 
xmlrpc_errors Off Off 
y2k_compliance On On 
zend.ze1_compatibility_mode Off Off 


apache2handler
Apache Version  Apache/2.2.8 (Unix) DAV/2 PHP/5.2.3  
Apache API Version  20051115  
Server Administrator  [email protected]  
Hostname:Port  [url]www.topguccishoes.com:0[/url]  
User/Group  daemon(2)/2  
Max Requests  Per Child: 10000 - Keep Alive: on - Max Per Connection: 100  
Timeouts  Connection: 300 - Keep-Alive: 5  
Virtual Server  Yes  
Server Root  /usr/local/apache2  
Loaded Modules  core prefork http_core mod_so mod_authn_file mod_authn_dbm mod_authn_anon mod_authn_dbd mod_authn_default mod_authz_host mod_authz_groupfile mod_authz_user mod_authz_dbm mod_authz_owner mod_authz_default mod_auth_basic mod_auth_digest mod_cache mod_dbd mod_dumpio mod_ext_filter mod_include mod_filter mod_substitute mod_deflate mod_log_config mod_log_forensic mod_logio mod_env mod_mime_magic mod_cern_meta mod_expires mod_headers mod_ident mod_usertrack mod_unique_id mod_setenvif mod_version mod_mime mod_dav mod_status mod_autoindex mod_asis mod_info mod_cgi mod_dav_fs mod_vhost_alias mod_negotiation mod_dir mod_imagemap mod_actions mod_speling mod_userdir mod_alias mod_rewrite mod_php5  

Directive Local Value Master Value 
engine 1 1 
last_modified 0 0 
xbithack 0 0 


Apache Environment
Variable Value 
UNIQUE_ID  e2SvsH8AAAEAACSpVD0AAAAF  
HTTP_ACCEPT  image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, application/x-silverlight, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, */*  
HTTP_ACCEPT_LANGUAGE  zh-cn  
HTTP_USER_AGENT  Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; CIBA; .NET CLR 2.0.50727)  
HTTP_HOST  [url]www.topguccishoes.com[/url]  
HTTP_CONNECTION  Keep-Alive  
HTTP_COOKIE  zenInstallId=f3ae81556d60afe98b81e600b5f7dfac  
PATH  /sbin:/usr/sbin:/bin:/usr/bin  
SERVER_SIGNATURE  no value  
SERVER_SOFTWARE  Apache/2.2.8 (Unix) DAV/2 PHP/5.2.3  
SERVER_NAME  [url]www.topguccishoes.com[/url]  
SERVER_ADDR  204.13.69.235  
SERVER_PORT  80  
REMOTE_ADDR  58.22.132.91  
DOCUMENT_ROOT  /www/www.topguccishoes.com/  
SERVER_ADMIN  [email protected]  
SCRIPT_FILENAME  /www/www.topguccishoes.com/test.php  
REMOTE_PORT  2355  
GATEWAY_INTERFACE  CGI/1.1  
SERVER_PROTOCOL  HTTP/1.0  
REQUEST_METHOD  GET  
QUERY_STRING  no value  
REQUEST_URI  /test.php  
SCRIPT_NAME  /test.php  


HTTP Headers Information
HTTP Request Headers 
HTTP Request  GET /test.php HTTP/1.0  
Accept  image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, application/x-silverlight, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, */*  
Accept-Language  zh-cn  
User-Agent  Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; CIBA; .NET CLR 2.0.50727)  
Host  [url]www.topguccishoes.com[/url]  
Connection  Keep-Alive  
Cookie  zenInstallId=f3ae81556d60afe98b81e600b5f7dfac  
HTTP Response Headers 
X-Powered-By  PHP/5.2.3  
Connection  close  
Content-Type  text/html  


bcmath
BCMath support  enabled  


ctype
ctype functions  enabled  


curl
cURL support  enabled  
cURL Information  libcurl/7.15.3 OpenSSL/0.9.8b zlib/1.2.3  


date
date/time support  enabled  
"Olson" Timezone Database Version  2007.5  
Timezone Database  internal  
Default timezone  Asia/Shanghai  

Directive Local Value Master Value 
date.default_latitude 31.7667 31.7667 
date.default_longitude 35.2333 35.2333 
date.sunrise_zenith 90.583333 90.583333 
date.sunset_zenith 90.583333 90.583333 
date.timezone Asia/Shanghai Asia/Shanghai 


dom
DOM/XML  enabled  
DOM/XML API Version  20031129  
libxml Version  2.6.19  
HTML Support  enabled  
XPath Support  enabled  
XPointer Support  enabled  
Schema Support  enabled  
RelaxNG Support  enabled  


filter
Input Validation and Filtering  enabled  
Revision  $Revision: 1.52.2.39 $  

Directive Local Value Master Value 
filter.default unsafe_raw unsafe_raw 
filter.default_flags no value no value 


ftp
FTP support  enabled  


gd
GD Support  enabled  
GD Version  2.0 or higher  
FreeType Support  enabled  
FreeType Linkage  with freetype  
FreeType Version  2.1.10  
GIF Read Support  enabled  
GIF Create Support  enabled  
JPG Support  enabled  
PNG Support  enabled  
WBMP Support  enabled  


hash
hash support  enabled  
Hashing Engines  md2 md4 md5 sha1 sha256 sha384 sha512 ripemd128 ripemd160 ripemd256 ripemd320 whirlpool tiger128,3 tiger160,3 tiger192,3 tiger128,4 tiger160,4 tiger192,4 snefru gost adler32 crc32 crc32b haval128,3 haval160,3 haval192,3 haval224,3 haval256,3 haval128,4 haval160,4 haval192,4 haval224,4 haval256,4 haval128,5 haval160,5 haval192,5 haval224,5 haval256,5  


iconv
iconv support  enabled  
iconv implementation  glibc  
iconv library version  2.5  

Directive Local Value Master Value 
iconv.input_encoding ISO-8859-1 ISO-8859-1 
iconv.internal_encoding ISO-8859-1 ISO-8859-1 
iconv.output_encoding ISO-8859-1 ISO-8859-1 


json
json support  enabled  
json version  1.2.1  


libxml
libXML support  active  
libXML Version  2.6.19  
libXML streams  enabled  


mcrypt
mcrypt support enabled 
Version  2.5.7  
Api No  20021217  
Supported ciphers  cast-128 gost rijndael-128 twofish arcfour cast-256 loki97 rijndael-192 saferplus wake blowfish-compat des rijndael-256 serpent xtea blowfish enigma rc2 tripledes  
Supported modes  cbc cfb ctr ecb ncfb nofb ofb stream  

Directive Local Value Master Value 
mcrypt.algorithms_dir no value no value 
mcrypt.modes_dir no value no value 


mhash
MHASH support  Enabled  
MHASH API Version  20060101  


mysql
MySQL Support enabled 
Active Persistent Links  0  
Active Links  0  
Client API version  5.0.21  
MYSQL_MODULE_TYPE  external  
MYSQL_SOCKET  /tmp/mysql.sock  
MYSQL_INCLUDE  -I/usr/local/mysql//include  
MYSQL_LIBS  -L/usr/local/mysql//lib -lmysqlclient  

Directive Local Value Master Value 
mysql.allow_persistent On On 
mysql.connect_timeout 60 60 
mysql.default_host no value no value 
mysql.default_password no value no value 
mysql.default_port no value no value 
mysql.default_socket no value no value 
mysql.default_user no value no value 
mysql.max_links Unlimited Unlimited 
mysql.max_persistent Unlimited Unlimited 
mysql.trace_mode Off Off 


pcre
PCRE (Perl Compatible Regular Expressions) Support  enabled  
PCRE Library Version  7.0 18-Dec-2006  


PDO
PDO support enabled 
PDO drivers  mysql  


pdo_mysql
PDO Driver for MySQL, client library version 5.0.21 


posix
Revision  $Revision: 1.70.2.3.2.15 $  


Reflection
Reflection enabled 
Version  $Id: php_reflection.c,v 1.164.2.33.2.39 2007/05/29 08:44:05 helly Exp $  


session
Session Support  enabled  
Registered save handlers  files user  
Registered serializer handlers  php php_binary  

Directive Local Value Master Value 
session.auto_start Off Off 
session.bug_compat_42 On On 
session.bug_compat_warn On On 
session.cache_expire 180 180 
session.cache_limiter nocache nocache 
session.cookie_domain no value no value 
session.cookie_httponly Off Off 
session.cookie_lifetime 0 0 
session.cookie_path / / 
session.cookie_secure Off Off 
session.entropy_file no value no value 
session.entropy_length 0 0 
session.gc_divisor 100 100 
session.gc_maxlifetime 1440 1440 
session.gc_probability 1 1 
session.hash_bits_per_character 4 4 
session.hash_function 0 0 
session.name PHPSESSID PHPSESSID 
session.referer_check no value no value 
session.save_handler files files 
session.save_path no value no value 
session.serialize_handler php php 
session.use_cookies On On 
session.use_only_cookies Off Off 
session.use_trans_sid 0 0 


SimpleXML
Simplexml support enabled 
Revision  $Revision: 1.151.2.22.2.26 $  
Schema support  enabled  


soap
Soap Client  enabled  
Soap Server  enabled  

Directive Local Value Master Value 
soap.wsdl_cache 1 1 
soap.wsdl_cache_dir /tmp /tmp 
soap.wsdl_cache_enabled 1 1 
soap.wsdl_cache_limit 5 5 
soap.wsdl_cache_ttl 86400 86400 


sockets
Sockets Support  enabled  


SPL
SPL support enabled 
Interfaces  Countable, OuterIterator, RecursiveIterator, SeekableIterator, SplObserver, SplSubject  
Classes  AppendIterator, ArrayIterator, ArrayObject, BadFunctionCallException, BadMethodCallException, CachingIterator, DirectoryIterator, DomainException, EmptyIterator, FilterIterator, InfiniteIterator, InvalidArgumentException, IteratorIterator, LengthException, LimitIterator, LogicException, NoRewindIterator, OutOfBoundsException, OutOfRangeException, OverflowException, ParentIterator, RangeException, RecursiveArrayIterator, RecursiveCachingIterator, RecursiveDirectoryIterator, RecursiveFilterIterator, RecursiveIteratorIterator, RecursiveRegexIterator, RegexIterator, RuntimeException, SimpleXMLIterator, SplFileInfo, SplFileObject, SplObjectStorage, SplTempFileObject, UnderflowException, UnexpectedValueException  


standard
Regex Library  Bundled library enabled  
Dynamic Library Support  enabled  
Path to sendmail  /usr/sbin/sendmail -t -i  

Directive Local Value Master Value 
assert.active 1 1 
assert.bail 0 0 
assert.callback no value no value 
assert.quiet_eval 0 0 
assert.warning 1 1 
auto_detect_line_endings 0 0 
default_socket_timeout 60 60 
safe_mode_allowed_env_vars PHP_ PHP_ 
safe_mode_protected_env_vars LD_LIBRARY_PATH LD_LIBRARY_PATH 
url_rewriter.tags a=href,area=href,frame=src,input=src,form=,fieldset= a=href,area=href,frame=src,input=src,form=,fieldset= 
user_agent no value no value 


tokenizer
Tokenizer Support  enabled  


xml
XML Support  active  
XML Namespace Support  active  
libxml2 Version  2.6.19  


xmlreader
XMLReader  enabled  


xmlwriter
XMLWriter  enabled  


xsl
XSL  enabled  
libxslt Version  1.1.15  
libxslt compiled against libxml Version  2.6.19  
EXSLT  enabled  
libexslt Version  1.1.15  


Zend Optimizer
Optimization Pass 1  enabled  
Optimization Pass 2  enabled  
Optimization Pass 3  enabled  
Optimization Pass 4  enabled  
Optimization Pass 9  enabled  
Zend Loader  enabled  
License Path  no value  
Obfuscation level  3  


zlib
ZLib Support  enabled  
Stream Wrapper support  compress.zlib://  
Stream Filter support  zlib.inflate, zlib.deflate  
Compiled Version  1.2.3  
Linked Version  1.2.3  

Directive Local Value Master Value 
zlib.output_compression Off Off 
zlib.output_compression_level -1 -1 
zlib.output_handler no value no value 


Additional Modules
Module Name 


Environment
Variable Value 
SELINUX_INIT  YES  
CONSOLE  /dev/console  
TERM  linux  
LD_LIBRARY_PATH  /usr/local/apache2/lib:  
INIT_VERSION  sysvinit-2.86  
PATH  /sbin:/usr/sbin:/bin:/usr/bin  
RUNLEVEL  3  
runlevel  3  
PWD  /  
LANG  en_US.UTF-8  
PREVLEVEL  N  
previous  N  
HOME  /  
SHLVL  2  
_  /usr/local/apache2/bin/httpd  


PHP Variables
Variable Value 
_REQUEST["zenInstallId"] f3ae81556d60afe98b81e600b5f7dfac 
_COOKIE["zenInstallId"] f3ae81556d60afe98b81e600b5f7dfac 
_SERVER["UNIQUE_ID"] e2SvsH8AAAEAACSpVD0AAAAF 
_SERVER["HTTP_ACCEPT"] image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, application/x-silverlight, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, */* 
_SERVER["HTTP_ACCEPT_LANGUAGE"] zh-cn 
_SERVER["HTTP_USER_AGENT"] Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; CIBA; .NET CLR 2.0.50727) 
_SERVER["HTTP_HOST"] [url]www.topguccishoes.com[/url] 
_SERVER["HTTP_CONNECTION"] Keep-Alive 
_SERVER["HTTP_COOKIE"] zenInstallId=f3ae81556d60afe98b81e600b5f7dfac 
_SERVER["PATH"] /sbin:/usr/sbin:/bin:/usr/bin 
_SERVER["SERVER_SIGNATURE"] no value 
_SERVER["SERVER_SOFTWARE"] Apache/2.2.8 (Unix) DAV/2 PHP/5.2.3 
_SERVER["SERVER_NAME"] [url]www.topguccishoes.com[/url] 
_SERVER["SERVER_ADDR"] 204.13.69.235 
_SERVER["SERVER_PORT"] 80 
_SERVER["REMOTE_ADDR"] 58.22.132.91 
_SERVER["DOCUMENT_ROOT"] /www/www.topguccishoes.com/ 
_SERVER["SERVER_ADMIN"] [email protected] 
_SERVER["SCRIPT_FILENAME"] /www/www.topguccishoes.com/test.php 
_SERVER["REMOTE_PORT"] 2355 
_SERVER["GATEWAY_INTERFACE"] CGI/1.1 
_SERVER["SERVER_PROTOCOL"] HTTP/1.0 
_SERVER["REQUEST_METHOD"] GET 
_SERVER["QUERY_STRING"] no value 
_SERVER["REQUEST_URI"] /test.php 
_SERVER["SCRIPT_NAME"] /test.php 
_SERVER["PHP_SELF"] /test.php 
_SERVER["REQUEST_TIME"] 1238511724 
_SERVER["argv"] Array
(
)
 
_SERVER["argc"] 0 
_ENV["SELINUX_INIT"] YES 
_ENV["CONSOLE"] /dev/console 
_ENV["TERM"] linux 
_ENV["LD_LIBRARY_PATH"] /usr/local/apache2/lib: 
_ENV["INIT_VERSION"] sysvinit-2.86 
_ENV["PATH"] /sbin:/usr/sbin:/bin:/usr/bin 
_ENV["RUNLEVEL"] 3 
_ENV["runlevel"] 3 
_ENV["PWD"] / 
_ENV["LANG"] en_US.UTF-8 
_ENV["PREVLEVEL"] N 
_ENV["previous"] N 
_ENV["HOME"] / 
_ENV["SHLVL"] 2 
_ENV["_"] /usr/local/apache2/bin/httpd
1 Apr 2009, 3:30 PM
#29
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: blank page during install

It seems you have it working now. When I go to https://www.topguccishoes.com I see a Zen Cart site ... but it looks like you're using a version of Zen Cart which was obtained from zencart.cn ... which is not the same code as published at zen-cart.com. Thus, the standard troubleshooting methods which I would use may not apply, since the CN version is based on an older version of Zen Cart. My troubleshooting help is based on Zen Cart v1.3.8a, as downloaded from https://www.zen-cart.com

2 Apr 2009, 7:18 AM
#30
georgezheng avatar

georgezheng

New Zenner

Join Date:
Mar 2009
Posts:
13
Plugin Contributions:
0

Re: blank page during install

hi DrByte,

thanks for your patience with me.However,the :frusty: problem is still gain no idea.if i have some idea on it,i would share with everybody here,so many people have the same headache,see :

http://www.zen-cart.com/forum/showthread.php?t=94700
http://www.zen-cart.com/forum/showthread.php?t=54802
http://www.zen-cart.com/forum/showthread.php?t=110920
http://www.zen-cart.com/forum/showthread.php?t=89614
http://www.zen-cart.com/forum/showthread.php?t=85522
http://www.zen-cart.com/forum/showthread.php?t=80078

i just have a way to go around it.just like i said i have install some zen cart(the same version 1.3.8a) in this same server.so i just copy and import the db,they can just work,but still can not bypass the system insepct step.have a look at here:

http://xp-shopping.com/

i tried to down load from zen.com with the 1.3.8a en version,but still ,i meet the dead blank page.

with the phpinfo page ,can you help me to figure out?

i belive there are some others have the same problem keep an eye on this thread.

thanks!!

2 Apr 2009, 7:32 AM
#31
georgezheng avatar

georgezheng

New Zenner

Join Date:
Mar 2009
Posts:
13
Plugin Contributions:
0

Re: blank page during install

no logs under zen cart cahce folder.
only found those from access log of apache:

58.22.77.118 - - [02/Apr/2009:02:24:17 -0500] "GET / HTTP/1.1" 200 2728 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8"
58.22.77.118 - - [02/Apr/2009:02:24:17 -0500] "GET /includes/templates/template_default/images/logo.gif HTTP/1.1" 304 - "http://xp-shopping.com/" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8"
58.22.77.118 - - [02/Apr/2009:02:24:19 -0500] "GET /zc_install/index.php HTTP/1.1" 200 2611 "http://xp-shopping.com/" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8"
58.22.77.118 - - [02/Apr/2009:02:24:19 -0500] "GET /zc_install/includes/templates/template_default/images/zen_header_bg.jpg HTTP/1.1" 200 12230 "http://xp-shopping.com/zc_install/index.php" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8"
58.22.77.118 - - [02/Apr/2009:02:24:20 -0500] "GET /zc_install/includes/templates/template_default/templates/about_zencart.html HTTP/1.1" 200 5522 "http://xp-shopping.com/zc_install/index.php" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8"
58.22.77.118 - - [02/Apr/2009:02:24:20 -0500] "GET /zc_install/includes/templates/template_default/images/tile_back.jpg HTTP/1.1" 200 1028 "http://xp-shopping.com/zc_install/includes/templates/template_default/css/stylesheet.css" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8"
58.22.77.118 - - [02/Apr/2009:02:24:21 -0500] "POST /zc_install/index.php?main_page=license HTTP/1.1" 200 2944 "http://xp-shopping.com/zc_install/index.php" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8"
58.22.77.118 - - [02/Apr/2009:02:24:21 -0500] "GET /zc_install/includes/templates/template_default/templates/gpl_license.html HTTP/1.1" 200 19247 "http://xp-shopping.com/zc_install/index.php?main_page=license" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8"
58.22.77.118 - - [02/Apr/2009:02:24:23 -0500] "POST /zc_install/index.php?main_page=license HTTP/1.1" 302 - "http://xp-shopping.com/zc_install/index.php?main_page=license" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8"

below are from error log of apache

[Thu Apr 02 02:08:41 2009] [error] [client 58.22.77.118] File does not exist: /www/xp-shopping.com/favicon.ico
[Thu Apr 02 02:08:42 2009] [error] [client 58.22.77.118] File does not exist: /www/xp-shopping.com/zc_install/favicon.ico
[Thu Apr 02 02:08:44 2009] [error] [client 58.22.77.118] File does not exist: /www/xp-shopping.com/favicon.ico
[Thu Apr 02 02:08:44 2009] [error] [client 58.22.77.118] File does not exist: /www/xp-shopping.com/zc_install/favicon.ico
[Thu Apr 02 02:08:44 2009] [error] [client 58.22.77.118] File does not exist: /www/xp-shopping.com/zc_install/favicon.ico

but give me no ideas,what do you think???

any idea or suggest is appreciated!!!!!!111

6 Apr 2009, 4:11 AM
#32
georgezheng avatar

georgezheng

New Zenner

Join Date:
Mar 2009
Posts:
13
Plugin Contributions:
0

Re: blank page during install

hi,nobody respone to me?

8 Apr 2009, 7:10 AM
#33
georgezheng avatar

georgezheng

New Zenner

Join Date:
Mar 2009
Posts:
13
Plugin Contributions:
0

Re: blank page during install

so this problem will be a puzzle for ever,how can zen cart team take no account of this.

8 Apr 2009, 7:00 PM
#34
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: blank page during install

From what I am seeing I would say you have a bad upload of files on the server ...

First, try to reload the files via FTP for:
/zc_install

and all of the subdirectories ...

If this is a brand new install, and if that first suggestion fails, I would reload all of the files ...

11 Apr 2009, 9:28 AM
#35
georgezheng avatar

georgezheng

New Zenner

Join Date:
Mar 2009
Posts:
13
Plugin Contributions:
0

Re: blank page during install

hi Ajeh,

i have try to upload all files with diff ftp client many times,and at last i download the tar ball from zen cart site to my server.so it not the problem you talked about.

anyway,if you are member of the core team you may put more attention to this prob,so many people meet the same prob.

thanks in advance.

george

11 Apr 2009, 2:08 PM
#36
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: blank page during install

I am on the Zen Cart Development Team ... :smile:

And your problem sounds like a bad install of the files to the server ...

What file did you download? We use Zip files ... :unsure:

5 May 2009, 12:51 AM
#37
georgezheng avatar

georgezheng

New Zenner

Join Date:
Mar 2009
Posts:
13
Plugin Contributions:
0

Re: blank page during install

Ajeh:

I am on the Zen Cart Development Team ... :smile:

And your problem sounds like a bad install of the files to the server ...

What file did you download? We use Zip files ... :unsure:

well,i hope you,guys on the zen cart team can help us to figure out:

i use:
wget http://nchc.dl.sourceforge.net/sourceforge/zencart/zen-cart-v1.3.8a-full-fileset-12112007.zip

to get the zen cart zip file,so it shouldn't be problem like broken file when upload via ftp client.

here you can check it:
http://www.xp-shopping.com/

yes,it may be caused by my server,but zen cart didn't give us some info that make sense.just a blank page.

5 May 2009, 2:31 PM
#38
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: blank page during install

Reload the files, via FTP, as it really looks like you have some files that are missing, bad or otherwise corrupt on the server ...

5 May 2009, 4:00 PM
#39
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: blank page during install

georgezheng,

Is your /cache/ folder set to 777 permissions?

There is a difference between v1.3.7 and v1.3.8: in v1.3.8 it requires PHP to be able to activate a PHP session. This is for many reasons, including the fact that if you can't start a PHP session, you won't be able to use Zen Cart anyway, so if that problem occurs at install-time, then you will know right away that the server has problems.
Additionally, in order to start a session before doing a full install and having database access, it must temporarily store a couple files in the /cache/ folder, hence the requirement for the /cache/ folder to be writable (777).

27 May 2009, 3:46 AM
#40
desertdreams avatar

desertdreams

New Zenner

Join Date:
May 2009
Location:
Arizona & Michigan
Posts:
2
Plugin Contributions:
0

Re: blank page during install

Getting the following on install:
Fatal error: Call to undefined function preg_match() in /home/drachir/desertdreamsllc.com/web/zen_cart/zc_install/includes/functions/general.php on line 467

Line 467:
if (preg_match('/.php$/', $zv_file) > 0) {

Zen Ver: 1.3.8
Add Ons: none
read all FAQs, search Forum, found this thread.

First store setup with ZenCart. Help!

Thanks...