Zen Cart Logo

Access Denied

Locked

Views: 6,552

Results 21 to 29 of 29
This thread is locked. New replies are disabled.
6 May 2008, 3:47 AM
#21
rosers avatar

rosers

New Zenner

Join Date:
Apr 2008
Posts:
17
Plugin Contributions:
0

Access Denied

ok so how do i do a reinstall or re-upload do i just delete what is there and start again?

6 May 2008, 4:04 AM
#22
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Access Denied

  1. Make full backups of all files and database, as mentioned above.
  2. Make a copy of your /includes/configure.php and /admin/includes/configure.php files in a separate folder on your PC, you'll need them again shortly.
  3. Delete all the files and folders you uploaded to your server (make sure you only delete the ones you uploaded, not the ones that were there already from your hosting company).
  4. Re-upload the clean set of Zen Cart files.
  5. Re-upload the /includes/configure.php and /admin/includes/configure.php files you saved in step 2.
  6. Test to see what happens now when accessing your store in your browser.

If that still has problems, it might be necessary to run zc_install and wipe the database ...

6 May 2008, 4:35 AM
#23
rosers avatar

rosers

New Zenner

Join Date:
Apr 2008
Posts:
17
Plugin Contributions:
0

Re: Access Denied

i just did a full copy of every file and still the same :cry:
i am so not looking forward to putting the products in :frusty:
but it happens

10 Oct 2008, 3:57 PM
#26
crato avatar

crato

New Zenner

Join Date:
Oct 2008
Posts:
7
Plugin Contributions:
0

Re: Access Denied

crato:

same prob. as well as mine.

when you try to log in or add a product to shopping cart it gives same message.

http://www.scandiskcards.com/zencart/index.php?main_page=login&action=process

http://www.scandiskcards.com/zencart/index.php?main_page=product_info&cPath=2_3&products_id=185&action=add_product

and also,

when i looked into server error log file i've found those lines

[Fri Oct 10 09:54:29 2008] [error] [client 66.249.73.215] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/pdo.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/pdo.so: undefined symbol: compiler_globals in Unknown on line 0
[Fri Oct 10 09:54:29 2008] [error] [client 66.249.73.215] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/pdo_sqlite.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/pdo_sqlite.so: undefined symbol: core_globals in Unknown on line 0
[Fri Oct 10 09:54:29 2008] [error] [client 66.249.73.215] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/sqlite.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/sqlite.so: undefined symbol: ps_globals in Unknown on line 0
[Fri Oct 10 09:54:29 2008] [error] [client 66.249.73.215] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/pdo_mysql.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/pdo_mysql.so: undefined symbol: core_globals in Unknown on line 0
[Fri Oct 10 09:54:29 2008] [error] [client 66.249.73.215] PHP Warning:  Zend Optimizer for PHP 5.2.x cannot be found (expected at '/usr/local/Zend/lib/Optimizer_TS/php-5.2.x/ZendOptimizer.so') - try reinstalling the Zend Optimizer in Unknown on line 0

hosting from bluehost
zencart version 1.3.8

11 Oct 2008, 2:03 AM
#27
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: Access Denied

crato, your problem is due to this:

PHP Warning: Zend Optimizer for PHP 5.2.x cannot be found

As this is a problem only your Hoster can correct, best to forward the errors you posted to your Hoster so they can fix it.

11 Oct 2008, 4:07 PM
#28
crato avatar

crato

New Zenner

Join Date:
Oct 2008
Posts:
7
Plugin Contributions:
0

Re: Access Denied

Website Rob:

crato, your problem is due to this:

PHP Warning: Zend Optimizer for PHP 5.2.x cannot be found

As this is a problem only your Hoster can correct, best to forward the errors you posted to your Hoster so they can fix it.

thanks a lot.

12 Oct 2008, 2:10 AM
#29
crato avatar

crato

New Zenner

Join Date:
Oct 2008
Posts:
7
Plugin Contributions:
0

Re: Access Denied

i've solved the problem by re-installing zencart.