Forums / Built-in Shipping and Payment Modules / USPS API changes announced for May 12, 2008

USPS API changes announced for May 12, 2008

Locked

Views: 43,034

Results 41 to 60 of 72
This thread is locked. New replies are disabled.
19 May 2008, 6:10 AM
#41
tj1 avatar

tj1

Totally Zenned

Join Date:
Mar 2005
Location:
California
Posts:
628
Plugin Contributions:
0

USPS API changes announced for May 12, 2008

Quick question about the new first-class international options, I see now there's
First class international packages
and
First class international parcels

It seems to me both are the same and would be redundant to have both. Is this correct?

19 May 2008, 5:49 PM
#42
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: USPS API changes announced for May 12, 2008

USPS quotes on both ... Might want to ask them about the difference.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

22 May 2008, 4:52 AM
#44
tj1 avatar

tj1

Totally Zenned

Join Date:
Mar 2005
Location:
California
Posts:
628
Plugin Contributions:
0

Re: USPS API changes announced for May 12, 2008

Just use 'Package', I'm pretty sure they're the same.
'Parcel' doesn't even return a value.

As far as I know as I know there's only 1st-class letter, 1st-class large envelope(flat), and 1st-class package.

The 'parcel' must be a duplicate.

23 May 2008, 3:17 PM
#45
helpme avatar

helpme

Totally Zenned

Join Date:
Apr 2007
Posts:
632
Plugin Contributions:
0

Re: USPS API changes announced for May 12, 2008

My parcel post is WAY off....for one pound it is calculating 8.25 everything else seems to be working fine.

www.mommyandbabyessentials.com

1.3.8a

this module installed

23 May 2008, 6:28 PM
#46
jivananda avatar

jivananda

New Zenner

Join Date:
Oct 2006
Posts:
10
Plugin Contributions:
0

Re: USPS API changes announced for May 12, 2008

Jivananda:

Aloha,

Thanks so much for the update.

For some reason, the domestic USPS priority mail flat rate box is not showing.

When I do a test of an 8 pound domestic USA shipment from zip 48103 to 94519, on the usps.com site, I get two flat rate options, "Priority Mail® Large Flat-Rate Box" and "Priority Mail® Flat Rate Box". Unfortunately in the shipping estimator, both these options do not show. Everything else seems to work fine.

I'm using Zen Cart 1.3.6.

Yogi Jivanandanatha

I'm still not getting USPS priority mail flat rate box. Anyone else having this problem?

24 May 2008, 7:16 PM
#47
charmedbytina2 avatar

charmedbytina2

Totally Zenned

Join Date:
Mar 2007
Location:
AZ
Posts:
1,890
Plugin Contributions:
0

Re: USPS API changes announced for May 12, 2008

I tried to install this update, but got several errors~
The new usps.php is to be uploaded to /includes/modules/shipping correct????

I did this and whammo - about 3 errors surfaced when I went back to admin to configure.

I deleted the new file, put the original usps.php back in, returned to Admin and was able to reconfigure no problems.

Any suggestions????

25 May 2008, 10:42 AM
#48
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: USPS API changes announced for May 12, 2008

I'm having a hard time guessing what those "errors" were ...

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

30 May 2008, 4:15 AM
#49
judyinspokane avatar

judyinspokane

New Zenner

Join Date:
Dec 2007
Location:
Spokane WA
Posts:
13
Plugin Contributions:
0

Re: USPS API changes announced for May 12, 2008

In the update thread: http://www.zen-cart.com/forum/showthread.php?t=97461
There are two zip files. One is a v13 which you put in first and has one page - usps.php. The other is v12 which you put in last and has two files...usps.php & _usps.php.

So I guess it's just me since no one else asked, but I am totally confused about which files to use to update the usps module???

Thanks

Thanks!
judyinspokane

30 May 2008, 12:41 PM
#50
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: USPS API changes announced for May 12, 2008

Ignore/delete the file starting with the underscore.

You want usps.php
You can delete any files starting with _ in the zip file.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

10 Jun 2008, 2:18 PM
#51
dmorris avatar

dmorris

New Zenner

Join Date:
Mar 2005
Posts:
42
Plugin Contributions:
0

Re: USPS API changes announced for May 12, 2008

I am running zencart 1.38a and having a usps shipping problem. I have uninstalled the shipping module and reinstalled with the new May 12th v13.

  • @version $Id: usps.php 8516 2008-05-13 01:56:07Z drbyte $

error that I am receiving

United States Postal Service
We are unable to find a USPS shipping quote suitable for your mailing address and the shipping methods we typically use.
If you prefer to use USPS as your shipping method, please contact us for assistance.
(Please check that your Zip Code is entered correctly.)

Any help would be appreciated.

Thanks

10 Jun 2008, 2:26 PM
#52
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: USPS API changes announced for May 12, 2008

dmorris:

**United States Postal Service **
We are unable to find a USPS shipping quote suitable for your mailing address and the shipping methods we typically use.
If you prefer to use USPS as your shipping method, please contact us for assistance.
(Please check that your Zip Code is entered correctly.)

That means exactly what it says ...

Using the Zip code configured in your store settings and the zip code of the customer's address, combined with the shipping options you've selected in your USPS module settings, and the package count and weight, it could not find any available options.

So, either you've got a bad zip code set in your admin under Configuration->Shipping/Packaging or you've unchecked too many options in your USPS module settings. Or maybe the address you're shipping to is bad.

You could turn on the debug emails in the module and see what the USPS response is from every attempted shipping quote.

Also, there are articles in the FAQ area which talk about related issues:

FAQ on proper configuration of USPS module: https://www.zen-cart.com/tutorials/index.php?article=327

FAQ on dealing with unexpected USPS results: https://www.zen-cart.com/tutorials/index.php?article=86

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

10 Jun 2008, 9:38 PM
#53
judyinspokane avatar

judyinspokane

New Zenner

Join Date:
Dec 2007
Location:
Spokane WA
Posts:
13
Plugin Contributions:
0

Re: USPS API changes announced for May 12, 2008

I had that same problem too (error message from USPS). Mine was resolved when reducing the number of heavy weight items in my cart. It worked fine after that. I now have "Call For Price" on the heavy weight item listings. Maybe this is your problem also?

Thanks!
judyinspokane

17 Jun 2008, 4:26 PM
#54
zilog357 avatar

zilog357

New Zenner

Join Date:
Jun 2008
Posts:
20
Plugin Contributions:
0

Re: USPS API changes announced for May 12, 2008

In my case, I switched to the Production Server after a call to the USPS. When doing the tests, International ratings work OK, but for some reason, US Domestic rates don't.

I found later, looking at the USPS programming Guides, that the API call for the ShippingAPI.dll for Domestic (US) rates is now "RateV3" and no longer "Rate". So the request must be changed to "RateV3Request USERID..." instead of the "RateRequest USERID..." used in the May 12, 2008 version. For International rates, "IntlRateRequest" is still used.

After doing the changes, Domestic rates are still not working. Seems like somehow, the module is stuck with "IntlRate" and not doing the switching when a Domestic rate is requested as the debugging function keeps returning an error with the IntlRate request as if the module didn't "realize" that a Domestic request was issued instead of an International one.

The error is listed bellow, and is typical, as when requesting a Domestic rate, and it is processed by the IntlRate request instead, the Country name is not transmitted.

And yes, I have the correct settings for the zip code and Country of origin in [Configuration] [Shipping/Packaging], which are Puerto Rico and 00985. All other parameters, like weight, service, etc are also set.

I'm really having a hard time at this :frusty:

error returned when requesting a DOMESTIC (US) rate (NOT International):

<?xml version="1.0"?>

<IntlRateResponse><Package ID="0"><Error><Number>-2147219080</Number><Source>;IntlRate.UnpackIntlRateNode</Source><Description>Missing value for Country.</Description><HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error></Package></IntlRateResponse>

Regards,

Richard

17 Jun 2008, 6:02 PM
#55
zilog357 avatar

zilog357

New Zenner

Join Date:
Jun 2008
Posts:
20
Plugin Contributions:
0

Re: USPS API changes announced for May 12, 2008

Ok. I changed "Rate&XML" for "RateV3&XML" and "RateRequest..." for "RateV3Request..." in the whole USPS.php module. Still no luck.

Then, I changed "Country of Origin" from "Puerto Rico" to "US". International requests still work and even when Domestic requests still show nothing on the pop up window, it did a positive change: now error messages from Domestic requests are returned by "RateV3 Respond" and NOT by "IntlRate Respond". I guess that the module "doesn't know" that Puerto Rico is an US Territory.

The first error was about the package container. Since it is an optional parameter, I took it out from the request string by putting a "//"

Ex:

    '<Ounces>' . $this->ounces . '</Ounces>' .
// '<Container>' . $this->container . '</Container>' .
    '<Size>' . $this->size . '</Size>' .

Now, it still doesn't show Domestic quotes on the pop up window, but the debug function sends two emails; one with all the package parameters and the correct quote for the request done and a second one with the info listed bellow. So now it calculates the rate ok, but doesn't display because of the error described on the second email.

Now I'm more clueless than before... :(

error:

<?xml version="1.0"?>

<Error><Number>-2147219085</Number><Source>Rate_Respond.;SOLServerRates.RateV3_Respond</Source><Description>Invalid XML Element cannot be empty according to the DTD/Schema.
line= 0 pos= 1147</Description><HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error>

17 Jun 2008, 9:16 PM
#56
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: USPS API changes announced for May 12, 2008

The module is not written for the v3 API. Just changing the request type is not sufficient.

Your problem is not in the API call. Your problem is likely due to USPS treating Puerto Rico differently than you expected ... namely country vs state/territory. You'll likely need to change your Zen Cart setup so that Puerto Rico is seen the same way USPS wants it, not necessarily how the International Standards (ISO) see it.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

17 Jun 2008, 10:59 PM
#57
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: USPS API changes announced for May 12, 2008

If you are using USPS you want to remove the US territories and Islands that are also defined as countries ... as they are listed as states of the US, to work with USPS and the rules they follow such as, if we own it, then the Country is obviously United States ... country 223 ... :smile:

If you are using UPS you want to remove the US Territories and Islands that are also defined as states ... as they are listed as individual countries as UPS doesn't look at who owns what but wants to make sure the package gets there on time ... :cool:

If you use both USPS and UPS ... you are doomed ... :cry:

... or, you can just accept that some people will not be able to use one shipping module or the other depending on "how" they create their account and whether they defined themselves as a Country or a State ... :smartalec:

Linda McGrath
If you have to think ... you haven't been zenned ...

**Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!**

Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today!]
Officially PayPal-Certified! Just click here

Try our Zen Cart Recommended Services - Hosting, Payment and more ...
Signup for our Announcements Forums to stay up to date on important changes and updates!

17 Jun 2008, 11:00 PM
#58
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: USPS API changes announced for May 12, 2008

NOTE: one of the first things I am doing when I have nothing better to do is write a dang translator to magically figure out who is who in the zoo ... I hate those dang quirks ... :censored:

Linda McGrath
If you have to think ... you haven't been zenned ...

**Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!**

Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today!]
Officially PayPal-Certified! Just click here

Try our Zen Cart Recommended Services - Hosting, Payment and more ...
Signup for our Announcements Forums to stay up to date on important changes and updates!

17 Jun 2008, 11:34 PM
#59
zilog357 avatar

zilog357

New Zenner

Join Date:
Jun 2008
Posts:
20
Plugin Contributions:
0

Re: USPS API changes announced for May 12, 2008

Ok, I see...no wonder...

Thanks for your prompt and enlightening reply guys. Will see what can I do to solve it in a way that I am more or less satisfied with.

14 Jul 2008, 8:39 PM
#60
cjmarley avatar

cjmarley

Zen Follower

Join Date:
May 2004
Posts:
96
Plugin Contributions:
2

Re: USPS API changes announced for May 12, 2008

Just so y'all know...I just checked out the USPS website and they are no longer listing First Class Intl Package as an option for international shipping which would explain why our cart is not showing that as an option for shipping overseas anymore.