Zen Cart Logo
Forums / Upgrading to 1.5.x / problem with upgrade from v151 to v153 - help please

problem with upgrade from v151 to v153 - help please

Views: 10,404

Results 1 to 20 of 125
17 Jul 2014, 8:12 PM
#1
bryanb3 avatar

bryanb3

New Zenner

Join Date:
Nov 2008
Posts:
11
Plugin Contributions:
0

problem with upgrade from v151 to v153 - help please

upgrade problem v151 to v153.

Am upgrading from v151 to v 153 and getting this error:

Your database appears to need patching to a higher level. See Tools->Server Information to review patch levels.

Any Ideas?

17 Jul 2014, 8:29 PM
#2
picaflor_azul avatar

picaflor_azul

Totally Zenned

Join Date:
Jul 2009
Location:
picaflor-azul.com
Posts:
6,940
Plugin Contributions:
28

Re: problem with upgrade from v151 to v153 - help please

bryanb3:

upgrade problem v151 to v153.

Am upgrading from v151 to v 153 and getting this error:

Your database appears to need patching to a higher level. See Tools->Server Information to review patch levels.

Any Ideas?

You need to upgrade your database also ;)

Thanks,

Anne

17 Jul 2014, 8:39 PM
#3
bryanb3 avatar

bryanb3

New Zenner

Join Date:
Nov 2008
Posts:
11
Plugin Contributions:
0

Re: problem with upgrade from v151 to v153 - help please

Thank you.

How do you do that?

The instructions don't mention an upgrade to the database. Am I missing something?

UPGRADE NOTES
To upgrade from v1.5.1 to v1.5.3
Simple: if you are using v1.5.1 already and have not customized any of the files listed in the changed_files-v1-5-2.html and changed_files-v1-5-3.html documents, then simply replace those files with the new versions contained herein.
If you HAVE customized or altered certain files, simply re-do your customizations in the new version of those particular files by making the same changes needed.
If you are using Addons/Plugins that have made alterations to those files, it is best to compare those changed files against the original v1.5.1 files, and see what changes were there ... and then re-build those changes in the v1.5.3 file.

17 Jul 2014, 9:01 PM
#4
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: problem with upgrade from v151 to v153 - help please

bryanb3:

Thank you.

How do you do that?

The instructions don't mention an upgrade to the database. Am I missing something?

UPGRADE NOTES
To upgrade from v1.5.1 to v1.5.3
Simple: if you are using v1.5.1 already and have not customized any of the files listed in the changed_files-v1-5-2.html and changed_files-v1-5-3.html documents, then simply replace those files with the new versions contained herein.
If you HAVE customized or altered certain files, simply re-do your customizations in the new version of those particular files by making the same changes needed.
If you are using Addons/Plugins that have made alterations to those files, it is best to compare those changed files against the original v1.5.1 files, and see what changes were there ... and then re-build those changes in the v1.5.3 file.

So regarding the files, that all is true, but the files only make half of ZC. The other half is the database. That is upgraded like other upgrade instructions state by using zc_install on the store and choosing to upgrade the database only.

17 Jul 2014, 9:28 PM
#5
bryanb3 avatar

bryanb3

New Zenner

Join Date:
Nov 2008
Posts:
11
Plugin Contributions:
0

Re: problem with upgrade from v151 to v153 - help please

Thank you will give that a try. :)

18 Jul 2014, 12:36 PM
#6
mikestewart avatar

mikestewart

New Zenner

Join Date:
Mar 2014
Location:
United States
Posts:
5
Plugin Contributions:
0

Re: problem with upgrade from v151 to v153 - help please

I was not able to upgrade the DB thought the ZC utility from 151 to 153. Kept giving me an error on the admin username and password. No I did not use the DB username and password. Used the zencart username and password. Was unable to update the db.

19 Jul 2014, 12:21 PM
#7
chain_man avatar

chain_man

Zen Follower

Join Date:
Dec 2005
Location:
Box Elder, SD
Posts:
375
Plugin Contributions:
0

Re: problem with upgrade from v151 to v153 - help please

mikestewart:

I was not able to upgrade the DB thought the ZC utility from 151 to 153. Kept giving me an error on the admin username and password. No I did not use the DB username and password. Used the zencart username and password. Was unable to update the db.

I had the same problem. I ended up manually applying the 2 upgrade sql statements through SQL Patches. No problems when done.

19 Jul 2014, 3:36 PM
#8
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: problem with upgrade from v151 to v153 - help please

Argh. There seems to be a bug in that password validation code specifically in v1.5.3 only.

We're working on a fix.

20 Jul 2014, 3:04 PM
#10
laurelsstitchery avatar

laurelsstitchery

Zen Follower

Join Date:
Jun 2010
Posts:
145
Plugin Contributions:
0

Re: problem with upgrade from v151 to v153 - help please

DrByte:

Fix posted at: http://www.zen-cart.com/showthread.php?213868-Known-Bugs-%28and-fixes%29-with-v1-5-3&p=1253144#post1253144

After uploading the fix, the password works, but it then goes to a white page and the following shows up in my /logs folder:

[20-Jul-2014 09:32:04 America/New_York] PHP Fatal error:  require_once(): Failed opening required '/home/user/html/catalog/../includes/classes/vendors/password_compat-master/lib/password.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/user/html/catalog/includes/classes/class.zcPassword.php on line 52

Someone else had posted about this same error on another thread as well. Let me know what needs to be done to fix this up. Thanks! :)

20 Jul 2014, 3:15 PM
#11
laurelsstitchery avatar

laurelsstitchery

Zen Follower

Join Date:
Jun 2010
Posts:
145
Plugin Contributions:
0

Re: problem with upgrade from v151 to v153 - help please

laurelsstitchery:

After uploading the fix, the password works, but it then goes to a white page and the following shows up in my /logs folder:

[20-Jul-2014 09:32:04 America/New_York] PHP Fatal error: require_once(): Failed opening required '/home/user/html/catalog/../includes/classes/vendors/password_compat-master/lib/password.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/user/html/catalog/includes/classes/class.zcPassword.php on line 52

> 
> Someone else had posted about this same error on another thread as well. Let me know what needs to be done to fix this up. Thanks! :)

Actually, I just tried again and it still went to the white screen, but no error log this time. Database upgrade was not applied.
14 Aug 2014, 1:49 PM
#12
reetp avatar

reetp

New Zenner

Join Date:
Nov 2008
Posts:
46
Plugin Contributions:
0

Re: problem with upgrade from v151 to v153 - help please

I seem to have the same password problem with an upgrade from 1.5.1 to 1.5.3

I have made sure the password is correct by resetting it with the old install of Zencart.

I am using the 1.5.3 with New Fix.

Testing is on my home server :

CentOS 5.x

[root@home logs]# httpd -v
Server version: Apache/2.2.3
Server built: Jul 23 2014 10:09:41

[root@home logs]# php -v
PHP 5.3.3 (cli) (built: Dec 16 2013 03:52:26)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
with Zend Debugger v5.3, Copyright (c) 1999-2010, by Zend Technologies

[root@home logs]# mysql -v
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 12137
Server version: 5.0.95 Source distribution

I attempted to copy over my templates to the new version and then run the update. This failed as below.

I then tried with a completely fresh version with no modifications and JUST the correct configure files. This failed as well.

At one point when messing about early on I DID manage to complete the upgrade once, with warnings. I logged in to the admin panel and it showed the system updated to 1.5.3 but the database still not updated at 1.5.1

Logs from one attempt - I can provide more :

[root@home logs]# cat zcInstallLog_Aug-14-2014_03-05-59-WF1Vjs.log

Aug 14 2014 15:05 -- inspect
System Inspection Results:

NA: Webserver => Apache
NA: HTTP Host => home.server.net
NA: Path_Translated => /home/e-smith/files/ibays/testbay/html/zencart/zc_install/index.php(SCRIPT_FILENAME)
NA: Real Path => /home/e-smith/files/ibays/testbay/html/zencart
NA: Server Free Disk Space => 40.83 GB
NA: PHP O/S => Linux
NA: PHP API Mode => apache2handler
NA: PHP Max Execution Time per page => 600
OK: Register Globals => OFF
OK: MySQL Support => ON
OK: PHP Version => 5.3.3
OK: PHP Safe Mode => OFF
OK: PHP Sessions Support => ON
OK: PHP Session.AutoStart => OFF
OK: PHP session.use_trans_sid => OFF
OK: Current SQL Cache Folder => /home/e-smith/files/ibays/testbay/html/zencart/cache-->Writeable
OK: Suggested SQL Cache Folder => /home/e-smith/files/ibays/testbay/html/zencart/cache
OK: PHP magic_quotes_runtime setting => OFF
OK: PHP magic_quotes_sybase setting => OFF
OK: PHP GD Support => ON
OK: GD Version => GD bundled (2.0.34 compatible)
OK: PHP ZLIB Compression Support => ON
OK: PHP OpenSSL Support => ON
OK: PHP cURL Support => ON
OK: CURL NON-SSL Capability => Okay
OK: CURL SSL Capability => Okay
OK: PHP Upload Support => ON upload_max_filesize=15M; post_max_size=20M
OK: PHP Upload TMP dir => /home/e-smith/files/ibays/testbay/tmp
WARN: Apache .htaccess Support => OFF
NA: PHP include_path => .:/usr/share/pear-addons:/usr/share/pear
NA: PHP SMTP destination => localhost
NA: PHP sendmail path => /usr/sbin/sendmail -t -i
NA: PHP sendmail 'from' => [email protected]
WARN: PHP open_basedir restrictions => /home/e-smith/files/ibays/testbay/html/:/usr/share/pear/:/usr/share/pear-addons/:/tmp/
OK: PHP Output Buffering (gzip) => ON
OK: PHP XML Support => ON
OK: PHP Session.Save_Path => /home/e-smith/files/ibays/testbay/html/zencart/cache-->Writeable
OK: includes/configure.php => Writeable
OK: admin/includes/configure.php => Writeable
OK: cache => OK 777 read/write/execute
OK: images => OK 777 read/write/execute (INCLUDE SUBDIRECTORIES TOO)
OK: includes/languages/english/html_includes => OK 777 read/write (INCLUDE SUBDIRECTORIES TOO)
OK: logs => OK 777 read/write/execute
OK: media => OK 777 read/write/execute
OK: pub => OK 777 read/write/execute
OK: admin/backups => OK 777 read/write
OK: admin/images/graphs => OK 777 read/write/execute
PHP Extensions compiled: Core, date, ereg, libxml, openssl, pcre, zlib, bz2, calendar, ctype, hash, filter, ftp, gettext, gmp, session, iconv, Reflection, standard, shmop, SPL, SimpleXML, sockets, exif, tokenizer, xml, apache2handler, curl, dom, fileinfo, gd, imap, json, ldap, mbstring, mcrypt, mysql, mysqli, PDO, pdo_mysql, pdo_sqlite, Phar, wddx, xmlreader, xmlwriter, xsl, zip, Zend Debugger


Aug 14 2014 15:06 -- database_upgrade
FATAL: Admin Password required to proceed with upgrade

[root@home logs]# cat zcInstallExceptionDetails_Aug-14-2014_03-05-59-WF1Vjs.log

Aug 14 2014 15:06 -- database_upgrade
FATAL: Admin Password required to proceed with upgrade

[root@home logs]# cat zcInstallDEBUG-1408021571-965907.log
[14-Aug-2014 15:06:12] PHP Warning: curl_setopt_array() [<a href='function.curl-setopt-array'>function.curl-setopt-array</a>]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /home/e-smith/files/ibays/testbay/html/zencart/zc_install/includes/modules/pages/inspect/header_php.php on line 560

[root@home logs]# cat zcInstallDEBUG-1408021571-965907.log
[14-Aug-2014 15:06:12] PHP Warning: curl_setopt_array() [<a href='function.curl-setopt-array'>function.curl-setopt-array</a>]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /home/e-smith/files/ibays/testbay/html/zencart/zc_install/includes/modules/pages/inspect/header_php.php on line 560

Now completely stuck with a couple of sites to update.

Any help appreciated.

B. Rgds
John

28 Oct 2014, 6:36 PM
#13
dk_scully avatar

dk_scully

Zen Follower

Join Date:
Jan 2011
Posts:
339
Plugin Contributions:
0

Re: problem with upgrade from v151 to v153 - help please

I'm having a similar problem, and now there's a big red error message across the top of the client's site.

I uploaded the new files to their proper location. When I tried to access the admin page, I got this error message:

Warning: You cannot access the admin until you have deleted the zc_install folder.
(Use your FTP program or your hosting control panel.)

When I tried to access the /zc_install/ folder to do the upgrade, as per everyone's instructions, I got a 404 page.

When I deleted the /zc_install/ folder, I was able to access the admin page again...but I got the "Your database appears to need patching to a higher level. See Admin->Tools->Server Information to review patch levels." error message.

I looked at the Admin / Tools / Server page, and it has a whole bunch of information on it...including that my database is at 1.5.0. But I haven't any idea how I'm supposed to "patch it to a higher level." I don't even see anything within the shopping cart that refers to the database.

Please help??

28 Oct 2014, 6:46 PM
#14
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: problem with upgrade from v151 to v153 - help please

DK_Scully:

When I tried to access the /zc_install/ folder to do the upgrade, as per everyone's instructions, I got a 404 page.404 means "not found", which suggests you've put an incorrect URL in your browser.
If the store is at https://www.example.com, and in FTP your store files are in the public_html directory, then you'd upload zc_install into public_html, and then point your browser to https://www.example.com/zc_install
But if in FTP your store is under public_html/store/ then you'd upload zc_install to public_html/store/zc_install and then point your browser to https://www.example.com/store/zc_install or if the domain vhost was altered to point example.com to the /store/ directly then you'd point your browser to https://www.example.com/zc_install
So, the correct action depends entirely on how you've configured the server and where you've put the files during the initial install.

28 Oct 2014, 7:36 PM
#15
dk_scully avatar

dk_scully

Zen Follower

Join Date:
Jan 2011
Posts:
339
Plugin Contributions:
0

Re: problem with upgrade from v151 to v153 - help please

LOL Oh, I'm not that much of a newbie...although I'm sure it seems like it sometimes. ;-)

No, I had the url correct. The problem is that it was immediately saying I had to delete the entire folder before I could access the admin section. But how can I upgrade the database if I can't access the /zc_install/ folder?

28 Oct 2014, 7:44 PM
#16
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: problem with upgrade from v151 to v153 - help please

The database-upgrade is done ONLY via zc_install. Once the db-upgrade is done, then you do delete the zc_install folder.
Not necessary to login to the admin side to do it.

28 Oct 2014, 8:07 PM
#17
dk_scully avatar

dk_scully

Zen Follower

Join Date:
Jan 2011
Posts:
339
Plugin Contributions:
0

Re: problem with upgrade from v151 to v153 - help please

DrByte:

Fix posted at: http://www.zen-cart.com/showthread.php?213868-Known-Bugs-%28and-fixes%29-with-v1-5-3&p=1253144#post1253144

I followed the link, installed the general.php file in the proper directory...and it still won't accept my username and password. My ZenCart upgrades are always a nightmare, but this is the worst yet. What gives??

(BTW, I had to uninstall and reinstall the zc_install folder five separate times before I was finally able to access it...using the same url each time.)

29 Oct 2014, 12:36 PM
#18
frank18 avatar

frank18

Deceased

Join Date:
Nov 2007
Location:
Sunny Coast, Australia
Posts:
3,427
Plugin Contributions:
2

Re: problem with upgrade from v151 to v153 - help please

DK_Scully:

... ZenCart upgrades are always a nightmare, but this is the worst yet. What gives??.....

Sorry for butting in here, but I tend to disagree with your statement.

I first started with ZC 1.3.7.1 back in 2007 with one store. That store is still alive and well, had umpteen modifications / upgrades and to date runs smoothly as version 1.5.3.

I never had a single hiccup with any of the upgrades I did to that store (or any other ZC installation), only because I took my time, read and followed the instructions carefully and did not take one single shortcut.

Meanwhile (7 years later) I am running several of my own ZC installations and administer ZC stores for clients and friends. Again: not one single malfunction.

Many of these stores have been moved or cloned between servers, local and live, and all are functioning as desired.

My tip: stick to the instructions, FAQ's and wiki and you won't go wrong.

And: take your time when attempting an upgrade.

Just my 2 cents....

29 Oct 2014, 1:18 PM
#19
dk_scully avatar

dk_scully

Zen Follower

Join Date:
Jan 2011
Posts:
339
Plugin Contributions:
0

Re: problem with upgrade from v151 to v153 - help please

I'm running zencart on 8 different sites. Every upgrade I've done has been a massive headache. :-/ I do take my time, and follow everything very carefully, researching the forum or asking questions at every point I don't understand to make sure it goes smoothly. But still it never does. And I seem to have a special "gift" for finding bugs that no one else has. This current problem is a case example. I ran into the same "invalid password" error that so many other people did, and I followed the patch instructions most carefully. But it still isn't working. The zc_install script still does not accept my username/password. Why? I have no idea. :-< Apparently neither does anyone else.

29 Oct 2014, 2:11 PM
#20
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: problem with upgrade from v151 to v153 - help please

There has been some discussion that the issue occurs at/around specific php version differences. I believe I have been able to overcome it by applying the I forgot my password "patch" after the database has been loaded into the siteand before running the zc_install to perform the upgrade... My understanding is that at those different php points password encryption changes, but yet the I forgot my password fix seems to work...