Zen Cart Logo

USPS new rates May

Locked

Views: 49,987

Results 41 to 60 of 168
This thread is locked. New replies are disabled.
14 May 2007, 6:03 AM
#41
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

USPS new rates May

Updated module has been released, and can be found here:

http://www.zen-cart.com/forum/showthread.php?p=374017#post374017

Module is compatible with Zen Cart v1.2.4 and newer.
(if applying to v1.2.x, you'll need to make a small edit in the file:)
/includes/modules/shipping/usps.php
line 13:

class usps extends base {

becomes

class usps {

If using v1.3.0 or newer, you do NOT need to edit the patched files.

14 May 2007, 9:09 AM
#42
tomarriola avatar

tomarriola

Zen Follower

Join Date:
Oct 2004
Posts:
206
Plugin Contributions:
0

Re: USPS new rates May

The field for password didn't appear. I got an error message about a missing id/password. The password config info was in the mysql table so I entered it manually and the error went away.

Am I the only one to see this error?
Tom

14 May 2007, 12:04 PM
#43
helpme avatar

helpme

Totally Zenned

Join Date:
Apr 2007
Posts:
632
Plugin Contributions:
0

Re: USPS new rates May

I have installed the USPS module and thought it was working, but I have someone who would like to purchase from Australia. When you get to the shopping cart, there is no options for overseas shipping? I have the module set to none for the zone and I have all of the international options checked. Any ideas why this isn't working?
https://www.mommyandbabyessentials.com

14 May 2007, 12:13 PM
#45
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: USPS new rates May

The module file was updated about 20 minutes after it was posted to remove the password warning.
If you repeat the download, unzip, upload, remove, install, reconfig process, you'll avert the warning.

There is no functional difference other than averting the warning.

14 May 2007, 12:22 PM
#46
helpme avatar

helpme

Totally Zenned

Join Date:
Apr 2007
Posts:
632
Plugin Contributions:
0

Re: USPS new rates May

I added this patch and it still isn't working? It works for domestic but not international?

14 May 2007, 12:40 PM
#47
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: USPS new rates May

What are the details of the order:

  1. Your store's ZIP code and all the rest of the settings from Admin->Configuration->Shipping/Packaging
  2. The customer's complete address.
  3. The number of items in the cart, including their price and weight.

Also, try these:
a. Go to USPS website and test for a quotation using the same details. What results do they give you?
b. Turn on debugging in your USPS module. It'll email you the raw quote details that USPS sent back for your store to process.

14 May 2007, 12:51 PM
#48
helpme avatar

helpme

Totally Zenned

Join Date:
Apr 2007
Posts:
632
Plugin Contributions:
0

Re: USPS new rates May

  1. store zip code is set as well as the other settings
  2. I don't know their complete address, I know it is Australia and the zip is 2333
  3. any item, I am trying a v2 supporter for $38.99 .8 lbs

I used USPS website and it gives me 4 options, all of which I have enabled.
I have tried to estimate shipping to UK and Canada and they nothing comes up for any of them.

14 May 2007, 1:13 PM
#49
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: USPS new rates May

Did you get the new USPS module for the new rates?
http://www.zen-cart.com/forum/showthread.php?t=65732

Follow the instructions and it will give you the new overseas rates ...

14 May 2007, 1:17 PM
#51
helpme avatar

helpme

Totally Zenned

Join Date:
Apr 2007
Posts:
632
Plugin Contributions:
0

Re: USPS new rates May

I installed the patch for the new rates and still nothing for international. It is really puzzling. US rates work fine, just the international isn't working.

14 May 2007, 1:23 PM
#52
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: USPS new rates May

Make sure that you are set to the Production server ...

Also be sure that you see in the:
/includes/modules/shipping

Today's date on the usps.php file and that you did a Remove and Install and configuration on your site ...

The module works with your old USPS Web Tools User ID ... if this is a new account make sure that you have called USPS and activated the account ...

14 May 2007, 1:25 PM
#53
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: USPS new rates May

If you are not in v1.3.x be sure that you have edited the file with the changes on the instructions ...

14 May 2007, 1:47 PM
#54
helpme avatar

helpme

Totally Zenned

Join Date:
Apr 2007
Posts:
632
Plugin Contributions:
0

Re: USPS new rates May

I am using zen cart 1.3.7 so I did not modify any files. and everything else looks right, the date, all the new files and I am on a production server...however it is a new account, but I have called USPS and activated and all that.
I have looked and can't find how to run the debug for USPS, can you point me in a direction? Maybe that will do something.
Thanks

14 May 2007, 2:51 PM
#55
deadeye avatar

deadeye

Zen Follower

Join Date:
Jul 2005
Posts:
109
Plugin Contributions:
0

Re: USPS new rates May

I have a problem where (International) Priority Mail is an option, but the (International) Express Mail is not presented as an option. Express Mail Domestic works though.

Update: If I select (International) Express Mail Envelope Flat Rate...that shows up as well. Global Express Guaranteed options show up also.

14 May 2007, 4:11 PM
#56
cyfarian avatar

cyfarian

New Zenner

Join Date:
Mar 2006
Posts:
29
Plugin Contributions:
0

Re: USPS new rates May

Hello,
I am running 1.2.7 and downloaded the files, editted line 13 on usps.php and uploaded. When I clicked on modules/shipping, I got the following derror message:

Fatal error: Cannot redeclare class usps in /home2/hfb/public_html/store/includes/modules/shipping/usps.php on line 13

and the usps module does not appear.

I undid the change to line 13, but that resulted in another error about being unable to declare the base function.

Any ideas?

EDIT::::I put the old files back up and the error is still there, but it is on line 23 with the old files. I didn't check it beforehand, so the error may have been there prior to installing the update. Would it be because of the new rates release? All orders were fine yesterday, so I can only guess that this error wasn't there yesterday. Any help would be appreciated.

Thanks!!

14 May 2007, 4:21 PM
#57
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: USPS new rates May

You edited the module and changed:

class usps extends base {

To read:

class usps {

NOTE: USPS is also have intermittent server issues ... this is not related to your error

14 May 2007, 4:23 PM
#58
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: USPS new rates May

deadeye:

I have a problem where (International) Priority Mail is an option, but the (International) Express Mail is not presented as an option. Express Mail Domestic works though.

Update: If I select (International) Express Mail Envelope Flat Rate...that shows up as well. Global Express Guaranteed options show up also.

There are rules concerning weight on USPS ... there is also a rule on amount for one of the shipping methods on orders over $400.00

These will disable shipping methods if the weight does not work for that method or the order total is over $400.00

SEE: usps.com for more information on their new rules

14 May 2007, 4:25 PM
#59
stagebrace avatar

stagebrace

Totally Zenned

Join Date:
Jan 2005
Location:
Tennessee
Posts:
985
Plugin Contributions:
0

Re: USPS new rates May

NOTE: USPS is also have intermittent server issues ... this is not related to your error

You said it, BIG TIME

14 May 2007, 4:31 PM
#60
cyfarian avatar

cyfarian

New Zenner

Join Date:
Mar 2006
Posts:
29
Plugin Contributions:
0

Re: USPS new rates May

Ajeh:

You edited the module and changed:

class usps extends base {

> 
> To read:
> ```php
class usps {

NOTE: USPS is also have intermittent server issues ... this is not related to your error

Was this post to me? If so, thank you for reponding to my post. Yes, I did edit the file per the instructions in the post. It did not correct the issue. Did I do it incorrectly? I removed the edit and as I said in my post, it just resulted in a different error.