Zen Cart Logo
Forums / All Other Contributions/Addons / Auction Lister Pro (ALP) Support

Auction Lister Pro (ALP) Support

Views: 95,811

Results 141 to 160 of 374
11 Oct 2007, 7:20 PM
#141
maxrisc avatar

maxrisc

Zen Follower

Join Date:
Mar 2007
Location:
Houston
Posts:
246
Plugin Contributions:
1

Auction Lister Pro (ALP) Support

Babyface,

You will need to make sure that your cache directory is writable or change the cache location in /alp/includes/configure.php.

The "Call-time pass-by-reference has been deprecated" is an old message. It will be displayed by default as a notice that it is to be removed in the future. This is caused by the API toolkit and they have mentioned that they will work on this to remove these problems in the future. You can remove this message by suppressing errors and notices in /alp/inlcudes/application_top.php or in php.ini.

Also I notice that you are using a Windows based host. There is a function in the lister that may not work correctly with your environment unless you have some sort of mktime() function or Unix tools like Cygwin installed.

The rest of the problems you are having are because your token file is not setup correctly for some reason. The error message you emailed me hints at the path as your problem. "/var/www/vhosts/example.com/httpdocs/alp/config/my.token". This will need to be changed to d:\windows_directory\alp\includes etc etc etc

HTH

  • David
11 Oct 2007, 7:28 PM
#142
maxrisc avatar

maxrisc

Zen Follower

Join Date:
Mar 2007
Location:
Houston
Posts:
246
Plugin Contributions:
1

Re: Auction Lister Pro (ALP) Support

Hi folks,

This is a general post asking that you do not email me directly for support. There are forums here and there are also forums on my site. I may not post daily but I see every single message on both sites regarding ALP.

So if you are having troubles, PLEASE post them in the forum and not to my PM or email account.

I get way too much email already and it isn't fair for other users if I provide you email support directly so that they don't benefit. It's free software and so far free support. I just ask that you post in the forums so I can help everyone.

Thanks,
David

12 Oct 2007, 11:13 AM
#143
a_berezin avatar

a_berezin

Deceased

Join Date:
Aug 2004
Location:
Saint Petersburg, Russia
Posts:
1,782
Plugin Contributions:
5

Re: Auction Lister Pro (ALP) Support

maxrisc:

The "Call-time pass-by-reference has been deprecated" is an old message. It will be displayed by default as a notice that it is to be removed in the future. This is caused by the API toolkit and they have mentioned that they will work on this to remove these problems in the future. You can remove this message by suppressing errors and notices in /alp/inlcudes/application_top.php or in php.ini.
.htaccess or php.ini

php_flag allow_call_time_pass_reference On
13 Oct 2007, 4:23 AM
#144
maxrisc avatar

maxrisc

Zen Follower

Join Date:
Mar 2007
Location:
Houston
Posts:
246
Plugin Contributions:
1

Re: Auction Lister Pro (ALP) Support

Yes that works too if your hosting configuration supports it. :smile:

16 Oct 2007, 9:23 PM
#145
babyface avatar

babyface

New Zenner

Join Date:
Jan 2007
Posts:
26
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

maxrisc:

Babyface,

You will need to make sure that your cache directory is writable or change the cache location in /alp/includes/configure.php.

The "Call-time pass-by-reference has been deprecated" is an old message. It will be displayed by default as a notice that it is to be removed in the future. This is caused by the API toolkit and they have mentioned that they will work on this to remove these problems in the future. You can remove this message by suppressing errors and notices in /alp/inlcudes/application_top.php or in php.ini.

Also I notice that you are using a Windows based host. There is a function in the lister that may not work correctly with your environment unless you have some sort of mktime() function or Unix tools like Cygwin installed.

The rest of the problems you are having are because your token file is not setup correctly for some reason. The error message you emailed me hints at the path as your problem. "/var/www/vhosts/example.com/httpdocs/alp/config/my.token". This will need to be changed to d:\windows_directory\alp\includes etc etc etc

HTH

  • David

Ok we got the error messages suppressed, got our images to work.
However, we could not find any reference to the cache directory in the configure.php file.
Also which file do we modify the location of the token in?

17 Oct 2007, 4:09 AM
#146
maxrisc avatar

maxrisc

Zen Follower

Join Date:
Mar 2007
Location:
Houston
Posts:
246
Plugin Contributions:
1

Re: Auction Lister Pro (ALP) Support

For now it is located in /alp/includes/config/token/my.token

The configuration file is /alp/includes/config/ebay.config.php

17 Oct 2007, 4:40 AM
#147
babyface avatar

babyface

New Zenner

Join Date:
Jan 2007
Posts:
26
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

maxrisc:

For now it is located in /alp/includes/config/token/my.token

The configuration file is /alp/includes/config/ebay.config.php

Thanks David,
I think we've got the token issue resolved, now that leaves us with the session issue we're having which refers to the cache directory. Which file do we find the reference to the cache directory so we can modify that?

18 Oct 2007, 4:17 AM
#148
maxrisc avatar

maxrisc

Zen Follower

Join Date:
Mar 2007
Location:
Houston
Posts:
246
Plugin Contributions:
1

Re: Auction Lister Pro (ALP) Support

mkdir /alp/cache

In /alp/includes/configure.php

Add this line

define('DIR_FS_CACHE' . 'cache/');
```That should solve the problem.
20 Oct 2007, 7:25 PM
#149
troy77 avatar

troy77

New Zenner

Join Date:
Jan 2007
Posts:
45
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

Hi, can i use this on ebay.co.uk or is it just for the .com?
Thanx

21 Oct 2007, 5:25 AM
#150
maxrisc avatar

maxrisc

Zen Follower

Join Date:
Mar 2007
Location:
Houston
Posts:
246
Plugin Contributions:
1

Re: Auction Lister Pro (ALP) Support

It works with UK as well. You will need different categories however to use it. I will supply those in the next couple days on my site so you can download them and use the installer to up them to your server.

21 Oct 2007, 9:52 PM
#151
fatguyinaz avatar

fatguyinaz

Zen Follower

Join Date:
Oct 2007
Location:
Safford, AZ
Posts:
313
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

Hi David,

I just started a new installation. In step 2 the instructions very cleary say that the SQL (AuctionListerPro.SQL) file must be located in the /alp/install/ folder. However, the file structure has it in a folder called /SQL_Data/ within the /install/ folder. I am not sure if this matters because I went ahead and copied the file and placed it in the /install/ folder where your instructions say it should be. I may have gotten an error at that step if I had continued without moving the file?

I didn't continue too much further since I am not able to get eBay developer key, token, etc. at this time. eBay is apparently doing some maintenance on that part of their site.

Just thought you should know about the SQL part.

Steve

22 Oct 2007, 2:04 AM
#152
maxrisc avatar

maxrisc

Zen Follower

Join Date:
Mar 2007
Location:
Houston
Posts:
246
Plugin Contributions:
1

Re: Auction Lister Pro (ALP) Support

Thanks for pointing that out. I will have a look at it to make sure. The correct location however should be SQL_Data.

There is one issue that I recently became aware of with Buy It Now items showing up as failed auctions in the completed listings area. I am working on correcting that now and hope to get a patch out soon along with the most recent eBay API for your use.

22 Oct 2007, 11:34 PM
#153
babyface avatar

babyface

New Zenner

Join Date:
Jan 2007
Posts:
26
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

David,

Thanks for all the help but we're still getting session errors.

Here is the error we're getting:

Warning: session_start() [*function.session-start*]: open(/cache\sess_pt0n9itlg18spvui4j4p1nh390, O_RDWR) failed: No such file or directory (2) in D:{wwwroot}\alp\includes\functions\sessions.php on line 68

Below is the configure.php

<?php
*define('HTTP_SERVER', 'http://{webaddress}/alp'); *
define('HTTP_CATALOG_SERVER', 'http://{webaddress}');
define('HTTPS_CATALOG_SERVER', 'https://{webaddress}');
define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module

define('DIR_WS_DOCUMENT_ROOT','' );

define('DIR_FS_DOCUMENT_ROOT','' );
define('DIR_FS_CACHE', 'cache/');
define('DIR_WS_HTTP_CATALOG','http://{webaddress}/');
define('DIR_WS_ADMIN', '/');
define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN);
define('DIR_WS_CATALOG', '/catalog/');
define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG);
define('DIR_WS_IMAGES', 'images/');
define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
define('DIR_WS_CATALOG_IMAGES', 'http://{webaddress}/' . 'images/');
define('DIR_WS_INCLUDES', DIR_WS_DOCUMENT_ROOT . 'includes/');
define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
// define our database connection
define('DB_SERVER', '{servername}');
define('DB_SERVER_USERNAME', '{username}');
define('DB_SERVER_PASSWORD', '{password}');
define('DB_DATABASE', '{databasename}');
define('USE_PCONNECT', 'false');
define('STORE_SESSIONS', '');
?>

I also confirmed that the /alp/cache directory fully writtable.

Any ideas?

Thanks

maxrisc:

mkdir /alp/cache
In /alp/includes/configure.php

Add this line

define('DIR_FS_CACHE' . 'cache/');

24 Oct 2007, 6:23 AM
#154
maxrisc avatar

maxrisc

Zen Follower

Join Date:
Mar 2007
Location:
Houston
Posts:
246
Plugin Contributions:
1

Re: Auction Lister Pro (ALP) Support

Not sure what is causing this. I don't use Windows. You may want to try specifying absolute path here in this case.

Did you purposely leave out DIR_FS_DOCUMENT_ROOT and DIR_WS_DOCUMENT_ROOT on your configuration above?

Those need to be set.

25 Oct 2007, 3:20 PM
#155
tweaked avatar

tweaked

New Zenner

Join Date:
Oct 2007
Posts:
1
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

I have ALP installed and working great after much trial and error.

Anyway there is still an error in the logs for that I have not figured out.


PHP Warning: Unknown: Your script possibly relies on a session side-effect which existed until PHP 4.2.3. Please be advised that the session extension does not consider global variables as a source of data, unless register_globals is enabled. You can disable this functionality and this warning by setting session.bug_compat_42 or session.bug_compat_warn to off, respectively. in Unknown on line 0

It does't point to where to fix. Our server is register_globals off

Is session.bug_compat_42 or session.bug_compat_warn in your script somewhere?

Anyway you have out done yourself on such a great contribution to zen cart. I sent a little donation earlier when I was having trouble but now I think you should get more as the script works great now.

25 Oct 2007, 6:06 PM
#156
fatguyinaz avatar

fatguyinaz

Zen Follower

Join Date:
Oct 2007
Location:
Safford, AZ
Posts:
313
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

Hello,

I was able to fix the 1146 error by searching this forum topic and found out the prefix on my database tables (zen_) needed to be added in the database_tables.php file. However, when I click on "Select" next to the category box there is an error in the popup window as follows:

Get Categories

Fatal error: Call to undefined function: getcategoryversion() in /home/swiker2/public_html/swiker/alp/getCategoriesSQL2.php on line 65

Any clue what this means?

Thanks,
Steve

25 Oct 2007, 8:37 PM
#157
barricades avatar

barricades

Inactive

Join Date:
May 2007
Posts:
150
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

Hi there, this looks like it could be really great, thanks for the hard work you've put in.

I've been reading through the couple of threads about this mod, been doing so for the last couple of days to try to get my head around all this. I'm a bit new.

Basically I want to open a shop on eBay to sell the stuff in my zencart. Is this software meant to allow you to do that (and hence benefit from lower listing fees) or will it only allow you to make a one-off style sale, and just get the customer to your cart to make the payment?

I'm I just stupid?

Is there a how to kinda thing for people with limited knowledge yet?

cheers

25 Oct 2007, 10:26 PM
#158
fatguyinaz avatar

fatguyinaz

Zen Follower

Join Date:
Oct 2007
Location:
Safford, AZ
Posts:
313
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

Well I figured out my error from 2 posts up. I had already installed the categories before I joined and got my eBay Developer keys & token. Therefore, I didn't think I had to install the categories again, which you do. The categories must be installed after the ALP software is installed.

Silly me!

However, I have found something you may want to fix, David. Once you install the categories and you are left with a button that says "Administration Tool", when clicked it takes you to the root of your domain and not to the ALP administration area.

So far all is working great!

Steve

26 Oct 2007, 2:45 PM
#159
barricades avatar

barricades

Inactive

Join Date:
May 2007
Posts:
150
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

Hi there, I've read through the other thread and just have one question. Below are quotes from the old thread with links;

When it says that our only fees will be listing fees does that mean that this software will eliminate final value fees? (since the transaction takes place outside of eBay)

The only fees for using Ebay are the standard listing fees.

http://www.zen-cart.com/forum/showpost.php?p=351277&postcount=21

You can email your winners and redirect them to your cart without being charged a fee by eBay or incurring any bad kharma with them.

http://www.zen-cart.com/forum/showpost.php?p=358568&postcount=75

thanks in advance

26 Oct 2007, 3:39 PM
#160
troy77 avatar

troy77

New Zenner

Join Date:
Jan 2007
Posts:
45
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

Hi people, i get this error after insalling it:

**1146 - Table 'fishkrib_ebay.configuration' doesn't exist

select configuration_key as cfgKey, configuration_value as cfgValue from configuration

[TEP STOP]**

Mind you it could be me cos on install it asks for a key and i dont no it.
Please advise.

Great mod for everyone if we can get it going though.:D