Zen Cart Logo
Forums / All Other Contributions/Addons / Windows Live Product Search Contribution Support Thread

Windows Live Product Search Contribution Support Thread

Locked

Views: 57,407

Results 61 to 80 of 210
This thread is locked. New replies are disabled.
13 Sep 2007, 9:14 PM
#61
stevekim avatar

stevekim

New Zenner

Join Date:
Apr 2007
Location:
Los Angeles, CA
Posts:
44
Plugin Contributions:
0

Windows Live Product Search Contribution Support Thread

numinix:

There is no error within the products themselves, but your feed file doesn't appear to be complete. Perhaps it is timing out before including all of the products. Add the following manually to the end of the file each time, or find out what is causing the script to not complete.

</OfferCollection> </DataFeed> ``` > > Also, check that all of your products are included (your newest additions would be at the end of the file). You can also use MAX PRODUCTS to limit the number of products included in the feed.

Thanks for the fastest reponse!

I've set the max product to 300 and it took 301 seconds to complete with DataFeed bracket at the end successfully.

But my question now is, where can I go and change this execution time limit higher? My php.ini's max_execution_time is set to 180 (but how would this particular script pass 180 and take 301 seconds?)

Thanks,

SK.

13 Sep 2007, 10:29 PM
#62
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Re: Windows Live Product Search Contribution Support Thread

You are on a very slow server, I would recommend moving to a better host ASAP.

I'm not sure why but you may want to increase it in both the php.ini and you in your store configuration.

14 Sep 2007, 4:16 AM
#63
stevekim avatar

stevekim

New Zenner

Join Date:
Apr 2007
Location:
Los Angeles, CA
Posts:
44
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

numinix:

You are on a very slow server, I would recommend moving to a better host ASAP.

I'm not sure why but you may want to increase it in both the php.ini and you in your store configuration.

I've got it resolved and it would be better to post it here for future references.
Modify following:

Go to Admin Configuration->My Store->Admin Set max_execution_time for processes

Thanks!

21 Sep 2007, 7:25 PM
#64
gothstone avatar

gothstone

Zen Follower

Join Date:
Jun 2005
Posts:
330
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Since I upgraded from LPS 1.0.1 to 1.02 ive been getting an error uploading:

Live Product Search Feeder v.1.02 19.08.2007 17:02 started 2007/09/21 14:19:58
Feed file - /home/goth/public_html/feed/lps.xml
Processing: Feed - Yes, Upload - Yes
Live Product Search File Complete In 0.048855 Seconds 29 Records
Upload started...
Upload Failed
Connected to: ftp.productupload.live.comLogin ok:Current Directory Is: /Warning: ftp_put() [function.ftp-put]: Transfer complete but post processing FAILED. 21522 bytes transferred. 21522 bps.

Upload failed...
Thinking it may have been part of my problem, I carefully uninstalled UPC/ISBN and installed Auction Site Attributes v1.05, but it hasen't helped. oddly enough ebay exporter, and google base are working fine.

I noticed that LPS does not have a config option for ASA. Could that be part of the problem?

21 Sep 2007, 7:55 PM
#65
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Re: Windows Live Product Search Contribution Support Thread

Turning on the UPC or ISBN configurations will activate ASA so no that is not an issue.

What is happening is actually nothing to do with the script at all. If you were to try FTPing the file you'd get the same message. Windows Live Product Search is either not accepting the file for processing, or the file name is incorrect. They are definitely not as stable as Google Base, but if you set your script to run every 2 days, it should be fine.

22 Sep 2007, 10:10 PM
#66
n8pbm avatar

n8pbm

Zen Follower

Join Date:
Mar 2005
Posts:
142
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

I moved to a new site. The feed worked fine on the old hostig site but after I moved to the new host I get the following error:

Live Product Search Feeder v.1.0.1a 29.08.2007 13:50 started 2007/09/22 16:00:29
Feed file - D:/Inetpub/mccampingsupplies/home/feed/mccamp.xml
Processing: Feed - Yes, Upload - No

Fatal error: Maximum execution time of 30 seconds exceeded in D:\Inetpub\mccampingsupplies\home\lps.php on line 169

I have added a php.ini file in my website root (i do not have access to the php.ini file) with only the following:

max_execution_time = 300
max_input_time = 140
memory_limit = 32M

I have alse increased the session timeout in the admin section.

Any suggestions?

I also have froogle feeder (old version that i need to upgrade) and that takes longer to give an error but does com up with an Access Violation error.

I am running on IIS server
PHP Version: 5.2.1
MySQL 5.0.27
Zen Cart 1.3.7

23 Sep 2007, 11:28 PM
#67
stevekim avatar

stevekim

New Zenner

Join Date:
Apr 2007
Location:
Los Angeles, CA
Posts:
44
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

n8pbm:

I moved to a new site. The feed worked fine on the old hostig site but after I moved to the new host I get the following error:

Live Product Search Feeder v.1.0.1a 29.08.2007 13:50 started 2007/09/22 16:00:29
Feed file - D:/Inetpub/mccampingsupplies/home/feed/mccamp.xml
Processing: Feed - Yes, Upload - No

Fatal error: Maximum execution time of 30 seconds exceeded in D:\Inetpub\mccampingsupplies\home\lps.php on line 169

I have added a php.ini file in my website root (i do not have access to the php.ini file) with only the following:

max_execution_time = 300
max_input_time = 140
memory_limit = 32M

I have alse increased the session timeout in the admin section.

Any suggestions?

I also have froogle feeder (old version that i need to upgrade) and that takes longer to give an error but does com up with an Access Violation error.

I am running on IIS server
PHP Version: 5.2.1
MySQL 5.0.27
Zen Cart 1.3.7

Read #61 and #63 above.

24 Sep 2007, 12:31 AM
#68
n8pbm avatar

n8pbm

Zen Follower

Join Date:
Mar 2005
Posts:
142
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Thanks but I have already tried changinge the settings in the admin section.

This appears to be a setting on the host. I can sucessfully extract 1200 products before getting the timeout. Any more and I have the time out. The hosting company will not change the timeout settings.

I am sure there is a way to execute the script for every 1000 products and then restart the script and append to the file for the next 1000. That way I will not hit the timeout issue. The problem is I do not know much PHP.

I was hoping there was a setting that I was missing.

24 Sep 2007, 12:33 AM
#69
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Re: Windows Live Product Search Contribution Support Thread

Try moving the php.ini file to your store root rather than your site root. I believe it will override settings in that folder

25 Sep 2007, 10:37 PM
#70
n8pbm avatar

n8pbm

Zen Follower

Join Date:
Mar 2005
Posts:
142
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Moving the php.ini file did not help.

25 Sep 2007, 11:49 PM
#71
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Re: Windows Live Product Search Contribution Support Thread

If you'd like, there is a feature in the ePier exporter that you can copy to the Google Base Feeder. It is a conditional statement near the beginning of the output section (after the products_query) that starts writing at 'X' number of products. So, you'd first put start = 1, max_products = 1000, then start = 1001, max_products = 2000 and so on.

28 Sep 2007, 6:31 AM
#72
arik7648 avatar

arik7648

New Zenner

Join Date:
Sep 2007
Posts:
6
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Hi

Please help with wlps. I've error

Live Product Search Feeder v.1.02 19.08.2007 17:02 started 2007/09/28 02:29:21
Feed file - /....../public_html/feed/livesearch.xml
Processing: Feed - Yes, Upload - No

Warning: chmod() [function.chmod]: Operation not permitted in /....../public_html/lps.php on line 69

Warning: chmod() [function.chmod]: Operation not permitted in /......../public_html/lps.php on line 177
Live Product Search File Complete In 0.293991 Seconds 70 Records

Please help:oops:

28 Sep 2007, 7:19 PM
#73
gothstone avatar

gothstone

Zen Follower

Join Date:
Jun 2005
Posts:
330
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Change the permissions of the feed folder to 777, then delete the livesearch.xml file and let it create a new one itself.

28 Sep 2007, 8:32 PM
#74
arik7648 avatar

arik7648

New Zenner

Join Date:
Sep 2007
Posts:
6
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

:blush: it's not what you think

All permission was install before, it's not first feed in the folder

28 Sep 2007, 9:18 PM
#75
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Re: Windows Live Product Search Contribution Support Thread

Follow the second part of his advice.

28 Sep 2007, 10:52 PM
#76
arik7648 avatar

arik7648

New Zenner

Join Date:
Sep 2007
Posts:
6
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Thank you !!! Everything OK!!! :clap:

Do you have contribution for import from AMAZON and eBay. I want feed it to Google and yahoo or ....

Do you have any idea ?

29 Sep 2007, 11:30 PM
#77
n8pbm avatar

n8pbm

Zen Follower

Join Date:
Mar 2005
Posts:
142
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

numinix:

If you'd like, there is a feature in the ePier exporter that you can copy to the Google Base Feeder. It is a conditional statement near the beginning of the output section (after the products_query) that starts writing at 'X' number of products. So, you'd first put start = 1, max_products = 1000, then start = 1001, max_products = 2000 and so on.

I'll take a look at that and try to modify the script.

Currently I backup the store to my local computer and then run the script locally. Of course I have to modify the output to add the correct urls and manually upload the file but it works.

If I can get this to work on the server then I can use a cron job to do this automatically. My php skills are minimal but may try the epier solution.

Any plans to integrate it into a future release (thought I had to ask :))?

30 Sep 2007, 4:39 AM
#78
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Re: Windows Live Product Search Contribution Support Thread

I've got a lot of contributions to support now, probably too many. I'm going to most likely integrate the feeders into a single universal script, and at that time I will definitely have maximum features.

At this time I have no plans to add that functionality just yet...

4 Oct 2007, 9:30 PM
#79
inovermyhead avatar

inovermyhead

Zen Follower

Join Date:
Feb 2007
Posts:
154
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Good afternoon Zenners ...
I have a question about when the items in a catalog become searchable.

Yesterday, I finally managed to get a shop's catalog to FTP up and to start processing. I promptly followed the same procedure on 3 other stores, and left them in 'processing' status. This morning they were still in 'processing' status, but this afternoon, all 4 showed a published status, 1 with a yellow triangle and !, and 3 with a green circle and check mark, though all 4 had some errors.

From what I've turned up in the doc, I thought when the catalog status became published, all the items not in error would be searchable on products.live.com, but there are no items at all showing up. Maybe I still have to wait 36 hours? Any input would be appreciated, as I feel in over my head again <grin>.

Thanks!

5 Oct 2007, 1:10 PM
#80
inovermyhead avatar

inovermyhead

Zen Follower

Join Date:
Feb 2007
Posts:
154
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

inovermyhead:

From what I've turned up in the doc, I thought when the catalog status became published, all the items not in error would be searchable on products.live.com, but there are no items at all showing up. Maybe I still have to wait 36 hours?
Thanks!

Well, apparently my assumption wasn't accurate, this morning the items are showing up in the Products Live Search. So even though the catalog showed up as published yesterday, the items were not yet to the point of being searchable. There is a quirk or two. If I search for the URL, as the doc suggests, only 40 or 50 items show up, but if I search with specific key words, many more items show up. Is that copacetic ?

Thanks,