Zen Cart Logo
Forums / All Other Contributions/Addons / Windows Live Product Search Contribution Support Thread

Windows Live Product Search Contribution Support Thread

Locked

Views: 57,407

Results 101 to 120 of 210
This thread is locked. New replies are disabled.
19 Nov 2007, 9:52 PM
#101
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Windows Live Product Search Contribution Support Thread

And what is the error? If you're product filename isn't registered with WLPS, it will reject the file immediately.

19 Nov 2007, 10:45 PM
#102
hyperlite635 avatar

hyperlite635

New Zenner

Join Date:
Jun 2007
Posts:
46
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

The file is registered. It uploads the file and right as it completes it says HTTP ERROR 403 or something like that.

24 Nov 2007, 9:17 PM
#103
hyperlite635 avatar

hyperlite635

New Zenner

Join Date:
Jun 2007
Posts:
46
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Has anyone figured out why this is happening? Any ideas?

24 Nov 2007, 9:30 PM
#104
hyperlite635 avatar

hyperlite635

New Zenner

Join Date:
Jun 2007
Posts:
46
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Ok I just tried to upload it manually again and it took it but then I got this message-

Catalog rejected: Not in the expected XML format.

I think there may be something wrong with the code?

24 Nov 2007, 11:42 PM
#105
lankeeyankee avatar

lankeeyankee

Totally Zenned

Join Date:
Jan 2007
Posts:
1,514
Plugin Contributions:
1

Re: Windows Live Product Search Contribution Support Thread

hyperlite635:

Ok I just tried to upload it manually again and it took it but then I got this message-

Catalog rejected: Not in the expected XML format.

I think there may be something wrong with the code?

I'm using it without any problems so it must be your installation. I would try running the uninstall SQL patch, uninstall all of the files from your sever and then start from scratch. A file might have been corrupted during the upload, it happens sometimes. And make sure that lps.php is installed in the root directory of your zencart.

Matt

25 Nov 2007, 4:52 AM
#106
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Re: Windows Live Product Search Contribution Support Thread

It's more likely that his XML feed is incomplete and doesn't have the closing declarations. We really can't go into further detail without seeing the feed itself. A link would be appreciated...

27 Nov 2007, 1:45 AM
#107
hyperlite635 avatar

hyperlite635

New Zenner

Join Date:
Jun 2007
Posts:
46
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

I already checked to see if the file completed and it was. I'm going to try to uninstall and reinstall and ill get back to you.

27 Nov 2007, 7:39 AM
#108
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Re: Windows Live Product Search Contribution Support Thread

I just looked at the file on your site and everything looks fine...

Just make sure you have registere the correct filename with WLPS.

Good luck.

27 Nov 2007, 1:33 PM
#109
dealbyethan_com avatar

dealbyethan_com

Totally Zenned

Join Date:
Dec 2005
Location:
Perth, Western Australia, Australia
Posts:
782
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Hi,

I installed this module and tried creating my product feed. I received the following warning. What did I do wrong?

Warning: chmod() [function.chmod]: Operation not permitted in /home/dealbyet/public_html/lps.php on line 70

27 Nov 2007, 1:50 PM
#110
dealbyethan_com avatar

dealbyethan_com

Totally Zenned

Join Date:
Dec 2005
Location:
Perth, Western Australia, Australia
Posts:
782
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

More information

I realized that I installed v1.04. So I updated to v1.06 by overwriting files and running the updated sql. When I clicked to create my product feed, it still shows the same warning.

Warning: chmod() [function.chmod]: Operation not permitted in /home/dealbyet/public_html/lps.php on line 78

27 Nov 2007, 6:38 PM
#111
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Re: Windows Live Product Search Contribution Support Thread

Delete the feed file and let the script create it.

27 Nov 2007, 10:51 PM
#112
dealbyethan_com avatar

dealbyethan_com

Totally Zenned

Join Date:
Dec 2005
Location:
Perth, Western Australia, Australia
Posts:
782
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Hi Jeff

Thanks for your help. After deleting the lps.xml feed file, the script then did create a new one itself. However, when I clicked to view my product feed file before proceeding to step 2, I received this error:
XML Parsing Error: no element found
Location: http://www.dealbyethan.com/feed/lps.xml
Line Number 13087, Column 9:</Offer>
--------^

Also, when I clicked to upload product feed to Live Product Search, I received this error:
Feed file - /home/dealbyet/public_html/feed/lps.xml
Processing: Feed - No, Upload - Yes
Upload started...
Connection failed: ftp.productupload.live.com
Warning: ftp_connect() [function.ftp-connect]: php_network_getaddresses: getaddrinfo failed: Name or service not known
Upload failed...

Clicking to view Live Product Search FTP content resulted in this message:
Live Product Search FTP content:
Connected to: ftp.productupload.live.com
Connection failed: ftp.productupload.live.com

Is something wrong with my installation? Please advise. Thank you.

28 Nov 2007, 2:18 AM
#113
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Re: Windows Live Product Search Contribution Support Thread

Nothing is wrong. Your script is timing out before completing. Also, the issue with not being able to use FTP functions seems to be related to hosting and non-dedicated ip's.

This costs about $2 a month...

28 Nov 2007, 3:20 AM
#114
dealbyethan_com avatar

dealbyethan_com

Totally Zenned

Join Date:
Dec 2005
Location:
Perth, Western Australia, Australia
Posts:
782
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Hi Jeff,

Thanks for your explanation.

When you said my script is timing out before completing, what should I do with this problem?

What should I tell my hosting company about the issue with not being able to use FTP functions? Who do I pay the $2 per month to?

30 Nov 2007, 7:59 PM
#115
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Re: Windows Live Product Search Contribution Support Thread

Your host would offer dedicated IP's as an upgrade on your current package.

You can increase the timeout length in php.ini as well as the Zen Cart admin as described earlier in this thread and also in the Google Base Feeder support thread (I believe it also states in the GBF readme.txt as well).

Another thing you can do is set the start and stop to a set amount of products. You seem to be getting around 3000 products in your feed so anywhere around that number would probably work. Then run it again at 3001. Use max_products to set the end.

6 Dec 2007, 1:14 PM
#116
james739 avatar

james739

Zen Follower

Join Date:
Jun 2007
Posts:
210
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

excellent mods. Works great!

Thank you!

12 Dec 2007, 4:21 PM
#117
seanscully avatar

seanscully

Zen Follower

Join Date:
Apr 2006
Location:
Largo, Florida USA
Posts:
99
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

I get the Live error 2 out of 3 times - the Goolge uploads all of the time, you just have to keep retrying Live and it will go through or FTP it.

Live Product Search Feeder v.1.0.1 09.08.2007 13:54 started 2007/12/12 11:13:04
Feed file - /home/stakemil/public_html/store/feed/lps.xml
Processing: Feed - No, Upload - Yes
Upload started...
Upload Failed
Connected to: ftp.productupload.live.comLogin ok:Current Directory Is: /Warning: ftp_put(): Transfer complete but post processing FAILED. 1347520 bytes transferred. 1347520 bps.

Upload failed...

I see Live.com has been updated -- if you FTP then you have to FTP everytime or vice versa
**Changes to the upload method for all catalogs: **When you create a new catalog, the upload method that you select for that catalog, either HTTP (Hypertext Transfer Protocol. A protocol used to transmit files over the Web.) or FTP (File Transfer Protocol. A fast, high bandwidth method of communicating between two computers.) , can't be changed. When you update a catalog, you must use the same upload method that you used when you first uploaded the catalog. If you have existing catalogs in Product Upload Beta, the last upload method that was used to upload each catalog will be set as the permanent upload method for it.

12 Dec 2007, 5:18 PM
#118
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Re: Windows Live Product Search Contribution Support Thread

Yes, the WLPS FTP server falls very short of the capabilities of the Google Base FTP server. Fortunately, Live is so useless for sending traffic that it doesn't really matter.

19 Dec 2007, 11:11 PM
#119
khopek avatar

khopek

Totally Zenned

Join Date:
Aug 2006
Location:
portlandish, oregon
Posts:
795
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

I just installed Windows Live Product Search Feeder, and I installed the GoogleBase feeder a couple days ago. The problem I am having is both feeds are using my _Lrg images for product images instead of _Med. I do not have _Lrg images for all products as it is actually a "detailed view" of the product if one is needed.

What do I need to change to get this to grab the _Med images instead?

20 Dec 2007, 5:29 PM
#120
ctcentralinfo avatar

ctcentralinfo

Totally Zenned

Join Date:
Apr 2005
Posts:
853
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

I am really having a difficult time getting this mod to work. I have no issue with generating the file, but I can't seem to be able to ftp the file. I am getting the same error the other users are getting

Live Product Search Feeder v.1.06 08.11.2007 00:00:59 started 2007/12/20 12:26:16
Feed file - /home/wwwcool/public_html/feed/msn_cooltechcentral.xml
Processing: Feed - No, Upload - Yes
Upload started...
Connection failed: ftp.productupload.live.com

Upload failed...

I was told by my web hosting company if the ftp upload is it browser based, it won't work because anonymous ftp is disabled.

I have your google base, feeder as well as your yahoo feeder installed, I am using the same feeder folder for all, could that also be causing the same issue?