Zen Cart Logo
Forums / All Other Contributions/Addons / Windows Live Product Search Contribution Support Thread

Windows Live Product Search Contribution Support Thread

Locked

Views: 57,407

Results 141 to 160 of 210
This thread is locked. New replies are disabled.
19 Jan 2008, 5:06 AM
#141
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Windows Live Product Search Contribution Support Thread

This is the most common question with the feeders and has to do with the script timing out before finishing the feed. See, XML files require the closing tags or they will not validate.

You can manually close them yourself.

22 Jan 2008, 2:56 AM
#142
khopek avatar

khopek

Totally Zenned

Join Date:
Aug 2006
Location:
portlandish, oregon
Posts:
795
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

So my catalog supposedly got published, but int he settings at Live it says "Merchant Category removed: does not conform to the correct format"

So...none of my products even show up

in the xml file it's showing:
<MerchantCategory>GIRLS | Outerwear</MerchantCategory>

with the | between the category and subcategories. I'm sure that is the probelm since it is not listed in the "allowed" characters...

I don't know what I need to do to fix this.

29 Jan 2008, 6:38 PM
#143
coucho avatar

coucho

Zen Follower

Join Date:
Jan 2008
Location:
Memphis, USA
Posts:
298
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Hi,

I looked through the threads and found some related subject matter but I did not find a clear solution to the error I am getting when I try to upload the xml file.

Processing: Feed - No, Upload - Yes
Upload started...
Connection failed: ftp.productupload.live.com
Warning: ftp_connect() [function.ftp-connect]: php_network_getaddresses: getaddrinfo failed: Name or service not known
Upload failed...

Anyone have a solution to this issue?

Update: I downloaded the .xml file directly from my feed directory in Cpanel and manually uploaded the file using HTTP. The catalog was published within 1 day.

Thanks,
Coucho

https://www.internationalcoffeeandbeverage.com

30 Jan 2008, 8:39 PM
#144
lextechs avatar

lextechs

Zen Follower

Join Date:
Mar 2005
Location:
Tempe, AZ
Posts:
316
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

I am getting the following error below however it's creating the file and the file is chmod 777 any ideas as to how i fix this error

Live Product Search Feeder v.1.06 08.11.2007 00:00:59 started 2008/01/30 14:32:13
Feed file - /home/username/public_html/site folder/feed/lextechslive.xml
Processing: Feed - Yes, Upload - No

Warning: chmod() [function.chmod]: Operation not permitted in /home/username/public_html/sitefolder/lps.php on line 78

Warning: chmod() [function.chmod]: Operation not permitted in /home/username/public_html/site folder/lps.php on line 192
Live Product Search File Complete In 1.593263 Seconds 347 Records

Dashizna:

Ok i tryed to create that live product feed file and i got these errors

Warning: chmod() [function.chmod]: Operation not permitted in /home/addisc5/public_html/lps.php on line 69

Warning: chmod() [function.chmod]: Operation not permitted in /home/addisc5/public_html/lps.php on line 177

But i think that it did create the file

But when i tryed to upload it with windows live they rejected the catalog

Please help.

1 Mar 2008, 11:28 AM
#145
pinetreecandles avatar

pinetreecandles

Zen Follower

Join Date:
Feb 2008
Location:
West Virginia
Posts:
135
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Just installed the 1.07 version of this mod and it's not creating the xml file at all. I have uninstalled and reinstalled it a couple times and nothing. I click on the link from admin to create the file and a small window with nothing in it pops up.

I checked the feed folder to see if it was there and it's not. Not sure where to go from here since it's not creating the file. Any suggestions as to what might be the problem?

4 Mar 2008, 1:20 PM
#146
necsy avatar

necsy

New Zenner

Join Date:
Dec 2007
Posts:
16
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

hummm... sorry numinix but have problems whit this mode...

if lunch sql file have this reply:

8 statements processed.
Errore ERROR: Impossibile inserire configuration_key "" in quanto già esistente
Avviso Note: 1 statements ignored. See "upgrade_exceptions" table for additional details.

If go to Admin->Configuration->Live Product Search Feeder Configuration

The page is empy, look only Live Product Search Feeder Configuration and title value action, no other... :unsure:

5 Mar 2008, 2:41 PM
#147
kitcorsa avatar

kitcorsa

Totally Zenned

Join Date:
Feb 2007
Posts:
1,724
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

i have this modual installed on my 2 site as seen below. i also have the google feed installed on both site.

with https://www.rubberduckbathrooms.co.uk i installed both moduals google and live and both worked first time out of the box so to say.

with https://www.fire2you.co.uk i found that neither google or live worked and recieved errors. with live i recieved this error. also had a simular error with google.

Processing: Feed - No, Upload - Yes
Upload started...
Upload Failed
Connected to: ftp.productupload.live.comLogin ok:Current Directory Is: /Warning: ftp_put() [function.ftp-put]: Opening ASCII mode data connection for lps.xml. 

Upload failed...

with this error is has to do with passive mode and the server. Both my sites are osted through the same companie on the same server package it was just a wierd error.

i then edited the following on line 431

		ftp_pasv($cd, false);

and changed it to

		ftp_pasv($cd, ture);

this turned passive mode on and the upload worked

hope this helps people out

5 Mar 2008, 3:09 PM
#148
nfm avatar

nfm

New Zenner

Join Date:
Jan 2008
Posts:
90
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Right, that's what I tried and it still didn't work. I'll try it again...

5 Mar 2008, 3:10 PM
#149
nfm avatar

nfm

New Zenner

Join Date:
Jan 2008
Posts:
90
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Just tried again, 3 times, all three times the upload failed....quickly.

5 Mar 2008, 3:30 PM
#150
kitcorsa avatar

kitcorsa

Totally Zenned

Join Date:
Feb 2007
Posts:
1,724
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

what the error you recieve.

only other thing to do is download a new copy of the modual (might have a curruption) and upload again to your site.

then make sure all these file are set to 644 and the feed folder is set to 755

run this from standard with no modifications if you recieve the same error as mine, try the passive mode change above if you still recieve the same or different error please let us know the version of zencart you using and the version of live mod your trying to use.

5 Mar 2008, 4:51 PM
#151
nfm avatar

nfm

New Zenner

Join Date:
Jan 2008
Posts:
90
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Ehh...not worth it anymore. I'll just use an FTP program to put the file up there once a week....as long as the Google one works I'm fine....I get most of my customers from Google anyways.

5 Mar 2008, 7:05 PM
#152
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Re: Windows Live Product Search Contribution Support Thread

I'm working on the FTP portion to see if it can be altered to work better for Live. Right now it is virtually the same as the GBF.

5 Mar 2008, 7:40 PM
#153
necsy avatar

necsy

New Zenner

Join Date:
Dec 2007
Posts:
16
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Up my problem and show image.

If go in configuration I do not see anything, only this blank page

6 Mar 2008, 4:06 PM
#154
kitcorsa avatar

kitcorsa

Totally Zenned

Join Date:
Feb 2007
Posts:
1,724
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

NFM:

Ehh...not worth it anymore. I'll just use an FTP program to put the file up there once a week....as long as the Google one works I'm fine....I get most of my customers from Google anyways.

try a cron job see if that fails

6 Mar 2008, 4:08 PM
#155
kitcorsa avatar

kitcorsa

Totally Zenned

Join Date:
Feb 2007
Posts:
1,724
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Necsy:

Up my problem and show image.

If go in configuration I do not see anything, only this blank page

maybe a problem with your edited style sheet blocking the screen

7 Mar 2008, 8:36 AM
#156
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Re: Windows Live Product Search Contribution Support Thread

It was a problem with his database. Installing from phpmyadmin solved his issue. If anyone wishes to use phpmyadmin, make sure you account for database prefixes.

8 Mar 2008, 1:39 PM
#157
necsy avatar

necsy

New Zenner

Join Date:
Dec 2007
Posts:
16
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Publicly thank you for your willingness and your support...thank you Numinix! :clap:

12 Mar 2008, 7:55 PM
#158
dealbyethan_com avatar

dealbyethan_com

Totally Zenned

Join Date:
Dec 2005
Location:
Perth, Western Australia, Australia
Posts:
782
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

numinix:

Your host would offer dedicated IP's as an upgrade on your current package.

You can increase the timeout length in php.ini as well as the Zen Cart admin as described earlier in this thread and also in the Google Base Feeder support thread (I believe it also states in the GBF readme.txt as well).

I took your advice to make all the recommended changes. But I still couldn't get it to work. I did step 1 and the message is:
Feed file - /home/dealbyet/public_html/feed/lps.xml
Processing: Feed - Yes, Upload - No

When I view my product feed file in Firefox at http://www.dealbyethan.com/feed/lps.xml, I received this:
XML Parsing Error: no element found
Location: http://www.dealbyethan.com/feed/lps.xml
Line Number 13087, Column 9:</Offer>
--------^

whereas in IE7, it seems to work but at the end of the page, I have this:
The XML page cannot be displayed
Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.

The following tags were not closed: DataFeed, OfferCollection. Error processing resource 'http://www.dealbyethan.com/feed/l...

Brand />
<MerchantCategory>Shop by Menswear Brands</MerchantCategory>
<ReferenceImageURL>http://www.dealbyethan.com/bmz_cache/d/d0da7760b2b6c34c40f27dd72a0f582f.image.220x207.jpg</ReferenceImageURL>

Also, step 2 gave me this message:
Feed file - /home/dealbyet/public_html/feed/lps.xml
Processing: Feed - No, Upload - Yes
Upload started...
Connection failed: ftp.productupload.live.com
Warning: ftp_connect() [function.ftp-connect]: php_network_getaddresses: getaddrinfo failed: Name or service not known
Upload failed...

I then signed in to productupload.live.com. I created a new catalog with the following details.

File type: product search XML (.xml)
Delimiter: left this unselected

Choose file upload method: through browser

I uploaded lps.xml through browser but I get this message:
Catalog rejected: Not in the expected XML format.
Correct the format, and then try your upload again.

Can anyone who got it working please help? I have been testing this for a long time with no luck still. Thanks in advance.

12 Mar 2008, 8:17 PM
#159
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Re: Windows Live Product Search Contribution Support Thread

If you try the latest version on the Numinix site, you may find that it will solve problems for sites with a larger number of products.

Your feed is timing out and not closing the tags at the end of the file. I know you aren't using the latest version because I have removed image handler and your post shows an image created by image handler...

12 Mar 2008, 8:52 PM
#160
dealbyethan_com avatar

dealbyethan_com

Totally Zenned

Join Date:
Dec 2005
Location:
Perth, Western Australia, Australia
Posts:
782
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

numinix:

If you try the latest version on the Numinix site, you may find that it will solve problems for sites with a larger number of products.

Your feed is timing out and not closing the tags at the end of the file. I know you aren't using the latest version because I have removed image handler and your post shows an image created by image handler...

Yes, you are right. It seems to be working and the status is processing. Thanks a lot :)