Zen Cart Logo
Forums / All Other Contributions/Addons / Windows Live Product Search Contribution Support Thread

Windows Live Product Search Contribution Support Thread

Locked

Views: 57,407

Results 81 to 100 of 210
This thread is locked. New replies are disabled.
5 Oct 2007, 2:14 PM
#81
dashizna avatar

dashizna

Zen Follower

Join Date:
Mar 2006
Posts:
424
Plugin Contributions:
0

Windows Live Product Search Contribution Support Thread

Ok i tryed to create that live product feed file and i got these errors

Warning: chmod() [function.chmod]: Operation not permitted in /home/addisc5/public_html/lps.php on line 69

Warning: chmod() [function.chmod]: Operation not permitted in /home/addisc5/public_html/lps.php on line 177

But i think that it did create the file

But when i tryed to upload it with windows live they rejected the catalog

Please help.

5 Oct 2007, 2:55 PM
#82
inovermyhead avatar

inovermyhead

Zen Follower

Join Date:
Feb 2007
Posts:
154
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Hello, Dashizna ... what is the size of your output file ? If it's 0, you probably need to check the permissions on the file, and make it writeable.

5 Oct 2007, 3:34 PM
#83
dashizna avatar

dashizna

Zen Follower

Join Date:
Mar 2006
Posts:
424
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

ok got it thanks

31 Oct 2007, 3:47 PM
#84
seanscully avatar

seanscully

Zen Follower

Join Date:
Apr 2006
Location:
Largo, Florida USA
Posts:
99
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

I am having a problem with my LPS.XML file not completing - this is what I get in the very end when viewing it after it fails. What do I need to adjust? {I may nothave the below in the correct brackets}

[URL="http://www.stakemill.com/store/feed/lps.xml#"][B]-[/B][/URL] <Offer>
<DIV> <OfferName>[B]Crain CR-4.0 Metric Series Rod Replacement Section[/B]</OfferName> 
 
<DIV class=e><DIV style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em"> <Brand>[B]CRAIN[/B]</<FONT color=#990000>Brand
 
The XML page cannot be displayed 
Cannot view XML input using XSL style sheet. Please correct the error and then click the [URL="http://javascript<b></b>:location.reload()"]Refresh[/URL] button, or try again later. A semi colon character was expected. Error processing resource 'http://www.stakemill.com/store/feed/lps.xml'. Line 6123, P...
<ReferenceImageURL>http://www.stakemill.com/store/images/57-NMB100&CH1000.jpg</ReferenceImageURL>---------...PAN class="m">></SPAN> 
 <MerchantCategory>[B]Grade Rods | Replacement Parts Rods | Crain Rod Replacement Parts[/B]</MerchantCategory> 
 
 <ReferenceImageURL>[B][URL]http://www.stakemill.com/store/images/replacement_section.jpg[/URL][/B]</ReferenceImageURL> 
 
 <ActionURL>[B][URL]http://www.stakemill.com/store/index.php?main_page=product_info&products_id=959&language=en&currency=USD[/URL][/B]</ActionURL> 
31 Oct 2007, 5:57 PM
#85
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Re: Windows Live Product Search Contribution Support Thread

seanscully:

I am having a problem with my LPS.XML file not completing - this is what I get in the very end when viewing it after it fails. What do I need to adjust? {I may nothave the below in the correct brackets}

It is timing out before completing the feed. Follow the instructions for increasing the php max execution time on your server and in the zen cart admin. You may also want to use the max products feature.

31 Oct 2007, 6:37 PM
#86
seanscully avatar

seanscully

Zen Follower

Join Date:
Apr 2006
Location:
Largo, Florida USA
Posts:
99
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Somehow it fixed itself - I did change the max products to 2000, adjusted the time to 360 but I wonder if the ampersand had anything to do with it? That is where the page broke when viewing in a browser, it was fine in Crimpson Editor.

images/57-NMB100&CH1000.jpg</ReferenceImageURL>---------...

me done good

1 Nov 2007, 2:01 PM
#87
seanscully avatar

seanscully

Zen Follower

Join Date:
Apr 2006
Location:
Largo, Florida USA
Posts:
99
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Image Size - my catalog is published and now searchable on http://products.live.com It shows some of my listings without images, do they have a image size limit.

Thanks for the great mods Numinix

2 Nov 2007, 2:03 PM
#88
alext avatar

alext

New Zenner

Join Date:
May 2007
Location:
Perth, Australia
Posts:
54
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

This mod breaks my site, I tried both v. 1.01 and 1.04 :(

lps.sql loads OK upon installation, the product feed file is also generated OK. But if I refresh my website after the feed has been generated, it shows only logo and the following text:

Warning: Variable passed to each() is not an array or object in /home/matrecom/public_html/includes/classes/db/mysql/query_factory.php on line 114
Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/matrecom/public_html/includes/classes/db/mysql/query_factory.php:114) in /home/matrecom/public_html/includes/functions/sessions.php on line 108
Warning: Cannot modify header information - headers already sent by (output started at /home/matrecom/public_html/includes/classes/db/mysql/query_factory.php:114) in /home/matrecom/public_html/includes/init_includes/init_templates.php on line 78
"Beauty will save the world"

  • Dostoevsky Home
    Russian Matryoshka Dolls
    New Products For NovemberFeatured ProductsMonthly Specials For November
    1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'EXPECTED_PRODUCTS_SORT limit MAX_DISPLAY_UPCOMING_PRODUC' at line 7
    in:
    [select p.products_id, pd.products_name, products_date_available as date_expected from zen_products p, zen_products_description pd where p.products_id = pd.products_id and p.products_status = 1 and pd.language_id = '1' and p.products_date_available >=20071103 order by EXPECTED_PRODUCTS_FIELD EXPECTED_PRODUCTS_SORT limit MAX_DISPLAY_UPCOMING_PRODUCTS]

I am not sure what I am doing wrong? Any ideas are much appreciated!

Many thanks,
Alex

2 Nov 2007, 5:43 PM
#89
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Re: Windows Live Product Search Contribution Support Thread

I am not sure what is happening, but nothing in that quote relates to any of the feeders/exporters...

2 Nov 2007, 11:08 PM
#90
alext avatar

alext

New Zenner

Join Date:
May 2007
Location:
Perth, Australia
Posts:
54
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

numinix:

I am not sure what is happening, but nothing in that quote relates to any of the feeders/exporters...

Are there any known incompatibilities with other mods?
Any ideas at all on how I should approach the issue?

Many thanks,
Alex

2 Nov 2007, 11:35 PM
#91
alext avatar

alext

New Zenner

Join Date:
May 2007
Location:
Perth, Australia
Posts:
54
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

AlexT:

Are there any known incompatibilities with other mods?
Any ideas at all on how I should approach the issue?

Many thanks,
Alex

For those with the same problem, here is the fix:

DrByte:

The real fix/resolution is here:
http://www.zen-cart.com/forum/showthread.php?p=378357#post378357

4 Nov 2007, 7:53 PM
#92
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Re: Windows Live Product Search Contribution Support Thread

v1.05 WINDOWS LIVE PRODUCT SEARCH FEEDER

updated to use Magic SEO URLs.

6 Nov 2007, 12:12 PM
#93
taf avatar

taf

New Zenner

Join Date:
Jun 2007
Posts:
58
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Hi,

Sorry if this is slightly off topic. Been looking at this very nice mod and I was wondering if windows live product search has a UK version so i can use this Mod.

I can't see anything about a UK version on the web. Anyone know how to contact MS to find out about this?

Thanks.

8 Nov 2007, 6:00 AM
#94
lankeeyankee avatar

lankeeyankee

Totally Zenned

Join Date:
Jan 2007
Posts:
1,514
Plugin Contributions:
1

Re: Windows Live Product Search Contribution Support Thread

I installed v1.05 and I get this error message when trying to upload to the windows ftp site:

Upload started...
Connection failed: ftp.productupload.live.com
Warning: ftp_connect() [function.ftp-connect]: php_network_getaddresses: getaddrinfo failed: Name or service not known
Upload failed...

I have, I believe anyway, everything set up correctly in the config. Any ideas?

Here are my config settings:

Live FTP Username xxxxxxxx
Live FTP Password xxxxxxxx
LPS Server ftp.productupload.live.com
Default Currency USD
Magic SEO URLs true
Output File Name lps.xml
Compress Feed File false
Output Directory feed/
Use cPath in url false
uploaded date
Max products 0
Starting Point 0
Included Categories
Excluded Categories
UPC true
ISBN false
Product Type top

Thanks!

Matt

13 Nov 2007, 8:45 PM
#95
james739 avatar

james739

Zen Follower

Join Date:
Jun 2007
Posts:
210
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

Thanks for the contribution. I get this error when I click on step 1 under the feeder option.

Error 404 - File Not Found

**The file you are trying to reach could not be found on the server.
Please make sure that you type the URL correctly. **

what could be the problem?

19 Nov 2007, 3:03 AM
#96
hyperlite635 avatar

hyperlite635

New Zenner

Join Date:
Jun 2007
Posts:
46
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

lankeeyankee:

I installed v1.05 and I get this error message when trying to upload to the windows ftp site:

Upload started...
Connection failed: ftp.productupload.live.com
Warning: ftp_connect() [function.ftp-connect]: php_network_getaddresses: getaddrinfo failed: Name or service not known
Upload failed...

I have, I believe anyway, everything set up correctly in the config. Any ideas?

Here are my config settings:

Live FTP Username xxxxxxxx
Live FTP Password xxxxxxxx
LPS Server ftp.productupload.live.com
Default Currency USD
Magic SEO URLs true
Output File Name lps.xml
Compress Feed File false
Output Directory feed/
Use cPath in url false
uploaded date
Max products 0
Starting Point 0
Included Categories
Excluded Categories
UPC true
ISBN false
Product Type top

Thanks!

Matt

I'm getting the same error. Did you figure it out?

19 Nov 2007, 4:29 AM
#97
lankeeyankee avatar

lankeeyankee

Totally Zenned

Join Date:
Jan 2007
Posts:
1,514
Plugin Contributions:
1

Re: Windows Live Product Search Contribution Support Thread

hyperlite635:

I'm getting the same error. Did you figure it out?

I got this from another thread dealing with another feeder by the same author, he thinks that it's because we don't have a dedicated IP and our server won't allow php to execute the script from a shared IP. Do you have a shared IP or a dedicated IP?

Matt

19 Nov 2007, 5:43 AM
#98
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,566
Plugin Contributions:
58

Re: Windows Live Product Search Contribution Support Thread

I'm not sure what the reason is (whether shared IP or not, this is something you have speculated), but it seems to be very common that store owners cannot use the FTP functions.

In fact, way back when someone first brought this forward, I took a very general FTP script off the net and uploaded it to one store's website, executed it, and had the exact same error return. So, don't think that I haven't tested this. It works 100% on 95% of stores with a handful of others unable to use it.

Out of curosity, who do you use for hosting? Maybe we can find a pattern.

19 Nov 2007, 12:42 PM
#99
alext avatar

alext

New Zenner

Join Date:
May 2007
Location:
Perth, Australia
Posts:
54
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

numinix:

I'm not sure what the reason is (whether shared IP or not, this is something you have speculated), but it seems to be very common that store owners cannot use the FTP functions.

In fact, way back when someone first brought this forward, I took a very general FTP script off the net and uploaded it to one store's website, executed it, and had the exact same error return. So, don't think that I haven't tested this. It works 100% on 95% of stores with a handful of others unable to use it.

Out of curosity, who do you use for hosting? Maybe we can find a pattern.

I have exactly the same problem on dedicated IP (hosted with Jumba, the server is in Australia). Interesting that the Google Base Feeder does not cause similar problems.

Thanks,
Alex

19 Nov 2007, 5:53 PM
#100
hyperlite635 avatar

hyperlite635

New Zenner

Join Date:
Jun 2007
Posts:
46
Plugin Contributions:
0

Re: Windows Live Product Search Contribution Support Thread

I have a dedicated IP and I also have the google base feeder and it works fine. I think there is something wrong with this module. I also tried downloading the xml file and uploading it manually and I get an error.