Zen Cart Logo
Forums / All Other Contributions/Addons / Autoresponder+ for ZC v1.3.x [support thread]

Autoresponder+ for ZC v1.3.x [support thread]

Views: 45,163

Results 101 to 120 of 232
30 Jun 2009, 10:35 PM
#101
happymom avatar

happymom

New Zenner

Join Date:
May 2006
Posts:
82
Plugin Contributions:
0

Autoresponder+ for ZC v1.3.x [support thread]

I uninstalled the SQL code using the uninstall file.

Then, I copy and pasted the sql code to the Admin -> Tools -> Install SQL Patches and I got an error saying that there were blanks in the code.

I removed the blanks and re-copy the sql code.

This time it was successful and it say that 8 entries/statements were excuted... does that sound right?

Anyways... still no "Autoresponder" under the Configuration menu.

  • I do not have the latest patches installed, since I am using 1.3.7
  • I do not have any other modifications under the Configuration menu. :no:

Thanks! :-)

30 Jun 2009, 10:52 PM
#102
steven300 avatar

steven300

Totally Zenned

Join Date:
Jan 2008
Posts:
1,564
Plugin Contributions:
1

Re: Autoresponder+ for ZC v1.3.x [support thread]

HappyMom:

This time it was successful and it say that 8 entries/statements were excuted... does that sound right?

Yes, that sounds correct.

As a test, I just went to OpenSourceCMS where they have a Zen Cart demo and I ran the Install.sql and the Autoresponder+ admin settings appeared as expected. Feel free to try it yourself.

It would be interesting to know what would happen if you tried to install another mod which also uses admin settings in the configuration menu.

Considering everything, I believe it is your Zen Cart that is the problem.

I suggest opening a separate thread as it sounds like the problem is not with the mod.

30 Jun 2009, 11:03 PM
#103
happymom avatar

happymom

New Zenner

Join Date:
May 2006
Posts:
82
Plugin Contributions:
0

Re: Autoresponder+ for ZC v1.3.x [support thread]

I did try it in http://www.opensourcecms.com/d and it worked. bummer! :-)

I will test it on a fresh 1.3.7 install or I must upgrade to 1.3.8.

Thanks for all of your help! :smile:

30 Jun 2009, 11:05 PM
#104
steven300 avatar

steven300

Totally Zenned

Join Date:
Jan 2008
Posts:
1,564
Plugin Contributions:
1

Re: Autoresponder+ for ZC v1.3.x [support thread]

You're welcome. Good luck!

30 Jun 2009, 11:18 PM
#105
happymom avatar

happymom

New Zenner

Join Date:
May 2006
Posts:
82
Plugin Contributions:
0

Re: Autoresponder+ for ZC v1.3.x [support thread]

I figure it out!!! :clap:

I have the admin addon patch installed (the one that allows several admin to loggin to the store). My admin was not "allowed" to see this page, so once I changed the setting in the admin panel, the autoresponder appear. :clap:

Thanks so much for telling me where NOT to look. :D

30 Jun 2009, 11:21 PM
#106
steven300 avatar

steven300

Totally Zenned

Join Date:
Jan 2008
Posts:
1,564
Plugin Contributions:
1

Re: Autoresponder+ for ZC v1.3.x [support thread]

Excellent! Thanks for reporting back with the fix.

1 Jul 2009, 6:11 AM
#107
happymom avatar

happymom

New Zenner

Join Date:
May 2006
Posts:
82
Plugin Contributions:
0

Re: Autoresponder+ for ZC v1.3.x [support thread]

Now that I had a chance to play with this new tool, I can see how nicely it would be to just be able to enter my own sql. The possibility are endless!! :-):flex:

Great Job, and thanks for sharing. This tool is awesome!:clap:

1 Jul 2009, 12:11 PM
#108
medgollc avatar

medgollc

New Zenner

Join Date:
Aug 2007
Posts:
27
Plugin Contributions:
0

Re: Autoresponder+ for ZC v1.3.x [support thread]

I am using 1.3.8a and have installed the Autoresponder 2.1a and in test mode i recieve the message below. Can someone help me fix this?

Thanks
Rich :dontgetit

1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') AND OSH.orders_id=O.orders_id AND OSH.orders_status_id=O.orders_status' at line 4
in:
[SELECT DISTINCT OSH.orders_id, O.customers_email_address, O.customers_name FROM orders_status_history OSH, orders O WHERE OSH.date_added like '2009-06-30%' AND OSH.orders_status_id in () AND OSH.orders_id=O.orders_id AND OSH.orders_status_id=O.orders_status]

1 Jul 2009, 1:03 PM
#109
steven300 avatar

steven300

Totally Zenned

Join Date:
Jan 2008
Posts:
1,564
Plugin Contributions:
1

Re: Autoresponder+ for ZC v1.3.x [support thread]

Make sure to enter at least one 'Order Status ID' in the admin settings.

1 Jul 2009, 1:20 PM
#110
medgollc avatar

medgollc

New Zenner

Join Date:
Aug 2007
Posts:
27
Plugin Contributions:
0

Re: Autoresponder+ for ZC v1.3.x [support thread]

Thank you, but how do i add a status for account-no-order?

1 Jul 2009, 1:24 PM
#111
medgollc avatar

medgollc

New Zenner

Join Date:
Aug 2007
Posts:
27
Plugin Contributions:
0

Re: Autoresponder+ for ZC v1.3.x [support thread]

Never mind i got it.

Thnaks for your help. Great program.

1 Jul 2009, 1:29 PM
#112
steven300 avatar

steven300

Totally Zenned

Join Date:
Jan 2008
Posts:
1,564
Plugin Contributions:
1

Re: Autoresponder+ for ZC v1.3.x [support thread]

Just out of interest, was it because you had "order" instead of "account-no-order" configured for the "Query" setting?

1 Jul 2009, 6:07 PM
#113
dllong avatar

dllong

New Zenner

Join Date:
Jul 2008
Posts:
15
Plugin Contributions:
0

Re: Autoresponder+ for ZC v1.3.x [support thread]

Thought I'd follow up on my post #93 where I could not get the html email to work. It turns out that there is some code missing when the name is set to "0" (no name). The variable $this_auto_message_html is undefined.

Since I didn't want to play around further, I modified the following lines:
Comment out Line 413 and add " $html_message = "<p />" . $this_auto_message_html_1 . $product_details_html . $this_auto_message_html_2;" after it.
Repeat this process for lines 893 and 1369.

Of course the other approach would be to simply define "this_auto_message_html" but I'll let Steven300 post that change.

1 Jul 2009, 6:49 PM
#114
steven300 avatar

steven300

Totally Zenned

Join Date:
Jan 2008
Posts:
1,564
Plugin Contributions:
1

Re: Autoresponder+ for ZC v1.3.x [support thread]

Hi DLLong,

It looks as if you have correctly identified the problem, along with a suitable fix.

$this_auto_message_html should not be in the code at all. It's a variable which was used before I added the ability to include product details and should have been updated during the development of the new feature.

However, since no name is being displayed at the beginning of the email, it seems better to omit the <p /> tag. So the code should be:

$html_message = $this_auto_message_html_1 . $product_details_html . $this_auto_message_html_2;

I will test this fix and upload a new version of Autoresponder+ either today or tomorrow.

Thanks for reporting.

2 Jul 2009, 5:51 AM
#115
happymom avatar

happymom

New Zenner

Join Date:
May 2006
Posts:
82
Plugin Contributions:
0

Re: Autoresponder+ for ZC v1.3.x [support thread]

Has anyone gotten these errors? I get them while running on test mode using the real crown job vs using the web page.

Also, it seems to be only affecting the loggin, since I get the emails correctly...

The error says that it can't open the autoresponder_log.log file, but when I try to change the permission of the file to 777, it denies me the permission to do that, but the file is updated. :blink:

<b>Warning</b>: fopen(/home/mxfimrk/public_html/AUTORESPONDER/autoresponder_log.log) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied in <b>/home/mxfimrk/public_html/autoresponder.php</b> on line <b>52</b><br />
<br />
<b>Warning</b>: fputs(): supplied argument is not a valid stream resource in <b>/home/mxfimrk/public_html/autoresponder.php</b> on line <b>53</b><br />
<br />
<b>Warning</b>: fclose(): supplied argument is not a valid stream resource in <b>/home/mxfimrk/public_html/autoresponder.php</b> on line <b>56</b><br />
Autoresponder successfully loaded.<br />End of message.

2 Jul 2009, 12:32 PM
#116
steven300 avatar

steven300

Totally Zenned

Join Date:
Jan 2008
Posts:
1,564
Plugin Contributions:
1

Re: Autoresponder+ for ZC v1.3.x [support thread]

What are your permissions for the autoresponder directory which the log is in?

Maybe you have 'suhosin' installed preventing 777 permissions?

Try configuring the log to be stored in the root directory.

Failing that, perhaps contact your host since it sounds like a server issue.

20 Jul 2009, 4:22 AM
#117
jabtac avatar

jabtac

New Zenner

Join Date:
Jun 2009
Posts:
17
Plugin Contributions:
0

Re: Autoresponder+ for ZC v1.3.x [support thread]

I'm having a problem implementing this mod. I am using 1.3.8a and successfully updated the database and I see AutoResponder+ under Admin -> Configuration. Now, I open a tab in my browser and type in the address for my autoresponder.php file (is this how you "run" the file? That's how I understood it from the instructions). I am getting this error:

Warning: require(includes/application_top.php) [function.require]: failed to open stream: No such file or directory in /home/MYSITE/public_html/MYRENAMEDautoresponder.php on line 11

Fatal error: require() [function.require]: Failed opening required 'includes/application_top.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/MYSITE/public_html/MYRENAMEDautoresponder.php on line 11

Line 11 in MYRENAMEDautoresponder.php says: require('includes/application_top.php');

I'm not sure what this error means... but the file "application_top.php" does exist in my /includes/ folder

Any ideas?

Thanks!
Jon

20 Jul 2009, 5:34 AM
#118
jabtac avatar

jabtac

New Zenner

Join Date:
Jun 2009
Posts:
17
Plugin Contributions:
0

Re: Autoresponder+ for ZC v1.3.x [support thread]

jabtac:

I'm having a problem implementing this mod. I am using 1.3.8a and successfully updated the database and I see AutoResponder+ under Admin -> Configuration. Now, I open a tab in my browser and type in the address for my autoresponder.php file (is this how you "run" the file? That's how I understood it from the instructions). I am getting this error:

Warning: require(includes/application_top.php) [function.require]: failed to open stream: No such file or directory in /home/MYSITE/public_html/MYRENAMEDautoresponder.php on line 11

Fatal error: require() [function.require]: Failed opening required 'includes/application_top.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/MYSITE/public_html/MYRENAMEDautoresponder.php on line 11

Line 11 in MYRENAMEDautoresponder.php says: require('includes/application_top.php');

I'm not sure what this error means... but the file "application_top.php" does exist in my /includes/ folder

Any ideas?

Thanks!
Jon

Well I just commented out line 11 and ran the autoresponder.php file without a problem. However, I'm not in test mode and setting appropriate values for the different options, but not receiving any email msgs.... Back to the grind.

20 Jul 2009, 12:59 PM
#119
steven300 avatar

steven300

Totally Zenned

Join Date:
Jan 2008
Posts:
1,564
Plugin Contributions:
1

Re: Autoresponder+ for ZC v1.3.x [support thread]

Hi Jon,

Quite perplexing.

It looks as if you have the autoresponder.php file in your root directory, so the path to the includes/application_top.php file should be correct. And if the includes/application_top.php file does exist (which it probably does since Zen Cart would not work without it), then the error message you received makes very little sense.

Interestingly, someone using one of my other mods, Desktop Data, had the same problem once. I'm not sure if they managed to fix the issue. When thinking about it, Autoresponder+ and Desktop Data are similarly built, in that they both have a "standalone" file in the root directory which includes application_top.php. From what I can tell, the majority of people have no problems with either mod so I believe this may be some type of server issue.

One thing I think is worth checking is the file permissions for includes/application_top.php. Are the permissions any lower than 644?

If that doesn't work, I will probably open a separate thread about this and hopefully one of the devs will have more of an idea.

20 Jul 2009, 5:30 PM
#120
jabtac avatar

jabtac

New Zenner

Join Date:
Jun 2009
Posts:
17
Plugin Contributions:
0

Re: Autoresponder+ for ZC v1.3.x [support thread]

Steven,

Thanks for the reply. I also use your Desktop Data mod so when you brought that up it made me think about file location. I went and checked where I had my "desktop_data.php" file and it ends up I had the "autoresponder.php" one folder up from my actual "root" directory. I reinstated Line 11 in autoresponder.php and moved it to the same directory as my desktop_data.php and ran it. No problems! I checked my presets and ran the test, no problems!

I knew something just wasn't right because I also wasn't getting an "autoresponder_log.log" file where I should have been... but now I am.

Thanks again for your great mods and your helping us all out.

-Jon