Zen Cart Logo
Forums / All Other Contributions/Addons / OLD Super Orders 2.0 (See v3.0 thread instead)

OLD Super Orders 2.0 (See v3.0 thread instead)

Locked

Views: 456,069

Results 881 to 900 of 2,020
This thread is locked. New replies are disabled.
11 Feb 2008, 1:58 PM
#881
blindside avatar

blindside

Totally Zenned

Join Date:
Sep 2004
Posts:
1,237
Plugin Contributions:
1

OLD Super Orders 2.0 (See v3.0 thread instead)

HMG:

Okay, you were of course, correct. Some files were missing. I placed them in the appropriate spot but still do not see the missing categories in the Admin tools. Do I need to re-run the script? If so, any other edits to the script since it's already been installed?

Thanks.
If you still don't see the categories, then you still have files missing, simple as that. Make sure you have everything from the "admin/includes/boxes" folder uploaded properly.

And no, the script only needs to be run once. Running it more than once will get in the same boat as these other poor souls.

@Other poor souls - Your problems would largely be rectified by a proper installer, like the one that comes with stock Zen Cart. That was to be part of the next release, but given all my delays I may have to release it without one.

HMG:

I went ahead and tried to re-run the script, keeping in mind the usual issues with duplicate entries for payment types. I rec'd the following note in the admin console and still see nothing for Super Orders other than in Admin --> Configuration --> Super Orders:

ERROR: Cannot ADD column date_completed because it already exists.
ERROR: Cannot ADD column date_cancelled because it already exists.
ERROR: Cannot ADD column balance_due because it already exists.
ERROR: Cannot create table customers_admin_notes because it already exists
ERROR: Cannot create table so_payments because it already exists
ERROR: Cannot create table so_payment_types because it already exists
ERROR: Cannot create table so_purchase_orders because it already exists
ERROR: Cannot create table so_refunds because it already exists
ERROR: Cannot insert configuration_key "MODULE_PAYMENT_PURCHASE_ORDER_STATUS" because it already exists
ERROR: Cannot insert configuration_key "MODULE_PAYMENT_PURCHASE_ORDER_PAYTO" because it already exists
ERROR: Cannot insert configuration_key "MODULE_PAYMENT_PURCHASE_ORDER_SORT_ORDER" because it already exists
ERROR: Cannot insert configuration_key "MODULE_PAYMENT_PURCHASE_ORDER_ZONE" because it already exists
ERROR: Cannot insert configuration_key "MODULE_PAYMENT_PURCHASE_ORDER_ORDER_STATUS_ID" because it already exists
ERROR: Cannot insert configuration_key "AUTO_STATUS_PO" because it already exists
ERROR: Cannot insert configuration_key "AUTO_STATUS_PAYMENT" because it already exists
ERROR: Cannot insert configuration_key "AUTO_STATUS_PO_PAYMENT" because it already exists
ERROR: Cannot insert configuration_key "AUTO_STATUS_REFUND" because it already exists
ERROR: Cannot insert configuration_key "AUTO_COMMENTS_PAYMENT" because it already exists
ERROR: Cannot insert configuration_key "AUTO_COMMENTS_PO_PAYMENT" because it already exists
ERROR: Cannot insert configuration_key "AUTO_COMMENTS_PO" because it already exists
ERROR: Cannot insert configuration_key "AUTO_COMMENTS_REFUND" because it already exists
ERROR: Cannot insert configuration_key "FED_TAX_ID_NUMBER" because it already exists
ERROR: Cannot insert configuration_key "STATUS_ORDER_CANCELLED" because it already exists
ERROR: Cannot insert configuration_key "STATUS_ORDER_COMPLETED" because it already exists
ERROR: Cannot insert configuration_key "STATUS_ORDER_REOPEN" because it already exists
Note: 25 statements ignored. See "upgrade_exceptions" table for additional details.
Same problem as the duplicate payment types, HMG. These are all existent entries, and thus entering them again causes conflicts. I suggest that, instead of running the whole thing, you simply extract the part(s) you need and run it from the SQL box in phpMyAdmin.
NullMind:

how can I reverse the bill to and ship to on the packing slip ?
You'll have to edit admin/super_packingslip.php. Pretty easy edit; you just have to change one word in two lines. The delivery line looks like this...

<td class="main"><?php echo zen_address_format($order->[B]delivery[/B]['format_id'], $order->[B]delivery[/B], 1, '', '<br />'); ?></td>

...and the billing looks like this...

<td class="main"><?php echo zen_address_format($order->[B]customer[/B]['format_id'], $order->[B]billing[/B], 1, '', '<br />'); ?></td>

Swap the two words I have highlighted in green and red with their counterpart in the opposing line.

11 Feb 2008, 2:33 PM
#882
hmg avatar

hmg

New Zenner

Join Date:
Sep 2007
Posts:
33
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

BlindSide:

If you still don't see the categories, then you still have files missing, simple as that. Make sure you have everything from the "admin/includes/boxes" folder uploaded properly.

And no, the script only needs to be run once. Running it more than once will get in the same boat as these other poor souls.

Getting CLOSER! The only thing I am missing now seems to be the PO Payment module. I am unsure if the folder "extra_datafiles" is just a place holder and the file "super_orders_defines.php" belongs in the root of admin/includes.

I'm sorry about all the questions, I didn't see in the directions anything about moving files out of placeholder directories, so pardon me if I misunderstood!

Thanks!

11 Feb 2008, 2:43 PM
#883
hmg avatar

hmg

New Zenner

Join Date:
Sep 2007
Posts:
33
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

HMG:

Getting CLOSER! The only thing I am missing now seems to be the PO Payment module. I am unsure if the folder "extra_datafiles" is just a place holder and the file "super_orders_defines.php" belongs in the root of admin/includes.

I'm sorry about all the questions, I didn't see in the directions anything about moving files out of placeholder directories, so pardon me if I misunderstood!

Thanks!

Screenshot attached so you can see what I mean.

11 Feb 2008, 3:50 PM
#884
hmg avatar

hmg

New Zenner

Join Date:
Sep 2007
Posts:
33
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

HMG:

Screenshot attached so you can see what I mean.

Okay, I think I have the problem solved.

Everything seems to look right, including purchase orders. Now to test! Thanks for all the help, I will be using this module quite a bit, it seems -perfect- for what I need it to do.

-HMG

:clap:

11 Feb 2008, 4:26 PM
#885
blindside avatar

blindside

Totally Zenned

Join Date:
Sep 2004
Posts:
1,237
Plugin Contributions:
1

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

Glad you got it working. And for anyone who's having the same problem, let me make it clear: you must upload all the files in the included directory structure; that's what allows them to drop into the proper places on your server.

11 Feb 2008, 5:18 PM
#886
cryogenicz avatar

cryogenicz

New Zenner

Join Date:
Apr 2007
Posts:
12
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

I installed this for the first time last night, and couldn't get everything to show up in admin.

I uploaded the files twice and I checked the folder/files for accuracy, but I still cant see this:

Admin --> Configuration --> Super Orders:

/mycopath.com/html/admin/includes/boxes/extra_boxes

has the following files:
super_orders_customers_dhtml.php
super_orders_localization_dhtml.php
super_orders_reports_dhtml.php

am I missing any other files? are there files from the previous install that weren't included in the new file set?

Thanks!

-Graham

11 Feb 2008, 7:04 PM
#887
blindside avatar

blindside

Totally Zenned

Join Date:
Sep 2004
Posts:
1,237
Plugin Contributions:
1

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

The configuration entries have nothing to do with the files, they are all entries in the DB, which means you probably didn't run the SQL file. Run the included SQL file over your DB and those entries will appear.

11 Feb 2008, 8:06 PM
#888
cryogenicz avatar

cryogenicz

New Zenner

Join Date:
Apr 2007
Posts:
12
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

I have run the sql file, and the other super order links are there... but not the admin.

-Graham

11 Feb 2008, 8:35 PM
#889
cryogenicz avatar

cryogenicz

New Zenner

Join Date:
Apr 2007
Posts:
12
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

finally!!!

I did as you suggested and started to manually enter each section from the sql file, till everything said it was either entered, or was duplicated already.. and it worked!!

Thanks guys!

I love this module, it should really help me get work done faster!

-Graham

13 Feb 2008, 4:26 PM
#890
jamie2k avatar

jamie2k

New Zenner

Join Date:
Oct 2006
Location:
Suffolk UK
Posts:
55
Plugin Contributions:
1

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

Hi Folks,

I have this mod installed on my multi site, works fine :)

Just wanted to know if there is a way of adding a third option when closing order.

Scenario:-

I have an order that is not processed by my own order processing department...

They would like to have an option which was clickable like COMPLETED or CANCELLED - but was OUTSOURCED

This would need another coloured button and the functionality to make this button update the status of the order,

Please help :)

Jamie

17 Feb 2008, 1:57 PM
#891
pinetreecandles avatar

pinetreecandles

Zen Follower

Join Date:
Feb 2008
Location:
West Virginia
Posts:
135
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

Hello-

New user to Zen Cart. Moving from oscommerce. I just installed the Super Orders and I have to say it's very nice with awesome features. Thank You!

During testing I found that when I enter something in the comments section of the order (in admin) and click update it works as intended and displays the comments in admin like so:

Thank you for shopping with us.

Your order has been received and is being processed. In stock orders normally ship within 1-2 business days.

Note* Remember, if your candles are made to order, please allow 2 - 5 Business days for order to be filled.

We do not make partial shipments. We will send your order once your entire order is complete.

Best Regards,

However, this is how it looks to the customer when viewing Account History Info for that order:

 	Thank you for shopping with us.<br />
<br />
Your order has been received and is being processed. In stock orders normally ship within 1-2 business days.<br />
<br />
<br />
Note* Remember, if your candles are made to order, please allow 2 - 5 Business days for order to be filled.<br />
<br />
We do not make partial shipments. We will send your order once your entire order is complete.<br />
<br />
Best Regards,<br />

I used no html when I entered the text in the comments section so I'm not sure where that is coming from.

Anyone have any suggestions?

18 Feb 2008, 2:08 PM
#892
tomcz avatar

tomcz

New Zenner

Join Date:
Feb 2007
Location:
Prague
Posts:
53
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

Hi, I have got thius problem with SO 2.0. I have some discounted items using Katalog - Speicials.
If I edit an order and add some of these discounted items to the order I am editing that the regular price is added with the product to the order.
Customers were unhappy with this :cool: so I must to check manually all items added to the order and find the price without TAX and manaully write it to the order.
Any idea how to solve this problem to add automatically the discounted price to the order with the added items ?

18 Feb 2008, 6:52 PM
#893
vhjdb avatar

vhjdb

New Zenner

Join Date:
Dec 2007
Posts:
19
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

Does SO 2.0 support refunds from PayPal Website Payments Pro? I tried using full refund in Admin section and also got replied from PyaPal IPN with confirmation but it did not show-up in SO line. Am I doing something wrong?

18 Feb 2008, 7:24 PM
#894
vhjdb avatar

vhjdb

New Zenner

Join Date:
Dec 2007
Posts:
19
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

I got my answer from Blindside's previous post

19 Feb 2008, 5:11 PM
#895
admcompa avatar

admcompa

New Zenner

Join Date:
Mar 2007
Posts:
44
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

I installed Super Orders and rand into one problem.When a customer puts a order in I do not receive the order confirmation in my email anymore. Any ideas? Thanks

21 Feb 2008, 6:46 PM
#896
admcompa avatar

admcompa

New Zenner

Join Date:
Mar 2007
Posts:
44
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

Update. The email issue only has affected my paypal orders. I received order confirmations for my vm credit card orders but not paypal. Everything worked great before installing super orders. Any idea what files were changed? Thanks

Doug

22 Feb 2008, 7:47 AM
#897
evotactical avatar

evotactical

New Zenner

Join Date:
Dec 2007
Posts:
25
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

Hi this is great little mod, thank you for your contribution. I'm running Zencart v.1.3.8a and it seems to work properly.

However I do have a question.

How come the Edit Products function only allows you to move items to another split order?

I thought you are able to edit the quantity or delete items from the order itself?

22 Feb 2008, 1:33 PM
#898
pinetreecandles avatar

pinetreecandles

Zen Follower

Join Date:
Feb 2008
Location:
West Virginia
Posts:
135
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

evotactical:

Hi this is great little mod, thank you for your contribution. I'm running Zencart v.1.3.8a and it seems to work properly.

However I do have a question.

How come the Edit Products function only allows you to move items to another split order?

I thought you are able to edit the quantity or delete items from the order itself?

From what I have read some people use the order edit along with this to do what this one doesn't do or do correctly. I haven't tried both so don't know for sure, but if you read through all the threads I think it's in here.

22 Feb 2008, 11:03 PM
#899
mauryg avatar

mauryg

Zen Follower

Join Date:
Jul 2006
Posts:
213
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

The Edit Orders mod will let you change quantities of products in an order, or delete a product by setting the quantity to '0'. But there have been problems reported when used together with Super Orders. The totals shown in SO do not update automatically. You have to do an 'edit products' in SO and then, without making any changes, do an 'update'. If all you need to do is delete a product from an order, you can split the order in SO and then delete the split order. Of course, that throws off your order numbering system, creating all the deleted orders. and may confuse your customer.

23 Feb 2008, 12:12 AM
#900
mauryg avatar

mauryg

Zen Follower

Join Date:
Jul 2006
Posts:
213
Plugin Contributions:
0

Re: OLD Super Orders 2.0 (See v3.0 thread instead)

I am writing a manual to tell employees how to process internet orders. Evotactical's question forced me to think about the following very likely scenario:
A customer orders e.g. 3 widgets and pays with a credit card or PayPal. You only have 2 in stock to ship and need to backorder one. :unsure:

This is not the same as having to backorder a separate item. You can't SPLIT the QUANTITY in either the Super Orders or Edit Orders mod. You can only change the quantity (EO) or split all of the widgets to a different order (SO). We will assume that, like most good shops, you promise not to charge the customer for the backordered item until it is shipped. You use "Authorization", not "Capture" for your payment gateway transaction so you can capture only the funds for the items you shipped and get the rest later when you ship the balance.

One possibility is use Edit Orders to reduce the quantity on the original order and then CREATE a new order for the customer for the back ordered item. Use the Encrypted Master Password mod to login to the customer account with your administrator password. The shipping can be set to FREE shipping since you captured the shipping charges with the original shipment. The customer should not have to pay extra shipping charges just because you didn't have the item in stock.

But the tricky part comes with the PAYMENT module. The problem is how do you complete the NEW order you created if the customer already paid for it. From the payment gateway, you can obtain the full credit card number and expiration date. I assume you do NOT store them on YOUR server for security reasons. So you can create the CC charge for the NEW order AS IF the customer had done it. (In PayPal you can simply create a new authorization but you still have to bypass the payment module in ZenCart because you don't have the customers password for PayPal.)

For the original shipment, in the gateway, you reduce the capture amount to the items you shipped (plus shipping and tax) and capture that as the FULL amount for the original order. Now you have a second new order for the backordered quantity and the correct amount held in the authorization queue. Whatever you do, you must notify your customer that you are making these changes so they will understand the charges on their credit card bill.

If someone has a different way to handle this, please let me know.